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New and Changed Information

• New and Changed Information, page xv

New and Changed Information
Where DocumentedDateDescription of Change

September,
2015

Parameter information for Client configuration file
moved to the Cisco Jabber 11.0 Parameters Reference
Guide.

September,
2015

This document applies to Cisco Jabber releases 11.0
and 11.1.

Jabber to Jabber Call, on page 172

IBM Notes Contact Search and
Calendar Integration, on page 207

September,
2015

New feature descriptions were added to the Cisco
Jabber Options chapter.

September,
2015

Reference information moved from the Integrate with
Directory Sources chapter into a Federation chapter in
the Cisco Jabber 11.0 Planning Guide.

August 5, 2015New parameters were added to the Configure Client
chapter for the 11.0(1) release.

June 18, 2015Some reference information was moved from the
Service Discovery chapter into the corresponding
chapter in the Cisco Jabber 11.0 Planning Guide.
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Where DocumentedDateDescription of Change

Cisco Jabber 11.0 Features, on
page 169

Enterprise Groups for Cisco
Unified CommunicationsManager
IMAnd Presence Service, on page
176

Far End Camera Control (FECC),
on page 178

Configure Bridge Escalations, on
page 178

Configure Collaboration Meeting
Rooms, on page 178

Configure Personal Rooms, on
page 179

Persistent Chat Room Support, on
page 212

June 18, 2015New feature descriptions were added to the Cisco
Jabber Options chapter.

June 18, 2015New parameters were added to the Configure Client
chapter

Setting up System SIP Parameters,
on page 47

June 18, 2015Updates were made to the topic on setting up SIP
parameters for Cisco Jabber mobile clients.

Common Installation Arguments,
on page 144

Create Configuration URL, on
page 19

June 18, 2015New installation arguments were added to the Install
Client chapter for Cisco Jabber for Windows, and new
Configuration URLs were added to the Service
Discovery chapter for Cisco Jabber for Mac, Android,
and iPhone and iPad.

June 18, 2015New directory integration parameters were added to
EDI and BDI content for the Enterprise Groups feature
in the chapter on Integrate with Directory Sources.

Mobile Configuration Using
Enterprise Mobility Management,
on page 22

June 18, 2015The chapter on Service Discovery was updated to
include information on Mobile Configuration using
Enterprise Mobility Management.

June 18, 2015Other changes were made throughout the guide to
resolve caveats.
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C H A P T E R  1
Jabber Overview

• Purpose of this Guide, page 1

• About Cisco Jabber, page 1

Purpose of this Guide
The Cisco Jabber Deployment and Installation Guide includes the following task-based information required
to deploy and install Cisco Jabber:

• Configuration and installation workflows that outline the processes to configure and install on-premises
or cloud deployments.

• How to configure the various services that the Cisco Jabber client interacts with, such as IM and Presence
Service, Voice and Video Communication, Visual Voicemail, and Conferencing.

• How to configure directory integration, certificate validation, and service discovery.

• How to install the clients.

Before you deploy and install Cisco Jabber, see the Cisco Jabber Planning Guide at http://www.cisco.com/
c/en/us/support/unified-communications/jabber-windows/products-installation-guides-list.html to determine
the deployment options that best suit your business needs.

About Cisco Jabber
Cisco Jabber is a suite of Unified Communications applications that allow seamless interaction with your
contacts from anywhere. Cisco Jabber offers IM, presence, audio and video calling, voicemail, and conferencing.

The applications in the Cisco Jabber family of products are:

• Cisco Jabber for Android

• Cisco Jabber for iPhone and iPad

• Cisco Jabber for Mac

• Cisco Jabber for Windows
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For more information about the Cisco Jabber suite of products, see http://www.cisco.com/go/jabber.
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C H A P T E R  2
Configuration and Installation Workflows

• Deployment and Installation Workflow for an On-Premises Deployment, page 3

• Deployment and Installation Workflow for Phone Mode, page 4

• Deployment and Installation Workflow for a Cloud-Based Deployment, page 5

Deployment and Installation Workflow for an On-Premises
Deployment

Procedure

PurposeCommand or Action

Read the Cisco Jabber Planning Guide located at http://
www.cisco.com/c/en/us/support/unified-communications/
jabber-windows/products-installation-guides-list.html.

Step 1 • Choose your deployment
scenario.

• Review requirements to
confirm that you meet
them.

• Review contact sources
to determine which
contact source you will
use.

Configure Directory Integration for an On-Premises
Deployment, on page 7.

Step 2

Certificates are required for
each service to which the
Jabber clients connect.

Configure Certificates for an On-Premises Deployment, on
page 13.

Step 3

Service Discovery, on page 19.Step 4

Configure a Service Profile, on page 31.Step 5
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PurposeCommand or Action

Configure IM and Presence Service for an On-Premises
Deployment, on page 33.

Step 6

Configure Voice and Video Communications for
On-Premises Deployments, on page 43.

Step 7

Complete one of the following:Step 8

• Configure Voicemail for an On-Premises Deployment
with Cisco Unified CommunicationsManager Release
9.x and Later, on page 67.

• Configure Voicemail for an On-Premises Deployment
with Cisco Unified CommunicationsManager Release
8.6, on page 68.

Configure Conferencing for an On-Premises Deployment,
on page 81.

Step 9

Configure Client, on page 93.Step 10

Install Client, on page 135.Step 11

Deployment and Installation Workflow for Phone Mode
Procedure

PurposeCommand or Action

Read the Cisco Jabber Planning Guide located at http://
www.cisco.com/c/en/us/support/unified-communications/
jabber-windows/products-installation-guides-list.html.

Step 1 • Choose your deployment
scenario.

• Review requirements to
confirm that you meet
them.

• Review contact sources
to determine which
contact source you will
use.

Configure Directory Integration for an On-Premises
Deployment, on page 7.

Step 2

Certificates are required for
each service to which the
Jabber clients connect.

Configure Certificates for an On-Premises Deployment, on
page 13.

Step 3

Service Discovery, on page 19.Step 4
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PurposeCommand or Action

Configure a Service Profile, on page 31.Step 5

Configure Voice and Video Communications for
On-Premises Deployments, on page 43.

Step 6

Complete one of the following:Step 7

• Configure Voicemail for an On-Premises Deployment
with Cisco Unified CommunicationsManager Release
9.x and Later, on page 67.

• Configure Voicemail for an On-Premises Deployment
with Cisco Unified CommunicationsManager Release
8.6, on page 68.

Configure Conferencing for an On-Premises Deployment,
on page 81.

Step 8

Configure Conferencing, on page 81Step 9

Configure Client, on page 93.Step 10

Install Client, on page 135.Step 11

Deployment and Installation Workflow for a Cloud-Based
Deployment

Procedure

PurposeCommand or Action

Read the Cisco Jabber Planning Guide located at http://
www.cisco.com/c/en/us/support/unified-communications/
jabber-windows/products-installation-guides-list.html.

Step 1 • Choose your
deployment scenario.

• Review requirements to
confirm that you meet
them.

• Review contact sources
to determine which
contact source you will
use.

Configure Directory Integration, on page 7Step 2

Set Up Certificate Validation, on page 13Step 3

Service Discovery, on page 19Step 4
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PurposeCommand or Action

Configure a Service Profile, on page 31Step 5

Configure IM and Presence Service for Cloud-Based
Deployments, on page 40

Step 6

Configure Voice and Video Communication for
Cloud-Based Deployments, on page 65

Step 7

Configure Voicemail for Cloud-Based Deployments, on
page 79

Step 8

Configure Conferencing for a Cloud-Based Deployment
using Cisco WebEx Meeting Center, on page 90

Step 9

Configure Client, on page 93Step 10

Install Client, on page 135Step 11
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C H A P T E R  3
Configure Directory Integration

• Configure Directory Integration for an On-Premises Deployment, page 7

• Configure Directory Integration for Cloud-Based Deployments, page 12

Configure Directory Integration for an On-Premises Deployment
Procedure

PurposeCommand or Action

To replicate contact data to Cisco Unified
Communications Manager.

Enable Synchronization, on page 7.Step 1

Only for Cisco Unified Communications Manager
IM and Presence Service release 10.x or later.

Configure IMAddress Scheme, on page
8

Step 2

Populate the user ID and directory URI from an
attribute in the directory.

Populate User ID and Directory URI,
on page 9

Step 3

Synchronize CiscoUnified CommunicationsManager
with the directory server.

Perform Synchronization, on page 11Step 4

Configure Cisco Unified Communications Manager
to authenticate with the directory server

Authenticate with the Directory Server,
on page 11.

Step 5

Enable Synchronization
To ensure that contact data in your directory server is replicated to Cisco Unified Communications Manager,
you must synchronize with the directory server. Before you can synchronize with the directory server, you
must enable synchronization.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > LDAP > LDAP System.

The LDAP System Configuration window opens.

Step 3 Locate the LDAP System Information section.
Step 4 Select Enable Synchronizing from LDAP Server.
Step 5 Select the type of directory server from which you are synchronizing data from the LDAP Server Type

drop-down list.

What to Do Next

Specify an LDAP attribute for the user ID.

Configure IM Address Scheme
This feature is supported on Cisco Unified Communications Manager IM and Presence Service release 10.x
or later. For versions of Cisco Unified Communications Manager IM and Presence Service release 9.x and
earlier the default IM address scheme used is UserID@[Default Domain].

Procedure

Step 1 Select the IMAddress Scheme in theAdvanced Presence Settings section of Cisco Unified Communications
Manager IM & Presence Administration:

• UserID@[Default Domain]
If you use the UserID, ensure that you configure a default domain. For example, services must be named
cups.com and not cups.

• Directory URI.

For more information on configuring the IM Address Scheme, see the Configuration and Administration of
IM and Presence Service on Cisco Unified Communications Manager guide.

Step 2 Select the required mapping in the Standard User Fields to Be Synchronized section of the Cisco Unified
Communications Manager Administration.

• User ID mapped to an LDAP field, the default is sAMAccountName.

• Directory URI mapped to eithermail or msRTCSIP-primaryuseraddress.

For more information on mapping the fields, see the Populate User ID and Directory URI section.
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Populate User ID and Directory URI
When you synchronize your LDAP directory server with Cisco Unified Communications Manager, you can
populate the end user configuration tables in both the Cisco Unified Communications Manager and the Cisco
Unified Communications Manager IM and Presence Service databases with attributes that contain values for
the following:

• User ID— You must specify a value for the user ID on Cisco Unified Communications Manager. This
value is required for the default IM address scheme and for users to sign in. The default value is
sAMAccountName.

• Directory URI— You should specify a value for the directory URI if you plan to:

• Enable URI dialing in Cisco Jabber.

• Use the directory URI address scheme on CiscoUnified CommunicationsManager IM and Presence
Service version 10 and higher.

When Cisco Unified Communications Manager synchronizes with the directory source, it retrieves the values
for the directory URI and user ID and populates them in the end user configuration table in the Cisco Unified
Communications Manager database.

The Cisco Unified Communications Manager database then synchronizes with the Cisco Unified
Communications Manager IM and Presence Service database. As a result, the values for the directory URI
and user ID are populated in the end user configuration table in the Cisco Unified Communications Manager
IM and Presence Service database.

Specify an LDAP Attribute for the User ID
When you synchronize from your directory source to Cisco Unified Communications Manager, you can
populate the user ID from an attribute in the directory. The default attribute that holds the user ID is
sAMAccountName.
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Procedure

Step 1 Locate the LDAP Attribute for User ID drop-down list on the LDAP System Configuration window.
Step 2 Specify an attribute for the user ID as appropriate and then select Save.

If the attribute for the user ID is other than sAMAccountName and you are using the default
IM address scheme in Cisco Unified Communications Manager IM and Presence Service, you
must specify the attribute as the value for the parameter in your client configuration file as
follows:

The EDI parameter is UserAccountName.
<UserAccountName>attribute-name</UserAccountName>

The BDI parameter is BDIUserAccountName.
<BDIUserAccountName>attribute-name</BDIUserAccountName>

If you do not specify the attribute in your configuration, and the attribute is other than
sAMAccountName, the client cannot resolve contacts in your directory. As a result, users do
not get presence and cannot send or receive instant messages.

Important

Specify an LDAP Attribute for the Directory URI
OnCisco Unified CommunicationsManager release 9.0(1) and later, you can populate the directory URI from
an attribute in the directory.

Before You Begin

Enable Synchronization.

Procedure

Step 1 Select System > LDAP > LDAP Directory.
Step 2 Select the appropriate LDAP directory or select Add New to add an LDAP directory.
Step 3 Locate the Standard User Fields To Be Synchronized section.
Step 4 Select one of the following LDAP attributes from the Directory URI drop-down list:

• msRTCSIP-primaryuseraddress—This attribute is populated in the AD when Microsoft Lync or
Microsoft OCS are used. This is the default attribute.

• mail

Step 5 Select Save.
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Perform Synchronization
After you add a directory server and specify the required parameters, you can synchronize Cisco Unified
Communications Manager with the directory server.

Before You Begin

If your environment includes a presence server, you should ensure the following feature service is activated
and started before you synchronize with the directory server:

• Cisco Unified Presence— Cisco UP Sync Agent

• Cisco Unified Communications Manager IM and Presence Service— Cisco Sync Agent

This service keeps data synchronized between the presence server and CiscoUnified CommunicationsManager.
When you perform the synchronization with your directory server, Cisco Unified Communications Manager
then synchronizes the data with the presence server. However, theCisco Sync Agent service must be activated
and started.

Procedure

Step 1 Select System > LDAP > LDAP Directory.
Step 2 Select Add New.

The LDAP Directory window opens.

Step 3 Specify the required details on the LDAP Directory window.
See theCisco Unified CommunicationsManager Administration Guide for more information about the values
and formats you can specify.

Step 4 Create an LDAPDirectory Synchronization Schedule to ensure that your information is synchronized regularly.
Step 5 Select Save.
Step 6 Select Perform Full Sync Now.

The amount of time it takes for the synchronization process to complete depends on the number of
users that exist in your directory. If you synchronize a large directory with thousands of users, you
should expect the process to take some time.

Note

User data from your directory server is synchronized to the Cisco Unified CommunicationsManager database.
Cisco Unified Communications Manager then synchronizes the user data to the presence server database.

Authenticate with the Directory Server
You should configure Cisco Unified Communications Manager to authenticate with the directory server.
When users sign in to the client, the presence server routes that authentication to Cisco Unified Communications
Manager. Cisco Unified Communications Manager then proxies that authentication to the directory server.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > LDAP > LDAP Authentication.
Step 3 Select Use LDAP Authentication for End Users.
Step 4 Specify LDAP credentials and a user search base as appropriate.

See the Cisco Unified Communications Manager Administration Guide for information about the fields on
the LDAP Authentication window.

Step 5 Select Save.

Configure Directory Integration for Cloud-Based Deployments
Procedure

PurposeCommand or Action

Review the topics.Review Directory Integration.Step 1

Configure your organization
information.

See Understanding the Configuration Tab.Step 2

Create and provision users.See Overview of User Management.Step 3

Add Directory Groups, on page 12.Step 4

Add Directory Groups
Directory groups, or enterprise groups, provide contact groups that administrators define for users.

Procedure

Step 1 Set up directory integration.
Step 2 Define your directory groups in a comma-separated values (.csv) file.
Step 3 Import your directory groups using the Cisco WebEx Administration Tool.

Related Topics

Directory Integration
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C H A P T E R  4
Set Up Certificate Validation

• Configure Certificates for an On-Premises Deployment, page 13

• Certificate Validation for Cloud Deployments, page 15

Configure Certificates for an On-Premises Deployment
Certificates are required for each service to which the Jabber clients connect.

Procedure

PurposeCommand or Action

For more information, see the Security Configuration
on IM and Presence Service chapter in Configuration

If you have Cisco Unified Presence or
Cisco Unified Communications Manager
IM and Presence Service, download the

Step 1

and Administration of IM and Presence Service on
Cisco Unified Communications Manager.applicable HTTP (tomcat) and XMPP

certificates.

For more information, see the Cisco Unified
Communications Manager Security Guide and the

Download the HTTPS (tomcat) certificate
for Cisco Unified Communications
Manager and Cisco Unity Connection.

Step 2

Cisco Unified Communications Operating System
Administration Guide found here.

For more information, see the Cisco WebEx Meetings
Server Administration Guide found here.

Download the HTTP (tomcat) for Cisco
WebEx Meetings Server.

Step 3

For more information, see Configuring Certificates
on Cisco VCS Expressway.

If you plan to configure remote access,
download the Cisco VCS Expressway and
Cisco Expressway-E Server certificate. The

Step 4

Server certificate is used for both HTTP
and XMPP.

Generate a Certificate Signing Request
(CSR).

Step 5

If you use a multiserver SAN, you only need to upload
a certificate to the service once per cluster per tomcat

Upload the certificate to the service.Step 6
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PurposeCommand or Action

certificate and once per cluster per XMPP certificate.
If you do not use a multiserver SAN, then you must
upload the certificate to the service for every Cisco
Unified Communications Manager node.

To ensure that certificate validation occurs without
users receiving a prompt to accept or decline

Deploy CACertificates to Clients, on page
14

Step 7

certificates, deploy certificates to the local certificate
store of the clients.

Deploy CA Certificates to Clients
To ensure that certificate validation occurs without users receiving a prompt to accept or decline certificates,
deploy certificates to the local certificate store of the endpoint clients.

If you use a well-known public CA, then the CA certificate may already exist on the client certificate store
or keychain. If so, you need not deploy CA certificates to the clients.

If the CA certificate is not already on the client certificate store or keychain, then deploy the CA certificate
to the clients.

Then we recommendIf your deployment size is

That you use a certificate deployment tool, such as Group
Policy or a certificate deployment management application.

To a large number of local machines

That you manually deploy the CA certificates.To a smaller number of local machines

Manually Deploy CA Certificates to Cisco Jabber for Windows Clients

Procedure

Step 1 Make the CA certificate available to the Cisco Jabber for Windows client machine.
Step 2 From the Windows machine, open the certificate file.
Step 3 Install the certificate and then select Next.
Step 4 Select Place all certificates in the following store, then select Browse.
Step 5 Select the Trusted Root Certification Authorities store.

When you finish the wizard, a message is displayed to verify successful certificate import.
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What to Do Next

Verify that the certificate is installed in the correct certificate store by opening the Windows Certificate
Manager tool. Browse to Trusted Root Certification Authorites > Certificates. The CA root certificate is
listed in the certificate store.

Manually Deploy CA Certificates to Cisco Jabber for Mac Clients

Procedure

Step 1 Make the CA certificate available to the Cisco Jabber for Mac client machine.
Step 2 From the Mac machine, open the certificate file.
Step 3 Add to the login keychain for the current user only, then select Add.

What to Do Next

Verify that the certificate is installed in the correct keychain by opening the Keychain Access Tool and selecting
Certificates. The CA root certificate is listed in the keychain.

Manually Deploy CA Certificates to Mobile Clients
To deploy the CA certificates to an iOS client, you need a certificate deployment management application.
You can email the CA certificate to users, or make the certificates available on a web server for users to access.
Users can download and install the certificate using the certificate deployment management tool.

However, Jabber for Android does not have a certificate management tool, you must use the following
procedure.

Procedure

Step 1 Download the CA certificate to the device.
Step 2 Tap the device Settings > Security > Install from device storage and follow the instructions.

Certificate Validation for Cloud Deployments
Cisco WebEx Messenger and Cisco WebEx Meeting Center present the following certificates to the client by
default:

• CAS

• WAPI
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Cisco WebEx certificates are signed by a public Certificate Authority (CA). Cisco Jabber validates these
certificates to establish secure connections with cloud-based services.

Note

Cisco Jabber validates the following XMPP certificates received from Cisco WebEx Messenger. If these
certificates are not included in your operating system, you must provide them.

• VeriSign Class 3 Public Primary Certification Authority - G5— This certificate is stored in the Trusted
Root Certificate Authority

• VeriSign Class 3 Secure Server CA - G3—T his certificate validates the Webex Messenger server
identity and is stored in the Intermediate Certificate Authority.

For more information about root certificates for Cisco Jabber for Windows, see http://www.identrust.co.uk/
certificates/trustid/install-nes36.html.

For more information about root certificates for Cisco Jabber for Mac, see http://support.apple.com.

Update Profile Photo URLs
In cloud-based deployments, Cisco WebEx assigns unique URLs to profile photos when you add or import
users. When Cisco Jabber resolves contact information, it retrieves the profile photo from Cisco WebEx at
the URL where the photo is hosted.

Profile photo URLs use HTTP Secure (https://server_name/) and present certificates to the client.
If the server name in the URL is:

• A fully qualified domain name (FQDN) that contains the CiscoWebEx domain— The client can validate
the web server that is hosting the profile photo against the Cisco WebEx certificate.

• An IP address— The client cannot validate the web server that is hosting the profile photo against the
Cisco WebEx certificate. In this case, the client prompts users to accept certificates whenever they look
up contacts with an IP address in their profile photo URLs.

Important •We recommend that you update all profile photo URLs that contain an IP address as the server name.
Replace the IP address with the FQDN that contains the Cisco WebEx domain to ensure that the
client does not prompt users to accept certificates.

•When you update a photo, the photo can take up to 24 hours to refresh in the client.

The following steps describe how to update profile photo URLs. Refer to the appropriate Cisco WebEx
documentation for detailed instructions.
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Procedure

Step 1 Export user contact data in CSV file format with the Cisco WebEx Administration Tool.
Step 2 In the userProfilePhotoURL field, replace IP addresses with the Cisco WebEx domain.
Step 3 Save the CSV file.
Step 4 Import the CSV file with the Cisco WebEx Administration Tool.
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C H A P T E R  5
Service Discovery

• Configuration URL Workflow, page 19

• Mobile Configuration Using Enterprise Mobility Management, page 22

• Manual Connection Settings, page 23

• Installer Switches: Cisco Jabber for Windows, page 26

Configuration URL Workflow
Procedure

PurposeCommand or Action

Create Configuration URL, on page 19Step 1

Provide Users with Configuration URL from a Website, on page
22

Step 2

Create Configuration URL
To enable users to launch Cisco Jabber without having to manually enter service discovery information, create
and distribute a configuration URL to users.

You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the
link to a website.

You can include and specify the following parameters in the URL:

• ServicesDomain—Required. Every configuration URLmust include the domain of the IM and presence
server that Cisco Jabber needs for service discovery.

• VoiceServiceDomain—Required only if you deploy a hybrid cloud-based architecture where the domain
of the IM and presence server differs from the domain of the voice server. You must set this parameter
to ensure that Cisco Jabber can discover voice services.
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• ServiceDiscoveryExcludedServices— Optional. You can exclude any of the following services from
the service discovery process:

◦WEBEX—When you set this value, the client:

• Does not perform CAS lookup

• Looks for:

◦_cisco-uds

◦_cuplogin

◦_collab-edge

◦CUCM—When you set this value, the client:

• Does not look for _cisco-uds

• Looks for:

◦_cuplogin

◦_collab-edge

◦CUP—When you set this value, the client:

• Does not look for _cuplogin

• Looks for:

◦_cisco-uds

◦_collab-edge

You can specify multiple, comma-separated values to exclude multiple services.

If you exclude all three services, the client does not perform service discovery and prompts the user to
manually enter connection settings.

• ServicesDomainSsoEmailPrompt—Optional. Specifies whether the user is shown the email prompt for
the purposes of determining their home cluster.

• EnablePRTEncryption—Optional. Specifies that the PRT file is encrypted. Applies to Cisco Jabber for
Mac only.

◦true

◦false

• PRTCertificateName—Optional. Specifies the name of the certificate. Applies to Cisco Jabber for Mac
only.

• InvalidCertificateBehavior—Optional. Specifies the client behavior for invalid certificates.

◦RejectAndNotify—A warning dialog displays and the client doesn't load.
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◦PromptPerSession—A warning dialog displays and the user can accept or reject the invalid
certificate.

• PRTCertificateUrl—Specifies the name of a certificate with a public key in the trusted root certificate
store. Applies to Cisco Jabber for iPhone and iPad and Cisco Jabber for Android.

• Telephony_Enabled— Specifies whether the user has the phone capability or not. The default is true.

• ForceLaunchBrowser— Used to force user to use the external browser.

ForceLaunchBrowser is used for client certificate deployments and for devices with
Android OS below 5.0.

Note

Create the configuration URL in the following format:
ciscojabber://provision?ServicesDomain=<domain_for_service_discover>
&VoiceServicesDomain=<domain_for_voice_services>
&ServiceDiscoveryExcludedServices=<services_to_exclude_from_service_discover>
&ServicesDomainSsoEmailPrompt=<ON/OFF>

The parameters are case sensitive. When you create the configuration URL, you must use the following
capitalization:

Note

• ServicesDomain

• VoiceServicesDomain

• ServiceDiscoveryExcludedServices

• ServicesDomainSsoEmailPrompt

• EnablePRTEncryption

• PRTCertificateName

• InvalidCertificateBehavior

Examples

• ciscojabber://provision?ServicesDomain=cisco.com
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• ciscojabber://provision?ServicesDomain=cisco.com
&VoiceServicesDomain=alphauk.cisco.com

• ciscojabber://provision?ServicesDomain=service_domain
&VoiceServicesDomain=voiceservice_domain&ServiceDiscoveryExcludedServices=WEBEX

• ciscojabber://provision?ServicesDomain=cisco.com
&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP

• ciscojabber://provision?ServicesDomain=cisco.com
&VoiceServicesDomain=alphauk.cisco.com&ServiceDiscoveryExcludedServices=CUCM,CUP
&ServicesDomainSsoEmailPrompt=OFF

Provide Users with Configuration URL from a Website
You can provide a configuration URL link to users by emailing the link to the user directly, or by posting the
link to a website.

Due to a limitation of the Android operating system, Cisco Jabber for Android users can encounter an
issue if they open the configuration URL directly from an Android application. To work around this issue,
we recommend that you distribute your configuration URL link using a website.

Note

If you want to use the website explore option for URL provisioning, we recommended you to use Mozilla
Firefox.

Use the following procedure to distribute the link from a website.

Procedure

Step 1 Create an internal web page that includes the configuration URL as an HTML hyperlink.
Step 2 Email the link to the internal web page to users.

In the email message, instruct users to perform the following steps:

1 Install the client.

2 Click the link in the email message to open the internal web page.

3 Click the link on the internal web page to configure the client.

Mobile Configuration Using Enterprise Mobility Management
Before using Enterprise Mobility Management (EMM), ensure:

• The EMM vendor supports Android for Work or Apple Managed App Configuration.

• Android devices have Android OS 5.0 or later and iOS devices have iOS 8.0 or later.

Configure Cisco Jabber using EMM on Cisco Jabber for Android and Cisco Jabber for iPhone and iPad. Use
EMM to perform all configurations that you do using URL configuration. For more information on setting
up EMM, refer to the instructions for administrators provided by the EMM provider.
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Supported EMM software:

• Airwatch by VMware

Manual Connection Settings
Manual connection settings provide a fallback mechanism when Service Discovery is not used.

When you start Cisco Jabber, you can specify the authenticator and server address in the Advanced settings
window. The client caches the server address to the local application configuration that loads on subsequent
starts.

Cisco Jabber prompts users to enter these advanced settings on the initial start as follows:

• On-Premises with Cisco Unified Communications Manager release 9.x and Later— If the client cannot
get the authenticator and server addresses from the service profile.

• Cloud-Based or On-Premises with Cisco Unified Communications Manager release 8.x— If you do
not set the authenticator in the bootstrap file. The client also prompts users to enter server addresses in
the Advanced settings window if you do not set server addresses in the bootstrap file or with SRV
records.

Settings that you enter in the Advanced settings window take priority over any other sources including SRV
records and bootstrap settings.

If you select eitherCisco IM&Presence orCisco CommunicationsManager 8.xoptions, the client retrieves
UC services from Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence
Service. The client does not use service profiles or SSO discovery.

Automatic Connection Setting for Service Discovery
Users can select the Automatic option in the Advanced settings window to discover servers automatically.

The Automatic option allows users change from manually setting the service connection details to using
service discovery. For example, on the initial launch, you manually set the authenticator and specify a server
address in the Advanced settings window.

The client always checks the cache for manual settings. The manual settings take higher priority over SRV
records, and for Cisco Jabber for Windows, the bootstrap file. For this reason, if you decide to deploy SRV
records and use service discovery, you override the manual settings from the initial launch.

Manual Connection Settings for On-Premises Deployments
Users can set Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service
as the authenticator and specify the server address in the Advanced settings window.

You can automatically set the default server address with the _cuplogin SRV record.Remember

The following diagram illustrates how the client uses manual connection settings in on-premises deployments:
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1 Users manually enter connection settings in the Advanced settings window.

2 The client authenticates to Cisco Unified Presence or Cisco Unified Communications Manager IM and
Presence Service.

3 The client retrieves service profiles from the presence server.

Manual Connection Settings for On-Premises Deployments in Phone Mode
Users can set Cisco Unified Communications Manager as the authenticator and specify the following server
addresses in the Advanced settings window:

• TFTP server

• CCMCIP server

• CTI server (Cisco Jabber for Windows and Cisco Jabber for Mac)

The following diagram illustrates how the client uses manual connection settings in phone mode deployments:
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1 Users manually enter connection settings in the Advanced settings window.

2 The client authenticates to Cisco Unified Communications Manager and gets configuration.

3 The client retrieves device and client configuration.

Manual Connection Settings for Cloud-Based Deployments
Users can set the Cisco WebEx Messenger service as the authenticator and specify the CAS URL for login
in the Advanced settings window.

The following diagram illustrates how the client uses manual connection settings in cloud-based deployments:
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1 Users manually enter connection settings in the Advanced settings window.

2 The client authenticates to the Cisco WebEx Messenger service.

3 The client retrieves configuration and services.

Installer Switches: Cisco Jabber for Windows
When you install Cisco Jabber, you can specify the authenticator and server addresses. The installer saves
these details to a bootstrap file. When users launch the client for the first time, it reads the bootstrap file. The
bootstrap file is ignored if service discovery is deployed.

Bootstrap files provide a fallback mechanism for service discovery in situations where service discovery has
not been deployed and where you do not want users to manually specify their connection settings.

The client only reads the bootstrap file on the initial launch. After the initial launch, the client caches the
server addresses and configuration, and then loads from the cache on subsequent launches.

We recommend that you do not use a bootstrap file, and instead use service discovery, in on-premises
deployments with Cisco Unified Communications Manager release 9.x and later.

Bootstrap Settings for On-Premises Deployments
The following table lists the argument values for various deployment types.

Argument ValuesServer ReleasesProduct Mode

Use the following installer switches and
values:

• AUTHENTICATOR=CUP

• CUP_ADDRESS=
<presence_server_address>

Release 9 and later:

• Cisco Unified Communications
Manager

• Cisco Unified Communications
Manager IM and Presence Service

Full UC (Default
Mode)

Use the following installer switches and
values:

• AUTHENTICATOR=CUP

• CUP_ADDRESS=
<presence_server_address>

Release 8.x:

• Cisco Unified Communications
Manager

• Cisco Unified Presence

Full UC (Default
Mode)

Use the following installer switches and
values:

• AUTHENTICATOR=CUP

• CUP_ADDRESS=
<presence_server_address>

Release 9 and later:

Cisco Unified Communications
Manager IM and Presence Service

IM Only (Default
Mode)
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Argument ValuesServer ReleasesProduct Mode

Use the following installer switches and
values:

• AUTHENTICATOR=CUP

• CUP_ADDRESS=
<presence_server_address>

Release 8.x:

Cisco Unified Presence

IM Only (Default
Mode)

The following diagram illustrates how the client uses bootstrap settings in on-premises deployments:

When users start the client for the first time, the following occurs:

1 The client retrieves settings from the bootstrap file.

The client starts in default mode and determines that Cisco Unified Communications Manager IM and
Presence Service is the authenticator. The client also gets the address of the presence server, unless Service
Discovery results dictate otherwise.

2 The client authenticates to Cisco Unified Communications Manager IM and Presence Service .

3 The client retrieves service profiles from the presence server.
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Bootstrap Settings for On-Premises Deployments in Phone Mode
During installation, you set values for arguments as follows:

• Set CUCM as the value for AUTHENTICATOR.

• Set phone_mode as the value for PRODUCT_MODE.

• Set the TFTP server address as the value for TFTP.

• Set the CTI server address as the value for CTI.

• Set the CCMCIP server address as the value for CCMCIP.

Cisco Unified CommunicationsManager release 9.x and earlier—If you enable Cisco ExtensionMobility,
the Cisco Extension Mobility servicemust be activated on the CiscoUnified CommunicationsManager
nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the Feature and
Services guide for your Cisco Unified Communications Manager release.

The following diagram illustrates how the client uses bootstrap settings in phone mode deployments:

When users start the client for the first time, the following process occurs:

1 The client retrieves settings from the bootstrap file.

The client starts in phone mode and determines that Cisco Unified Communications Manager is the
authenticator. The client also gets the addresses for the TFTP server (and CTI servers for Jabber for
Windows and Jabber for Mac), unless Service Discovery results dictate otherwise.
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2 The client authenticates to Cisco Unified Communications Manager and gets configuration.

3 The client retrieves device and client configuration.

Bootstrap Settings for Cloud-Based Deployments
During installation, you set values for arguments as follows:

• Set WEBEX as the value for AUTHENTICATOR.

The following diagram illustrates how the client uses bootstrap settings in cloud-based deployments:

When users start the client for the first time, the following occurs:

1 The client retrieves settings from the bootstrap file.

The client starts in default mode and determines that the Cisco WebEx Messenger service is the
authenticator, unless Service Discovery results dictate otherwise.

2 The client authenticates to the Cisco WebEx Messenger service.

3 The client retrieves configuration and services.

Cisco Jabber 11.0 Deployment and Installation Guide    
29

Service Discovery
Bootstrap Settings for Cloud-Based Deployments



   Cisco Jabber 11.0 Deployment and Installation Guide
30

Service Discovery
Bootstrap Settings for Cloud-Based Deployments



C H A P T E R  6
Configure a Service Profile

• Activate and Start Essential Services, page 31

• Create a Service Profile, page 32

Activate and Start Essential Services
Essential services enable communication between servers and provide capabilities to the client.

Procedure

Step 1 Open the Cisco Unified IM and Presence Serviceability interface.
Step 2 Select Tools > Control Center - Feature Services.
Step 3 Select the appropriate server from the Server drop-down list.
Step 4 Ensure the following services are started and activated:

• Cisco SIP Proxy

• Cisco Sync Agent

• Cisco XCP Authentication Service

• Cisco XCP Connection Manager

• Cisco XCP Text Conference Manager

• Cisco Presence Engine

Step 5 Select Tools > Control Center - Network Services.
Step 6 Select the appropriate server from the Server drop-down list.
Step 7 Ensure Cisco XCP Router Service is running.
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What to Do Next

• If you have Cisco Unified Communications Manager IM and Presence Service release 9.x and later,
Create a Service Profile, on page 32.

• If you have Cisco Unified Presence Release 8.6, Prepopulate Contact Lists in Bulk, on page 34.

Create a Service Profile
You create a service profile that contains the configuration settings for the services you add on Cisco Unified
Communications Manager. You add the service profile to the end user configuration for your users. The client
can then retrieve settings for available services from the service profile.

Before You Begin

Activate and Start Essential Services, on page 31

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

Step 3 Select Add New.
The Service Profile Configuration window opens.

Step 4 Enter settings on the Service Profile Configuration window as follows:
a) Specify a unique name for the service profile in the Name field.
b) SelectMake this the default service profile for the system, if appropriate.

For phone mode, in the IM and Presence Profile section ensure that the Primary field has <None>
selected.

Note

Step 5 Select Save.
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C H A P T E R  7
Configure the IM and Presence Service

• Configure IM and Presence Service for an On-Premises Deployment, page 33

• Configure IM and Presence Service for Cloud-Based Deployments, page 40

Configure IM and Presence Service for an On-Premises
Deployment

IM and Presence Service Workflow for an On-Premises Deployment with
Cisco Unified Communications Manager 10.5 and later

Procedure

PurposeCommand or Action

Prepopulate Contact Lists in Bulk, on page 34Step 1

Enable Message Settings, on page 35Step 2

Configure Presence in Microsoft SharePoint 2010 and 2013, on
page 38

Step 3

Configure Users, on page 38Step 4
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IM and Presence Service Workflow for an On-Premises Deployment with
Cisco Unified Communications Manager Release 9.x and Later

Procedure

PurposeCommand or Action

Prepopulate Contact Lists in Bulk, on page 34Step 1

Enable Message Settings, on page 35Step 2

Add an IM and Presence Service, on page 36Step 3

Apply an IM and Presence Service, on page 37Step 4

Configure Presence in Microsoft SharePoint 2010 and 2013, on
page 38

Step 5

Configure Users, on page 38Step 6

IM and Presence Service Workflow for an On-Premises Deployment with
Cisco Unified Communications Manager Release 8.6

Procedure

PurposeCommand or Action

Prepopulate Contact Lists in Bulk, on page 34Step 1

Enable Message Settings, on page 35Step 2

Specify Capabilities Assignments, on page 36Step 3

Configure Presence in Microsoft SharePoint 2010 and 2013, on
page 38

Step 4

Prepopulate Contact Lists in Bulk
You can pre-populate user contact lists with the Bulk Administration Tool (BAT).

In this way you can prepopulate contact lists for users so that they automatically have a set of contacts after
the initial launch of the client.

Cisco Jabber supports up to 300 contacts in a client contact list.
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Procedure

PurposeCommand or Action

Create a CSV file that defines the contact list
you want to provide to users.

Step 1

For more information about using BAT and the
format of the CSV file, see theDeployment Guide

Use the BAT to import the contact list in bulk
to a set of users.

Step 2

for Cisco Unified Communications Manager IM
& Presence for your release.

Enable Message Settings
Enable and configure instant messaging capabilities.

Before You Begin

Prepopulate Contact Lists in Bulk, on page 34.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 SelectMessaging > Settings.
Step 3 Select the following options:

• Enable instant messaging

• Allow clients to log instant message history

Step 4 Select other messaging settings as appropriate.
Step 5 Select Save.

Cisco Jabber does not support the following settings on the Presence Settingswindow on Cisco
Unified Communications Manager IM and Presence Service release 9.0.x:

Important

• Use DND status when user is on the phone

• Use DND status when user is in a meeting

What to Do Next

• If you have Cisco Unified Communications Manager IM and Presence Service release 9.x and later,
Add an IM and Presence Service, on page 36.

• If you have Cisco Unified Presence Release 8.6, Specify Capabilities Assignments, on page 36.
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Specify Capabilities Assignments
Complete the steps in this task to provide users with instant messaging and presence capabilities when using
Cisco Unified Presence.

Before You Begin

Enable Message Settings, on page 35

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Licensing > Capabilities Assignment.

The Find and List Capabilities Assignments window opens.

Step 3 Specify the appropriate filters in the Find Capabilities Assignment where field and then select Find to
retrieve a list of users.

Step 4 Select the appropriate users from the list.
The Capabilities Assignment Configuration window opens.

Step 5 Select both of the following in the Capabilities Assignment Configuration section:

• Enable CUP

• Enable CUPC

Step 6 Select Save.

Add an IM and Presence Service
Provide users with IM and Presence Service capabilities.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.

Step 3 Select Add New.
The UC Service Configuration window opens.

Step 4 In the Add a UC Service section, select IM and Presence from the UC Service Type drop-down list.
Step 5 Select Next.
Step 6 Provide details for the IM and Presence Service as follows:

a) Select Unified CM (IM and Presence) from the Product Type drop-down list.
b) Specify a name for the service in the Name field.
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The name you specify displays when you add the service to a profile. Ensure the name you specify is
unique, meaningful, and easy to identify.

c) Specify an optional description in the Description field.
d) Specify the instant messaging and presence service address in the Host Name/IP Address field.

The service address must be a fully qualified domain name or IP address.Important

Step 7 Select Save.

Apply an IM and Presence Service
After you add an IM and Presence Service on Cisco Unified Communications Manager, you must apply it to
a service profile so that the client can retrieve the settings.

Before You Begin

Add an IM and Presence Service, on page 36

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

Step 3 Find and select your service profile.
The Service Profile Configuration window opens.

Step 4 In the IM and Presence Profile section, select up to three services from the following drop-down lists:

• Primary

• Secondary

• Tertiary

Step 5 Click Save.
Step 6 Add users to the service profile.

a) Select User Management > End User.
The Find and List Users dialog box opens.

b) Specify the appropriate filters in the Find User where field and then select Find to find a user.
c) Click the user in the list.

The End User Configuration window appears.

d) Under the Service Settings area, check the Home Cluster check box.
e) Check theEnable User for UnifiedCM IMand Presence (Configure IM and Presence in the associated

UC Service Profile) check box.
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f) Select your service profile from the UC Service Profile drop-down list.

Step 7 Click Save.

Configure Presence in Microsoft SharePoint 2010 and 2013
If your organization defines users' profiles where their IM address is different from their email address, then
additional configuration is required to enable presence integration between the client andMicrosoft SharePoint
2010 and 2013.

Before You Begin

• For Cisco Jabber for Windows clients only.

• Ensure that all sites are in sync with Microsoft SharePoint Central Administration (CA).

• Ensure that synchronization between Microsoft SharePoint and Active Directory is set up.

Procedure

Step 1 If you have Microsoft SharePoint 2013, update the SharePoint CA profile pages for users with the following
information:
a) For the SIP Address profile field, leave it blank.
b) In theWork email profile field, enter the user profile. For example, john4mail@example.pst.

Step 2 If you have Microsoft SharePoint 2010, update the SharePoint CA profile pages for users with the following
information:
a) For the SIP Address profile field, enter the user profile. For example, john4mail@example.pst
b) In theWork email profile field, leave it blank.

Configure Users
To configure users, you enable instant messaging and presence and add a service profile to the users.

Before You Begin

Configure Presence in Microsoft SharePoint 2010 and 2013, on page 38

Configure Users Individually
Enable instant messaging and presence and add your service profile to individual users.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > End User.

The Find and List Users window opens.

Step 3 Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.
Step 4 Select the appropriate username from the list.

The End User Configuration window opens.

Step 5 Locate the Service Settings section and do the following:
a) Select Enable User for Unified CM IM and Presence.
b) Select your service profile from the UC Service Profile drop-down list.

Cisco Unified Communications Manager release 9.x only— If the user has only instant
messaging and presence capabilities (IM only), you must select Use Default. Cisco Unified
Communications Manager release version 9.x always applies the default service profile
regardless of what you select from the UC Service Profile drop-down list.

Important

Step 6 Select Save.

Configure Users in Bulk
Enable instant messaging and presence and add your service profile to multiple users.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Bulk Administration > Users > Update Users > Query.

The Find and List Users To Update window opens.

Step 3 Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.
Step 4 Select Next.

The Update Users Configuration window opens.

Step 5 Select both of the Enable User for Unified CM IM and Presence check boxes.
There are two check boxes for Enable User for Unified CM IM and Presence. To disable
instant messaging and presence, you select one check box. To enable instant messaging and
presence, you select both check boxes.

Important

Step 6 Select the UC Service Profile check box and then select your service profile from the drop-down list.
Cisco Unified CommunicationsManager release 9.x only— If the user has only instant messaging
and presence capabilities (IM only), you must select Use Default.

For IM only users— Cisco Unified Communications Manager release 9.x always applies the
default service profile regardless of what you select from the UC Service Profile drop-down
list.

Important
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Step 7 In the Job Information section, specify if you want to run the job immediately or at a later time.
Step 8 Select Submit.

Configure IM and Presence Service for Cloud-Based
Deployments

Procedure

PurposeCommand or Action

Configure IM and Presence Service, on page 40Step 1

Configure Presence in Microsoft SharePoint 2010 and 2013Step 2

Configure Privacy Options, on page 40Step 3

Configure IM and Presence Service
When users successfully authenticate to the Cisco WebEx Messenger service, they get IM and Presence
Service capabilities. You can optionally configure IM and Presence Service federation with the Cisco WebEx
Administration Tool.

Configure Privacy Options
You can specify the default settings for presence subscription requests in cloud-based deployments.

Procedure

Step 1 Open the Cisco WebEx Administration Tool.
Step 2 Select the Configuration tab.
Step 3 Select General IM in the Connect Client section.

The General IM pane opens.
Step 4 Select the appropriate options for contact list requests as follows:

DescriptionOption

Accept requests automatically from contacts in my organization
automatically becomes the default option to configure how the client
handles presence subscription requests. Users can change the default
option in the Options window.

Select Allow users to set
"Options for contact list
requests"
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DescriptionOption

You configure how the client handles presence subscription requests.
Users cannot change this configuration. The settings are not available in
the Options window.

Select one of the following options:

• Accept requests automatically from all contacts

• Accept requests automatically from contacts inmy organization

• Prompt me for each request

Do not select Allow users to set
"Options for contact list
requests"

The options for configuring how the client handles contact list requests are as follows:

• Accept requests automatically from all contacts— The client automatically accepts presence subscription
requests from any domain. If you specify this setting, users from any domain can automatically add
users to their contact list and view their availability status.

• Accept requests automatically from contacts in my organization— The client automatically accepts
presence subscription requests only from users in the domains you specify. To specify a domain, select
Domain(s) in the System Settings section on the Configuration tab.

When searching for contacts in your organization, users can see the temporary availability status
of all users in the organization. However, if User A blocks User B, User B cannot see the
temporary availability status of User A in the search list.

Note

• Prompt me for each request— The client prompts users to accept each presence subscription request.

Step 5 Select Save.
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C H A P T E R  8
Configure Voice and Video Communication

• Configure Voice and Video Communications for On-Premises Deployments, page 43

• Configure Voice and Video Communication for Cloud-Based Deployments, page 65

Configure Voice and Video Communications for On-Premises
Deployments

Procedure

PurposeCommand or Action

Complete this task if you have Cisco Unified
Communications Manager Release 8.x.

Setting up System SIP ParametersStep 1

Complete this task to make Cisco Jabber available
as a device in Cisco Unified Communications
Manager.

Install Cisco Options Package File for
Devices, on page 44.

Step 2

This is applicable for Cisco Unified
Communications Manager release 9.x and later
only.

Complete this task if you have Cisco Unified
Communications Manager Release 8.6 and you
plan to enable video desktop sharing.

Apply COP File for BFCP Capabilities,
on page 45.

Step 3

Complete this task if you have Cisco Unified
Communications Manager release 9 or earlier and
plan to configure devices for mobile clients.

Create SIP Profiles, on page 46.Step 4

Complete this task to setup secure phone
capabilities for all devices.

Configure the Phone Security Profile,
on page 48

Step 5
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PurposeCommand or Action

Complete this task if you plan to assign Cisco
Jabber for Mac or Cisco Jabber forWindows users
to CTI remote devices.

Enable User Mobility, on page 49.Step 6

Complete this task if you plan to assign Cisco
Jabber for Mac or Cisco Jabber forWindows users
to CTI remote devices.

Add a CTI Service, on page 50.Step 7

Complete this only if you have Cisco Unified
Communications Manager Release 8.6 with Cisco
Unified Presence.

Add a CTI Gateway Server, on page 51.Step 8

Video Desktop Sharing, on page 52Step 9

Create at least one device for every user that will
access Cisco Jabber.

Create and Configure Cisco Jabber
Devices, on page 53

Step 10

Provide Users with Authentication
Strings, on page 58

Step 11

Desk Phone Video Configuration, on
page 59

Step 12

Enable Video Rate Adaptation, on page
60

Step 13

Configure User Associations, on page
61

Step 14

Only if installing Cisco Jabber for MacReset Devices, on page 63Step 15

Create a CCMCIP Profile, on page 63Step 16

Dial Plan MappingStep 17

Install Cisco Options Package File for Devices
To make Cisco Jabber available as a device in Cisco Unified Communications Manager, you must install a
device-specific Cisco Options Package (COP) file on all your Cisco Unified CommunicationsManager nodes.

Perform this procedure at a time of low usage; it can interrupt service.

General information about installing COP files is available in the “Software Upgrades” chapter in the Cisco
Unified Communications Operating System Administration Guide for your release.

Procedure

Step 1 Download the device COP file.
a) Locate the device COP file.
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• Go to the software downloads site.

• Locate the device COP file for your release.

b) Click Download Now.
c) Note the MD5 checksum.

You will need this information later.

d) Click Proceed with Download and follow the instructions.

Step 2 Place the COP file on an FTP or SFTP server that is accessible from your Cisco Unified Communications
Manager nodes.

Step 3 Install this COP file on the Publisher node in your Cisco Unified Communications Manager cluster:
a) Open the Cisco Unified OS Administration interface.
b) Select Software Upgrades > Install/Upgrade.
c) Specify the location of the COP file and provide the required information.

For more information, see the online help.

d) Select Next.
e) Select the device COP file.
f) Select Next.
g) Follow the instructions on the screen.
h) Select Next.

Wait for the process to complete. This process can take some time.

i) Reboot Cisco Unified Communications Manager at a time of low usage.
j) Let the system fully return to service.

To avoid interruptions in service, make sure each node returns to active service before you perform
this procedure on another server.

Note

Step 4 Install the COP file on each Subscriber node in the cluster.
Use the same process you used for the Publisher, including rebooting the node.

Apply COP File for BFCP Capabilities
Youmust apply cmterm-bfcp-e.8-6-2.cop.sgn to configure video desktop sharing on Cisco Unified
Communication Manager release 8.6.2 and later. This COP file adds an option to enable BFCP on the CSF
device.
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Note • You must install the COP file each time you upgrade. For example, if you configure video desktop
sharing on Cisco Unified Communication Manager Release 8.6.2 .20000-1 and then upgrade to
Cisco Unified Communication Manager Release 8.6.2 .20000-2, you must apply the COP file on
Cisco Unified Communication Manager Release 8.6.2 .20000-2.

• If you configure video desktop sharing on Cisco Unified Communication Manager Release 8.6.1
and then upgrade to Cisco Unified Communication Manager release 8.6.2, you must apply the COP
file on Cisco Unified CommunicationManager release 8.6.2 before you can configure video desktop
sharing.

Procedure

Step 1 Download the Cisco Jabber administration package from Cisco.com.
Step 2 Copy cmterm-bfcp-e.8-6-2.cop.sgn from the Cisco Jabber administration package to your file

system.
Step 3 Open the Cisco Unified Communications Manager Administration interface.
Step 4 Upload and apply cmterm-bfcp-e.8-6-2.cop.sgn.
Step 5 Restart the server as follows:

a) Open the Cisco Unified OS Administration interface.
b) Select Settings > Version.
c) Select Restart.
d) Repeat the preceding steps for each node in the cluster, starting with your presentation server.

The COP add the Allow Presentation Sharing using BFCP field to the Protocol Specific Information
section on the Phone Configuration window for CSF devices.

Create SIP Profiles
This procedure is required only when you use Cisco Unified Communication Manager release 9 or earlier
and are configuring devices for mobile clients. Use the default SIP profile provided for desktop clients.

If you use Cisco Unified CommunicationManager release 9 or earlier, before you create and configure devices
for mobile clients, you must create a SIP profile that allows Cisco Jabber to stay connected to Cisco Unified
Communication Manager while Cisco Jabber runs in the background.

If you use Cisco Unified Communication Manager Release 10, choose the Standard SIP Profile for Mobile
Device default profile when you create and configure devices for mobile clients.

Before You Begin

Install Cisco Options Package File for Devices, on page 44
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Device Settings > SIP Profile.

The Find and List SIP Profiles window opens.

Step 3 Do one of the following to create a new SIP profile:

• Find the default SIP profile and create a copy that you can edit.

• Select Add New and create a new SIP profile.

Step 4 In the new SIP profile, set the following values:

• Timer Register Delta to 120

• Timer Register Expires to 720

• Timer Keep Alive Expires to 720

• Timer Subscribe Expires to 21600

• Timer Subscribe Delta to 15

Step 5 Select Save.

What to Do Next

Setting up System SIP Parameters, on page 47

Setting up System SIP Parameters
If you are connected to a low-bandwidth network and finding it difficult to take an incoming call on your
mobile device, you can set the system SIP parameters to improve the condition. Increase the SIP Dual Mode
Alert Timer value to ensure that calls to the Cisco Jabber extension are not prematurely routed to the
mobile-network phone number.

Before You Begin

This configuration is only for mobile clients.

Cisco Jabber must be running to receive work calls.

Create SIP Profiles, on page 46
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters.
Step 3 Select the node.
Step 4 Select the Cisco CallManager (Active) service.
Step 5 Scroll to the Clusterwide Parameters (System - Mobility) section.
Step 6 Increase the SIP Dual Mode Alert Timer value to 10000 milliseconds.
Step 7 Select Save.

If, after you increase the SIP DualMode Alert Timer value, incoming calls that arrive in Cisco Jabber
are still terminated and diverted using Mobile Connect, you can increase the SIP Dual Mode Alert
Timer value again in increments of 500 milliseconds.

Note

Configure the Phone Security Profile
You can optionally set up secure phone capabilities for all devices. Secure phone capabilities provide secure
SIP signaling, secure media streams, and encrypted device configuration files.

If you enable secure phone capabilities for users, device connections to Cisco Unified Communications
Manager are secure. However, calls with other devices are secure only if both devices have a secure connection.

Before You Begin

• Configure the Cisco Unified Communications Manager security mode using the Cisco CTL Client. At
minimum you must use mixed mode security.

For instructions on how to configure mixed mode with the Cisco CTL Client, see the Cisco Unified
Communications Manager Security Guide at http://www.cisco.com/c/en/us/support/
unified-communications/unified-communications-manager-callmanager/
products-maintenance-guides-list.html.

• For conference calls, ensure that the conferencing bridge supports secure phone capabilities. If the
conferencing bridge does not support secure phone capabilities, calls to that bridge are not secure.
Likewise, all parties must support a common encryption algorithm for the client to encrypt media on
conference calls.

Procedure

Step 1 In Cisco Unified Communications Manager, select System > Security > Phone Security Profile.
Step 2 Select Add New.
Step 3 From the Phone Type drop-down list, select the option that is applicable to the device type you are configuring

and then select Next.

• Cisco Unified Client Services Framework—Select this option to create a CSF device for Cisco Jabber
for Mac or Cisco Jabber for Windows.
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• Cisco Dual Mode for iPhone—Select this option to create a TFT device for an iPhone.

• Cisco Jabber for Tablet—Select this option to create a TAB device for an iPad or an Android tablet.

• Cisco Dual Mode for Android—Select this option to create a BOT device for an Android device.

• CTI Remote Device—Select this option to create a CTI remote device.
CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

Step 4 In the Name field of the Phone Security Profile Configuration window, specify a name for the phone
security profile.

Step 5 For Device Security Mode, select one of the following options:

• Authenticated—The SIP connection is over TLS using NULL-SHA encryption.

• Encrypted—The SIP connection is over TLS using AES 128/SHA encryption. The client uses Secure
Realtime Transport Protocol (SRTP) to offer encrypted media streams.

Step 6 For Transport Type, leave the default value of TLS.
Step 7 Select the TFTP Encrypted Config checkbox to encrypt the device configuration file that resides on the

TFTP server.
For TCT/BOT/Tablet device, do not select TFTP Encrypted Config checkbox here. For Authentication
Mode, select By Authentication String or Null String.

Note

Step 8 For Authentication Mode, select By Authentication String or By Null String.
Step 9 For Key Size (Bits), select the appropriate key size for the certificate. Key size refers to the bit length of the

public and private keys that the client generates during the CAPF enrollment process.
The Ciso Jabber clients were tested using authentication strings with 1024 bit length keys. The Cisco Jabber
clients require more time to generate 2048 bit length keys than 1024 bit length keys. As a result, if you select
2048, you should expect it to take longer to complete the CAPF enrollment process.

Step 10 For SIP Phone Port, leave the default value.
The port that you specify in this field takes effect only if you select Non Secure as the value for Device
Security Mode.

Step 11 Click Save.

Enable User Mobility
This task is only for desktop clients.

You must enable user mobility to provision CTI remote devices. If you do not enable mobility for users, you
cannot assign those users as owners of CTI remote devices.

Before You Begin

This task is applicable only if:

• You plan to assign Cisco Jabber for Mac or Cisco Jabber for Windows users to CTI remote devices.

• You have Cisco Unified Communication Manager release 9.x and later.
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Procedure

Step 1 Select User Management > End User.
The Find and List Users window opens.

Step 2 Specify the appropriate filters in the Find User where field to and then select Find to retrieve a list of users.
Step 3 Select the user from the list.

The End User Configuration window opens.

Step 4 Locate theMobility Information section.
Step 5 Select Enable Mobility.
Step 6 Select Save.

Add a CTI Service
The CTI service lets users control devices.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.

Step 3 Select Add New.
The UC Service Configuration window opens.

Step 4 In the Add a UC Service section, select CTI from the UC Service Type drop-down list.
Step 5 Select Next.
Step 6 Provide details for the instant messaging and presence service as follows:

a) Specify a name for the service in the Name field.
The name you specify displays when you add services to profiles. Ensure the name you specify is unique,
meaningful, and easy to identify.

b) Specify the CTI service address in the Host Name/IP Address field.
c) Specify the port number for the CTI service in the Port field.

Step 7 Select Save.

What to Do Next

Add the CTI service to your service profile.
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Apply a CTI Service
After you add a CTI service on Cisco Unified CommunicationsManager, youmust apply it to a service profile
so that the client can retrieve the settings.

Before You Begin

• Create a service profile if none already exists or if you require a separate service profile for CTI.

• Add a CTI service.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.
Step 3 Find and select your service profile.
Step 4 In the CTI Profile section of the Service Profile Configuration window, select up to three services from the

following drop-down lists:

• Primary

• Secondary

• Tertiary

Step 5 Select Save.

Add a CTI Gateway Server
This task is applicable only if you have CUCM 8.6 with CUP.

The client requires a CTI gateway to communicate with Cisco Unified CommunicationsManager and perform
certain functions such as desk phone control. The first step to set up a CTI gateway is to add a CTI gateway
server on Cisco Unified Presence.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > CTI Gateway Server.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified
Personal Communicator > CTI Gateway Server.

Note

The Find and List CTI Gateway Servers window opens.

Step 3 Select Add New.
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The CTI Gateway Server Configuration window opens.

Step 4 Specify the required details on the CTI Gateway Server Configuration window.
Step 5 Select Save.

What to Do Next

Create a CTI Gateway Profile, on page 52

Create a CTI Gateway Profile
After you add a CTI gateway server, you must create a CTI gateway profile and add that server to the profile.

Before You Begin

Add a CTI Gateway Server, on page 51

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > CTI Gateway Profile.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified
Personal Communicator > CTI Gateway Profile.

Note

Step 3 In the CTI Gateway Profile Configuration window, specify the required details.
Step 4 Select Add Users to Profile and add the appropriate users to the profile.
Step 5 Select Save.

Video Desktop Sharing
Binary Floor Control Protocol (BFCP) provides video desktop sharing capabilities for software phone devices,
also known as CSF devices. Cisco Unified Communications Manager handles the BFCP packets that users
transmit when using video desktop sharing capabilities. On Cisco Unified Communications Manager version
9.0(1) and later, BFCP presentation sharing is automatically enabled. For this reason, you do not need to
perform any steps to enable video desktop sharing on CSF devices.

Cisco Jabber for mobile clients can only receive BFCP.Note
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Note • You can enable video desktop sharing only on software phone devices. You cannot enable video
desktop sharing on desk phone devices.

• Users must be on active calls to use video desktop sharing capabilities. You can only initiate video
desktop sharing sessions from active calls.

• In hybrid cloud-based deployments, both CiscoWebEx and Cisco Unified CommunicationsManager
provide desktop sharing functionality.

• If users initiate desktop sharing sessions during an instant messaging session, Cisco WebEx
provides desktop sharing capabilities.

• If users initiate desktop sharing sessions during an audio or video conversation, Cisco Unified
Communications Manager provides desktop sharing capabilities.

• Video desktop sharing using BFCP is not supported if Trusted Relay Point orMedia Termination
Point are enabled on the software phone device.

• Video desktop sharing using BFCP is not supported during Cisco Jabber multi-party conference
calls unless Cisco TelePresence MCU is deployed.

You must enable BFCP on the SIP trunk to allow video desktop sharing capabilities outside of a Cisco
Unified Communications Manager cluster. To enable BFCP on the SIP trunk, do the following:

Tip

1 Select Allow Presentation Sharing using BFCP in the Trunk Specific Configuration section of the
SIP profile.

2 Select the SIP profile from the SIP Profile drop-down list on the CSF device configuration.

Create and Configure Cisco Jabber Devices
Create at least one device for every user that accesses Cisco Jabber. A user can have multiple devices.

Users can only remove participants from a conference call when using the softphone(CSF) device for
calls.

Note

Before You Begin

• Install COP files.

• Enable mobility for each user for whom you plan to assign to a CTI remote device.

• Create SIP profiles if you have Cisco Unified Communications Manager release 9 or earlier and plan
to configure devices for mobile clients.

• Create the Phone Security Profile if you plan to set up secure phone capabilities for all devices.
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• For CiscoUnified CommunicationsManager release 10 or later, ensure that the Cisco Certificate Authority
Proxy Function (CAPF) service parameters value forCertificate Issuer to Endpoint isCisco Certificate
Authority Proxy Function, this is the only option supported by Cisco Jabber. For information on
configuring the CAPF service parameter see the Update CAPF Service Parameters topic in the Cisco
Unified Communications Manager Security Guide.

Procedure

Step 1 Log in to the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.
Step 3 Select Add New.
Step 4 From the Phone Type drop-down list, select the option that is applicable to the device type you are configuring

and then select Next.

• Cisco Unified Client Services Framework—Select this option to create a CSF device for Cisco Jabber
for Mac or Cisco Jabber for Windows.

• Cisco Dual Mode for iPhone—Select this option to create a TCT device for an iPhone.

• Cisco Jabber for Tablet—Select this option to create a TAB device for an iPad or an Android tablet.

• Cisco Dual Mode for Android—Select this option to create a BOT device for an Android device.

• CTI Remote Device—Select this option to create a CTI remote device.
CTI remote devices are virtual devices that monitor and have call control over a user's remote destination.

Step 5 From the Owner User ID drop-down list, select the user for whom you want to create the device.
For the Cisco Unified Client Services Framework option in a Phone mode deployment, ensure that User is
selected.

Step 6 In the Device Name field, use the applicable format to specify a name for the device:
Required FormatIf You Select

•When you select an owner user ID, this field
autopopulates with CTIRD<owner user ID>.
You can change this value. The device name
does not have to begin with CTIRD.

• Valid characters: a–z, A–Z, 0–9, period (.),
underscore (_), hyphen (-).

• 15-character limit.

CTI Remote Device

• Valid characters: a–z, A–Z, 0–9.

• 15-character limit.

Cisco Unified Client Services Framework
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Required FormatIf You Select

• The device name must begin with TCT.
For example, if you create a TCT device for
user, Tanya Adams, whose username is tadams,
enter TCTTADAMS.

• Valid characters: a–z, A–Z, 0–9, period (.),
underscore (_), hyphen (-).

• 12-character limit.

Cisco Dual Mode for iPhone

• The device name must begin with TAB.
For example, if you create a TAB device for
user, Tanya Adams, whose username is tadams,
enter TABTADAMS.

• Valid characters: a–z, A–Z, 0–9, period (.),
underscore (_), hyphen (-).

• 12-character limit.

Cisco Jabber for Tablet

• The device name must begin with BOT.
For example, if you create a BOT device for
user, Tanya Adams, whose username is tadams,
enter BOTTADAMS.

• Valid characters: a–z, A–Z, 0–9, period (.),
underscore (_), hyphen (-).

• 12-character limit.

Cisco Dual Mode for Android

Step 7 If you are creating a CTI Remote Device, in the Protocol Specific Information section, select an appropriate
option from the Rerouting Calling Search Space drop-down list.
The Rerouting Calling Search Space defines the calling search space for rerouting and ensures that users can
send and receive calls from the CTI remote device.

Step 8 To generate an authentication string that you can provide to end users to access their devices and securely
register to Cisco Unified CommunicationsManager, navigate to theCertification Authority Proxy Function
(CAPF) Information section.

Step 9 From the Certificate Operation drop-down list, select Install/Upgrade.
Step 10 From the Authentication Mode drop-down list, select By Authentication String or By Null String.
Step 11 Click Generate String.
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The Authentication String autopopulates with a string value. This is the string that you will provide to end
users.

Step 12 From the Key Size (Bits) drop-down list, select the same key size that you set in the phone security profile.
Step 13 In the Operation Completes By fields, specify an expiration value for the authentication string or leave as

default.
Step 14 Specify remaining configuration settings in the Phone Configuration window as appropriate.

For more information about the remaining configuration settings, on the menu bar, click Help > This Page.
For detailed information about the settings in the Product Specific Configuration Layout section, click the
question mark icon.

Step 15 Select Save.
Step 16 Click Apply Config.

What to Do Next

Add a Directory Number to the device.

Add a Directory Number to the Device
After you create and configure each device, you must add a directory number to the device. This topic provides
instructions on adding directory numbers using the Device > Phone menu option.

Before You Begin

Create a device.

Procedure

Step 1 Locate the Association Information section on the Phone Configuration window.
Step 2 Click Add a new DN.
Step 3 In the Directory Number field, specify a directory number.
Step 4 In the Users Associated with Line section, click Associate End Users.
Step 5 In the Find User where field, specify the appropriate filters and then click Find.
Step 6 From the list that appears, select the applicable users and click Add Selected.
Step 7 Specify all other required configuration settings as appropriate.
Step 8 Select Apply Config.
Step 9 Select Save.

Add a Remote Destination
Remote destinations represent the CTI controllable devices that are available to users.

You should add a remote destination through the Cisco Unified CM Administration interface if you plan to
provision users with dedicated CTI remote devices. This task ensures that users can automatically control
their phones and place calls when they start the client.
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If you plan to provision users with CTI remote devices along with software phone devices and desk phone
devices, you should not add a remote destination through the Cisco Unified CM Administration interface.
Users can enter remote destinations through the client interface.

Note • You should create only one remote destination per user. Do not add two or more remote destinations
for a user.

• Cisco Unified Communications Manager does not verify if it can route remote destinations that you
add through theCisco Unified CMAdministration interface. For this reason, you must ensure that
Cisco Unified Communications Manager can route the remote destinations you add.

• Cisco Unified Communications Manager automatically applies application dial rules to all remote
destination numbers for CTI remote devices.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.

The Find and List Phones window opens.

Step 3 Specify the appropriate filters in the Find Phone where field to and then select Find to retrieve a list of
phones.

Step 4 Select the CTI remote device from the list.
The Phone Configuration window opens.

Step 5 Locate the Associated Remote Destinations section.
Step 6 Select Add a New Remote Destination.

The Remote Destination Information window opens.

Step 7 Specify JabberRD in the Name field.
You must specify JabberRD in the Name field. The client uses only the JabberRD remote
destination. If you specify a name other than JabberRD, users cannot access that remote
destination.

Restriction

The client automatically sets the JabberRD name when users add remote destinations through the client
interface.

Step 8 Enter the destination number in the Destination Number field.
Step 9 Specify all other values as appropriate.
Step 10 Select Save.

What to Do Next

Complete the following steps to verify the remote destination and apply the configuration to the CTI remote
device:

1 Repeat the steps to open the Phone Configuration window for the CTI remote device.

2 Locate the Associated Remote Destinations section.
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3 Verify the remote destination is available.

4 Select Apply Config.

The Device Information section on the Phone Configuration window contains a Active Remote
Destination field.

When users select a remote destination in the client, it displays as the value ofActive Remote Destination.

none displays as the value of Active Remote Destination if:

Note

• Users do not select a remote destination in the client.

• Users exit or are not signed in to the client.

Provide Users with Authentication Strings
Users must specify the authentication string in the client interface to access their devices and securely register
with Cisco Unified Communications Manager.

When users enter the authentication string in the client interface, the CAPF enrollment process begins.

The time it takes for the enrollment process to complete can vary depending on the user's computer or
mobile device and the current load for Cisco Unified Communications Manager. It can take up to one
minute for the client to complete the CAPF enrollment process.

Note

The client displays an error if:

• Users enter an incorrect authentication string.
Users can attempt to enter authentication strings again to complete the CAPF enrollment. However, if
a user continually enters an incorrect authentication string, the client might reject any string the user
enters, even if the string is correct. In this case, you must generate a new authentication string on the
user's device and then provide it to the user.

• Users do not enter the authentication string before the expiration time you set in theOperationCompletes
By field.

In this case, you must generate a new authentication string on the user's device. The user must then enter
that authentication string before the expiration time.

When you configure the end users in Cisco Unified Communications Manager, you must add them to the
following user groups:

Important

• Standard CCM End Users

• Standard CTI Enabled

Users must not belong to the Standard CTI Secure Connection user group.
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Desk Phone Video Configuration
Desk phone video capabilities let users receive video transmitted to their desk phone devices on their computers
through the client.

Set Up Desk Phone Video

To set up desk phone video, you must complete the following steps:

1 Physically connect the computer to the computer port on the desk phone device.

You must physically connect the computer to the desk phone device through the computer port so that the
client can establish a connection to the device. You cannot use desk phone video capabilities with wireless
connections to desk phone devices.

If users have both wireless and wired connections available, they should configure Microsoft Windows
so that wireless connections do not take priority over wired connections. See the following Microsoft
documentation for more information: An explanation of the Automatic Metric feature for Internet Protocol
routes.

Tip

2 Enable the desk phone device for video in Cisco Unified Communications Manager.

3 Install Cisco Media Services Interface on the computer.

Cisco Media Services Interface provides the Cisco Discover Protocol (CDP) driver that enables the client
to do the following:

• Discover the desk phone device.

• Establish and maintain a connection to the desk phone device using the CAST protocol.

Download the Cisco Media Services Interface installation program from the download site on
cisco.com.

Note

Desk Phone Video Considerations

Review the following considerations and limitations before you provision desk phone video capabilities to
users:

• You cannot use desk phone video capabilities on devices if video cameras are attached to the devices,
such as a Cisco Unified IP Phone 9971. You can use desk phone video capabilities if you remove video
cameras from the devices.

• You cannot use desk phone video capabilities with devices that do not support CTI.

• Video desktop sharing, using the BFCP protocol, is not supported with desk phone video.

• It is not possible for endpoints that use SCCP to receive video only. SCCP endpoints must send and
receive video. Instances where SCCP endpoints do not send video result in audio only calls.
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• 7900 series phones must use SCCP for desk phone video capabilities. 7900 series phones cannot use
SIP for desk phone video capabilities.

• If a user initiates a call from the keypad on a desk phone device, the call starts as an audio call on the
desk phone device. The client then escalates the call to video. For this reason, you cannot make video
calls to devices that do not support escalation, such as H.323 endpoints. To use desk phone video
capabilities with devices that do not support escalation, users should initiate calls from the client.

• A compatibility issue exists with Cisco Unified IP Phones that use firmware version SCCP45.9-2-1S.
You must upgrade your firmware to version SCCP45.9-3-1 to use desk phone video capabilities.

• Some antivirus or firewall applications, such as Symantec EndPoint Protection, block inbound CDP
packets, which disables desk phone video capabilities. You should configure your antivirus or firewall
application to allow inbound CDP packets.

See the following Symantec technical document for additional details about this issue: Cisco IP Phone
version 7970 and Cisco Unified Video Advantage is Blocked by Network Threat Protection.

• You must not select theMedia Termination Point Required checkbox on the SIP trunk configuration
for Cisco Unified Communications Manager. Desk phone video capabilities are not available if you
select this checkbox.

If you encounter an error that indicates desk phone video capabilities are unavailable or the desk phone device
is unknown, do the following:

1 Ensure you enable the desk phone device for video in Cisco Unified Communications Manager.

2 Reset the physical desk phone.

3 Exit the client.

4 Run services.msc on the computer where you installed the client.

5 Restart Cisco Media Services Interface.

6 Restart the client.

Enable Video Rate Adaptation
The client uses video rate adaptation to negotiate optimum video quality. Video rate adaptation dynamically
increases or decreases video quality based on network conditions.

To use video rate adaptation, you must enable Real-Time Transport Control Protocol (RTCP) on Cisco Unified
Communications Manager .

RTCP is enabled on software phone devices by default. However, you must enable RTCP on desk phone
devices.

Note

Enable RTCP on Common Phone Profiles
You can enable RTCP on a common phone profile to enable video rate adaptation on all devices that use the
profile.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Device Settings > Common Phone Profile.

The Find and List Common Phone Profiles window opens.

Step 3 Specify the appropriate filters in the Find Common Phone Profile where field and then select Find to retrieve
a list of profiles.

Step 4 Select the appropriate profile from the list.
The Common Phone Profile Configuration window opens.

Step 5 Locate the Product Specific Configuration Layout section.
Step 6 Select Enabled from the RTCP drop-down list.
Step 7 Select Save.

Enable RTCP on Device Configurations
You can enable RTCP on specific device configurations instead of a common phone profile. The specific
device configuration overrides any settings you specify on the common phone profile.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.

The Find and List Phones window opens.

Step 3 Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of phones.
Step 4 Select the appropriate phone from the list.

The Phone Configuration window opens.

Step 5 Locate the Product Specific Configuration Layout section.
Step 6 Select Enabled from the RTCP drop-down list.
Step 7 Select Save.

Configure User Associations
When you associate a user with a device, you provision that device to the user.

Before You Begin

Create and configure Cisco Jabber devices.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > End User.

The Find and List Users window opens.

Step 3 Specify the appropriate filters in the Find User where field and then select Find to retrieve a list of users.
Step 4 Select the appropriate user from the list.

The End User Configuration window opens.

Step 5 Locate the Service Settings section.
Step 6 Select Home Cluster.
Step 7 Select the appropriate service profile for the user from the UC Service Profile drop-down list.
Step 8 Locate the Device Information section.
Step 9 Select Device Association.

The User Device Association window opens.

Step 10 Select the devices to which you want to associate the user.
Step 11 Select Save Selected/Changes.
Step 12 Select User Management > End User and return to the Find and List Users window.
Step 13 Find and select the same user from the list.

The End User Configuration window opens.

Step 14 Locate the Permissions Information section.
Step 15 Select Add to Access Control Group.

The Find and List Access Control Groups dialog box opens.

Step 16 Select the access control groups to which you want to assign the user.
At a minimum you should assign the user to the following access control groups:

• Standard CCM End Users

• Standard CTI Enabled

If you are provisioning users with secure phone capabilities, do not assign the users to the
Standard CTI Secure Connection group.

Remember

Certain phone models require additional control groups, as follows:

• Cisco Unified IP Phone 9900, 8900, or 8800 series or DX series, select Standard CTI Allow Control
of Phones supporting Connected Xfer and conf.

• Cisco Unified IP Phone 6900 series, select Standard CTI Allow Control of Phones supporting
Rollover Mode.

Step 17 Select Add Selected.
The Find and List Access Control Groups window closes.

Step 18 Select Save on the End User Configuration window.
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Reset Devices
After you create and associate users with devices, you should reset those devices.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.

The Find and List Phones window opens.

Step 3 Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of devices.
Step 4 Select the appropriate device from the list.

The Phone Configuration window opens.

Step 5 Locate the Association Information section.
Step 6 Select the appropriate directory number configuration.

The Directory Number Configuration window opens.

Step 7 Select Reset.
The Device Reset dialog box opens.

Step 8 Select Reset.
Step 9 Select Close to close the Device Reset dialog box.

What to Do Next

Create a CCMCIP Profile, on page 63

Create a CCMCIP Profile
The client gets device lists for users from the CCMCIP server.

If the client gets the _cisco-uds SRV record from a DNS query, it can automatically locate the user's
home cluster and discover services. One of the services the client discovers is UDS, which replaces
CCMCIP.

Note

Before You Begin

Reset Devices, on page 63
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Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 Select Application > Legacy Clients > CCMCIP Profile.
Step 3 In the Find and List CCMCIP Profiles window, select Add New.
Step 4 In the CCMCIP Profile Configuration window, specify service details in the CCMCIP profile as follows:

a) Specify a name for the profile in the Name field.
b) Specify the fully qualified domain name or IP address of your primary CCMCIP service in the Primary

CCMCIP Host field.
c) Specify the fully qualified domain name or IP address of your backup CCMCIP service in the Backup

CCMCIP Host field.
d) Leave the default value for Server Certificate Verification.
Cisco Unified Communications Manager release 9.x and earlier—If you enable Cisco Extension Mobility,
the Cisco Extension Mobility service must be activated on the Cisco Unified Communications Manager
nodes that are used for CCMCIP. For information about Cisco Extension Mobility, see the Feature and
Services guide for your Cisco Unified Communications Manager release.

Step 5 Add users to the CCMCIP profile as follows:
a) Select Add Users to Profile.
b) In the Find and List Users dialog, specify the appropriate filters in the Find User where field and then

select Find to retrieve a list of users.
c) Select the appropriate users from the list.
d) Select Add Selected.

The selected users are added to the CCMCIP profile.

Step 6 Select Save.

What to Do Next

Dial Plan Mapping

Dial Plan Mapping

Publish Dial Rules
Cisco Unified Communications Manager release 8.6.1 or earlier does not automatically publish dial rules to
the client. For this reason, you must deploy a COP file to publish your dial rules. This COP file copies your
dial rules from the Cisco Unified Communications Manager database to an XML file on your TFTP server.
The client can then download that XML file and access your dial rules.

Youmust deploy the COP file every time you update or modify dial rules on Cisco Unified Communications
Manager release 8.6.1 or earlier.

Remember
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Before You Begin

1 Create your dial rules in Cisco Unified Communications Manager.

2 Download the Cisco Jabber administration package from cisco.com.

3 Copy cmterm-cupc-dialrule-wizard-0.1.cop.sgn from the Cisco Jabber administration
package to your file system.

Procedure

Step 1 Open the Cisco Unified OS Administration interface.
Step 2 Select Software Upgrades > Install/Upgrade.
Step 3 Specify the location of cmterm-cupc-dialrule-wizard-0.1.cop.sgn in the Software

Installation/Upgrade window.
Step 4 Select Next.
Step 5 Select cmterm-cupc-dialrule-wizard-0.1.cop.sgn from the Available Software list.
Step 6 Select Next and then select Install.
Step 7 Restart the TFTP service.
Step 8 Open the dial rules XML files in a browser to verify that they are available on your TFTP server.

a) Navigate to http://tftp_server_address:6970/CUPC/AppDialRules.xml.
b) Navigate to http://tftp_server_address:6970/CUPC/DirLookupDialRules.xml.
If you can access AppDialRules.xml and DirLookupDialRules.xmlwith your browser, the client
can download your dial rules.

Step 9 Repeat the preceding steps for each Cisco Unified CommunicationsManager instance that runs a TFTP service.

What to Do Next

After you repeat the preceding steps on each Cisco Unified Communications Manager instance, restart the
client.

Configure Voice and Video Communication for Cloud-Based
Deployments

Procedure

PurposeCommand or Action

Configure Audio and Video Services, on page 66Step 1

Add Teleconferencing Service Name Accounts, on page 66Step 2
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Configure Audio and Video Services
Integrate your on-premises Unified Communications environment with the Cisco WebEx Administration
Tool. See the following topics for more information:

• Getting started with Cisco Unified Communications Manager for Click to Call

• Creating Unified Communications Clusters

What to Do Next

Add Teleconferencing Service Name Accounts, on page 66

Add Teleconferencing Service Name Accounts
Users can make teleconference calls with either the default Cisco WebEx audio service or a third-party
teleconference provider.

To integrate the third-party teleconference provider audio services with Cisco WebEx, you must add
teleconferencing service name accounts. After you add those accounts, users can make teleconference calls
with the third-party provider audio services.

For more information about adding teleconferencing service name accounts, see the Cisco WebEx Site
Administration User's Guide.

Before You Begin

Configure Audio and Video Services, on page 66

   Cisco Jabber 11.0 Deployment and Installation Guide
66

Configure Voice and Video Communication
Configure Audio and Video Services



C H A P T E R  9
Configure Voicemail

• Configure Voicemail for an On-Premises Deployment with Cisco Unified Communications Manager
Release 9.x and Later, page 67

• Configure Voicemail for an On-Premises Deployment with Cisco Unified Communications Manager
Release 8.6, page 68

• Configure Cisco Unity Connection for Use with Cisco Jabber, page 69

• Configure Voicemail Accounts on Cisco Unity Connection, page 70

• Add a Voicemail Service, page 70

• Add a Mailstore Service, page 72

• Add a Voicemail Server, page 74

• Create a Mailstore, page 75

• Create a Voicemail Profile, page 76

• Configure Retrieval and Redirection, page 76

• Set a Voicemail Credentials Source, page 77

• Enable Enhanced Message Waiting Indicator, page 78

• Configure Voicemail for Cloud-Based Deployments, page 79

Configure Voicemail for an On-Premises Deployment with Cisco
Unified Communications Manager Release 9.x and Later

Procedure

PurposeCommand or Action

Configure Cisco Unity Connection so that Cisco
Jabber can access voicemail services.

Configure Cisco Unity Connection for
Use with Cisco Jabber, on page 69

Step 1
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PurposeCommand or Action

Add a Voicemail Service, on page 70Step 2

To configure Cisco Unity Connection, you must
create user profiles and then provide users with IMAP
access.

Configure Voicemail Accounts on Cisco
Unity Connection, on page 70

Step 3

After you add a voicemail service, you must apply
it to a service profile so that the client can retrieve
the settings.

Apply a Voicemail Service, on page 71Step 4

Add a Mailstore Service, on page 72Step 5

After you add a mailstore service, you must apply it
to a service profile so that the client can retrieve the
settings.

Apply Mailstore Service, on page 73Step 6

Configure retrieval so that users can access voice
mail messages. Configure redirection so that users
can send incoming calls to voicemail.

Configure Retrieval and Redirection, on
page 76

Step 7

Set a Voicemail Credentials Source, on
page 77

Step 8

This procedure applies only if you want to set up a
basic voicemail account that allows users to dial in

Enable Enhanced Message Waiting
Indicator, on page 78

Step 9

to their voice mailbox. This procedure is not required
if you want to set up visual voicemail.

Configure Voicemail for an On-Premises Deployment with Cisco
Unified Communications Manager Release 8.6

Procedure

PurposeCommand or Action

Configure Cisco Unity Connection for Use with Cisco Jabber, on
page 69

Step 1

Add a Voicemail Server, on page 74Step 2

Create a Mailstore, on page 75Step 3

Create a Voicemail Profile, on page 76Step 4

Configure Retrieval and Redirection, on page 76Step 5

Set a Voicemail Credentials Source, on page 77Step 6
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Configure Cisco Unity Connection for Use with Cisco Jabber
You must complete some specific steps to configure Cisco Unity Connection so that Cisco Jabber can access
voicemail services. You should refer to the Cisco Unity Connection documentation for instructions on general
tasks such as creating users, passwords, and provisioning users with voicemail access.

Cisco Jabber connects to the voicemail service through a REST interface and supports Cisco Unity
Connection release 8.5 or later.

Remember

Procedure

Step 1 Ensure the Connection Jetty and Connection REST Service services are started.
a) Open the Cisco Unity Connection Serviceability interface.
b) Select Tools > Service Management.
c) Locate the following services in the Optional Services section:

• Connection Jetty

• Connection REST Service

d) Start the services if required.

Step 2 Open the Cisco Unity Connection Administration interface.
Step 3 Edit user password settings.

a) Select Users.
b) Select the appropriate user.
c) Select Edit > Password Settings.
d) SelectWeb Application from the Choose Password menu.
e) Uncheck User Must Change at Next Sign-In.
f) Select Save.

Step 4 Provide users with access to the web inbox.
a) Select Class of Service.

The Search Class of Service window opens.

b) Select the appropriate class of service or add a new class of service.
c) Select Allow Users to Use the Web Inbox and RSS Feeds.
d) In the Features section, select Allow Users to Use Unified Client to Access Voice Mail.
e) Select all other options as appropriate.
f) Select Save.

Step 5 Select API configuration settings.
a) Select System Settings > Advanced > API Settings.

The API Configuration window opens.

b) Select the following options:
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• Allow Access to Secure Message Recordings through CUMI

• Display Message Header Information of Secure Messages through CUMI

• Allow Message Attachments through CUMI

c) Select Save.

What to Do Next

• If you have Cisco Unified Communications Manager release 9.x and later, Add a Voicemail Service,
on page 70.

• If you have Cisco Unified Communications Manager release 8.x, Add a Voicemail Server, on page 74.

Configure Voicemail Accounts on Cisco Unity Connection
To configure Cisco Unity Connection, you must create user profiles and then provide users with IMAP access.

See the Cisco Unity Connection documentation for specific configuration tasks.

Before You Begin

Add a Voicemail Service, on page 70

Procedure

Step 1 Create user profiles on Cisco Unity Connection.
Step 2 Provide users with IMAP access.

a) Open the Cisco Unity Connection administrative interface.
b) Select Class of Service.

The Edit Class of Service window opens.

c) Locate the Licensed Features section.
d) Select Allow Users to Access Voice Mail Using an IMAP Client and/or Single Inbox.
e) Select Allow IMAP Users to Access Message Bodies.
f) Select Save.

What to Do Next

Apply a Voicemail Service, on page 71

Add a Voicemail Service
Allow users to receive voice messages.
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Before You Begin

Configure Cisco Unity Connection for Use with Cisco Jabber, on page 69

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.
Step 3 In the Find and List UC Services window, select Add New.
Step 4 In the Add a UC Service section, select Voicemail from the UC Service Type drop-down list and select

Next
Step 5 Specify details for the voicemail service as follows:

• Product Type— Select Unity Connection.

• Name— Enter a descriptive name for the server, for example, PrimaryVoicemailServer.

• Hostname/IP Address— Enter the IP address or the fully qualified domain name (FQDN) of the
voicemail server.

• Port—You do not need to specify a port number. By default, the client always uses port 443 to connect
to the voicemail server. For this reason, any value you specify does not take effect.

• Protocol Type—You do not need to specify a value. By default, the client always uses HTTPS to connect
to the voicemail server. For this reason, any value you specify does not take effect.

Step 6 Select Save.

What to Do Next

Configure Voicemail Accounts on Cisco Unity Connection, on page 70

Apply a Voicemail Service
After you add a voicemail service on Cisco Unified Communications Manager, you must apply it to a service
profile so that the client can retrieve the settings.

Before You Begin

Configure Voicemail Accounts on Cisco Unity Connection, on page 70

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

Step 3 Find and select your service profile.
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The Service Profile Configuration window opens.

Step 4 Configure the Voicemail Profile section as follows:
a) Select up to three services from the following drop-down lists:

• Primary

• Secondary

• Tertiary

b) For Credentials source for voicemail service, select one of the following:

• Unified CM - IM and Presence— Uses the instant messaging and presence credentials to sign in
to the voicemail service. As a result, users do not need to enter their credentials for voicemail services
in the client.

•Web conferencing— This option is not supported, it uses the conferencing credentials to sign in
to the voicemail service. You cannot currently synchronize with conferencing credentials.

• Not set— This option is selected for Phone mode deployments.

Step 5 Click Save.
Step 6 Add users to the service profile.

a) Select User Management > End User.
The Find and List Users window opens.

b) Specify the appropriate filters in the Find User where field and then select Find to find a user.
c) Click the user in the list.

The End User Configuration window opens.

d) Under the Service Settings area, check the Home Cluster checkbox.
e) For Phone mode deployments, ensure the Enable User for Unified CM IM and Presence (Configure

IM and Presence in the associated UC Service Profile) option is not selected.
For all other deployments, check the Enable User for Unified CM IM and Presence (Configure IM
and Presence in the associated UC Service Profile) checkbox.

f) Select your service profile from the UC Service Profile drop-down list.
g) Click Save.

What to Do Next

Add a Mailstore Service, on page 72

Add a Mailstore Service
The mailstore service provides users with visual voicemail capabilities.

Before You Begin

Apply a Voicemail Service, on page 71
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.
Step 3 Select Add New.
Step 4 In theAdd a UC Service section, from theUC Service Type drop-down list, selectMailStore and then click

Next.
Step 5 Provide details for the mailstore service as follows:

• Name—Enter a descriptive name for the server, for example, PrimaryMailStoreServer.

• Hostname/IP Address—Enter the IP address or the Fully Qualified Domain Name (FQDN) of the
mailstore server.

• Port—You do not need to specify a port number. By default, the client always uses port 443 to connect
to the mailstore server. For this reason, any value you specify does not take effect.

• Protocol Type—You do not need to specify a value. By default, the client always uses HTTPS to connect
to the mailstore server. For this reason, any value you specify does not take effect.

Step 6 Select Save.

What to Do Next

Apply Mailstore Service, on page 73

Apply Mailstore Service
After you add a mailstore service on Cisco Unified Communications Manager, you must apply it to a service
profile so that the client can retrieve the settings.

Before You Begin

Add a Mailstore Service, on page 72

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

Step 3 Find and select your service profile.
The Service Profile Configuration window opens.

Step 4 Configure theMailStore Profile section as follows:
a) Select up to three services from the following drop-down lists:
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• Primary

• Secondary

• Tertiary

b) Specify appropriate values for the following fields:

• Inbox Folder

• Trash Folder

• Polling Interval

Step 5 Select Save.

What to Do Next

Configure Retrieval and Redirection, on page 76

Add a Voicemail Server
Complete the steps in this task to add your voicemail server on Cisco Unified Presence.

Before You Begin

Configure Cisco Unity Connection for Use with Cisco Jabber, on page 69

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > Voicemail Server.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified
Personal Communicator > Voicemail Server.

Note

The Find and List Voicemail Servers window opens.
Step 3 Select Add New.
Step 4 Select Unity Connection from the Server Type drop-down list.
Step 5 Specify details in the Voicemail Server Configuration section as follows:

• Name— Enter a descriptive name for the server, for example, PrimaryVoicemailServer.

• Hostname/IP Address— Enter the IP address or the fully qualified domain name (FQDN) of the
voicemail server.

• Port—You do not need to specify a port number. By default, the client always uses port 443 to connect
to the voicemail server. For this reason, any value you specify does not take effect.

• Protocol Type— You do not need to specify a value. By default, the client always uses HTTPS to
connect to the voicemail server. For this reason, any value you specify does not take effect.

   Cisco Jabber 11.0 Deployment and Installation Guide
74

Configure Voicemail
Add a Voicemail Server



Step 6 Select Save.

What to Do Next

Create a Mailstore, on page 75

Related Topics

Configuring Voicemail Server Names and Addresses on Cisco Unified Presence

Create a Mailstore
Complete the steps in this task to create a mailstore on Cisco Unified Presence.

Before You Begin

Ensure that you have Cisco Unified Communications Manager release 8.x and Cisco Unified Presence.

If you have Cisco Unified Communications Manager release 9.x or later, see Add a Mailstore Service, on
page 72.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Depending on your version of Cisco Unified Presence, select one of the following paths:

• Application > Cisco Jabber >Mailstore

• Application > Cisco Unified Personal Communicator >Mailstore

The Find and List Mailstore Servers window opens.
Step 3 Select Add New.

TheMailstore Configuration window opens.
Step 4 Specify details as follows:

• Name—Enter a descriptive name for the server, for example, PrimaryMailStoreServer.

• Hostname/IP Address—Enter the hostname, IP Address, or Fully Qualified Domain Name (FQDN)
of the mailstore server.

• Port—You do not need to specify a port number. By default, the client always uses port 443 to connect
to the mailstore server. For this reason, any value you specify does not take effect.

• Protocol Type—You do not need to specify a value. By default, the client always uses HTTPS to connect
to the mailstore server. For this reason, any value you specify does not take effect.

Step 5 Select Save.
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Create a Voicemail Profile
After you add a voicemail server, you must create a voicemail profile and add that server to the profile.

Before You Begin

Create a Mailstore, on page 75

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Depending on your version of Cisco Unified Presence, select one of the following:

• Application > Cisco Jabber > Voicemail Profile

• Application > Cisco Unified Personal Communicator > Voicemail Profile

The Find and List Voicemail Profiles window opens.
Step 3 Select Add New.

The Voicemail Profile Configuration window opens.
Step 4 Specify the required details.
Step 5 Add users to the voicemail profile as follows:

a) Select Add Users to Profile.
b) To retrieve a list of users, in the Find User where field, specify the appropriate filters and then select

Find.
c) Select the appropriate users from the list.
d) Select Add Selected.

The selected users are added to the voicemail profile.

Step 6 Select Save.

What to Do Next

Configure Retrieval and Redirection, on page 76

Configure Retrieval and Redirection
Configure retrieval so that users can access voicemail messages in the client interface. Configure redirection
so that users can send incoming calls to voicemail. You configure retrieval and redirection on Cisco Unified
Communications Manager.

Before You Begin

If you have Cisco Unified Communications Manager release 9.x and later, Apply Mailstore Service, on page
73.

If you have Cisco Unified Communications Manager release 8.x, Create a Voicemail Profile, on page 76.

   Cisco Jabber 11.0 Deployment and Installation Guide
76

Configure Voicemail
Create a Voicemail Profile



Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Configure the voicemail pilot.

a) Select Advanced Features > Voice Mail > Voice Mail Pilot.
The Find and List Voice Mail Pilots window opens.

b) Select Add New.
The Voice Mail Pilot Configuration window opens.

c) Specify the appropriate details on the Voice Mail Pilot Configuration window.
d) Select Save.

Step 3 Add the voicemail pilot to the voicemail profile.
a) Select Advanced Features > Voice Mail > Voice Mail Profile.

The Find and List Voice Mail Profiles window opens.

b) Specify the appropriate filters in the Find Voice Mail Profile where Voice Mail Profile Name field and
then select Find to retrieve a list of profiles.

c) Select the appropriate profile from the list.
The Voice Mail Pilot Configuration window opens.

d) Select the voicemail pilot from the Voice Mail Pilot drop-down list.
e) Select Save.

Step 4 Specify the voicemail profile in the directory number configuration.
a) Select Device > Phone.

The Find and List Phones window opens.

b) Specify the appropriate filters in the Find Phone where field and then select Find to retrieve a list of
devices.

c) Select the appropriate device from the list.
The Phone Configuration window opens.

d) Locate the Association Information section.
e) Select the appropriate device number.

The Directory Number Configuration window opens.

f) Locate the Directory Number Settings section.
g) Select the voicemail profile from the Voice Mail Profile drop-down list.
h) Select Save.

What to Do Next

Set a Voicemail Credentials Source, on page 77

Set a Voicemail Credentials Source
You can specify a voicemail credentials source for users.
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In hybrid cloud-based deployments, you can set a voicemail credentials source as part of your configuration
file with the VoiceMailService_UseCredentialsForm parameter.

Tip

Before You Begin

Configure Retrieval and Redirection, on page 76

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.
Step 3 Select the appropriate service profile to open the Service Profile Configuration window.
Step 4 In the Voicemail Profile section, select Unified CM - IM and Presence from the Credentials source for

voicemail service drop-down list.
Do not selectWeb Conferencing from the Credentials source for voicemail service drop-down
list. You cannot currently use conferencing credentials as a credentials source for voicemail services.

Note

The user's instant messaging and presence credentials match the user's voicemail credentials. As a result, users
do not need to specify their voicemail credentials in the client user interface.

What to Do Next

There is no mechanism to synchronize credentials between servers. If you specify a credentials source,
you must ensure that those credentials match the user's voicemail credentials.

For example, you specify that a user's instant messaging and presence credentials match the user's Cisco
Unity Connection credentials. The user's instant messaging and presence credentials then change. You
must update the user's Cisco Unity Connection credentials to reflect that change.

Cloud-Based deployments can use the configuration file parameter VoicemailService_UseCredentialsFrom.
Set this parameter to the value phone to use the Cisco Unified Communications Manager credentials to
sign in to Cisco Unity Connection.

Important

If you have Cisco Unified CommunicationsManager release 9.x and later, Enable EnhancedMessageWaiting
Indicator, on page 78.

Enable Enhanced Message Waiting Indicator
This procedure applies only if you want to set up a basic voicemail account that allows users to dial in to their
voice mailbox. This procedure is not required if you want to set up visual voicemail.

A Message Waiting Indicator (MWI) alerts users to the presence of new voice messages. Enhanced MWI
provides a count of new voice messages on systems that support this feature. Users can call the voice messaging
system to retrieve the messages.
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To enable the basic MWI, follow the instructions in the Cisco Unified Communications Manager
documentation for your release. There are no unique configurations for this client.

If your deployment supports Enhanced MWI, enable this option in the Cisco Unity Connection
Administration portal.

Note

Before You Begin

Set a Voicemail Credentials Source, on page 77

Procedure

Step 1 Open the Cisco Unity Connection Administration interface.
Step 2 In the left pane, navigate to Telephony Integrations > Phone System.
Step 3 Select the link for the desired phone system.
Step 4 In the Message Waiting Indicators section, select the Send Message Counts check box.

Configure Voicemail for Cloud-Based Deployments
Procedure

PurposeCommand or Action

Configure Voicemail, on page 79Step 1

Allow Users to Set Voicemail Server Settings, on page 79Step 2

Configure Voicemail
To configure your voicemail settings, use the Cisco WebEx Administration Tool.

What to Do Next

Allow Users to Set Voicemail Server Settings, on page 79

Allow Users to Set Voicemail Server Settings
Select an option with the CiscoWebEx Administration Tool so that users can specify voicemail server settings
in the client interface.
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Before You Begin

Configure Voicemail, on page 79

Procedure

Step 1 Open the Cisco WebEx Administration Tool.
Step 2 Select Configuration > Unified Communications.
Step 3 Select the Voicemail tab.
Step 4 Select Allow user to enter manual settings.

The user can access advanced voicemail settings in the Voicemail Accounts tab on the Options window in
the client interface.

The user can access advanced voicemail settings in the client interface by tapping Settings > Voicemail.
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C H A P T E R  10
Configure Conferencing

• Configure Conferencing for an On-Premises Deployment, page 81

• Configure Conferencing for a Cloud-Based Deployment using Cisco WebEx Meeting Center, page 90

Configure Conferencing for an On-Premises Deployment
When you implement an on-premises deployment for Cisco Jabber, you can configure conferencing on-premises
with Cisco WebEx Meetings Server, or in the cloud in Cisco WebEx Meetings Center.

Configure On-Premises Conferencing using WebEx Meetings Server

Procedure

PurposeCommand or Action

Authenticate CiscoWebExMeetings Server, on
page 82.

Step 1

Complete this task if you have Cisco Unified
Communications Manager release 9.x and
later.

Add Cisco WebEx Meetings Server on Cisco
Unified CommunicationsManager, on page 82.

Step 2

Complete this task if you have Cisco Unified
Communications Manager Release 8.6 and
Cisco Unified Presence.

Add Cisco WebEx Meetings Server on Cisco
Unified Presence, on page 84.

Step 3
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Authenticate Cisco WebEx Meetings Server

Procedure

To authenticate with Cisco WebEx Meetings Server, complete one of the following options:

• Configure single sign-on (SSO) with Cisco WebEx Meetings Server to integrate with the SSO
environment. In this case, you do not need to specify credentials for users to authenticate with Cisco
WebEx Meetings Server

• Set a credentials source on Cisco Unified Communications Manager. If the users' credentials for Cisco
WebEx Meetings Server match their credentials for Cisco Unified Communications Manager IM and
Presence Service or Cisco Unity Connection, you can set a credentials source. The client then
automatically authenticates to Cisco WebEx Meetings Server with the users' credential source.

• Instruct users to manually enter credentials in the client.

What to Do Next

Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager, on page 82

Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager
To configure conferencing on Cisco Unified CommunicationsManager, youmust add a CiscoWebExMeetings
Server.

Before You Begin

Authenticate Cisco WebEx Meetings Server, on page 82

Procedure

Step 1 Open the Cisco Unified CMAdministration interface and select User Management > User Settings > UC
Service.
The Find and List UC Services window opens.

Step 2 Select Add New.
Step 3 In the Add a UC Service section, from the UC Service Type drop-down list, select Conferencing and then

select Next.
Step 4 Complete the following fields:

• Product Type— SelectWebEx (Conferencing).

• Name— Enter a name for the configuration. The name you specify is displayed when you add services
to profiles. Ensure the name you specify is unique, meaningful, and easy to identify.

• Hostname/IP Address— Enter the site URL for Cisco WebEx Meetings Server. This URL is case
sensitive and must match the case that was configured for the site URL in CiscoWebExMeetings Server.

• Port— Leave the default value.

• Protocol— Select HTTPS.
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Step 5 To use Cisco WebEx as the single sign-on (SSO) identity provider, check User web conference server as
SSO identity provider.

This field is available only if you selectWebEx (Conferencing) from the Product Type drop-down
list.

Note

Step 6 Select Save.

What to Do Next

Add the Cisco WebEx Meetings Server to a Service Profile, on page 83

Add the Cisco WebEx Meetings Server to a Service Profile

After you add CiscoWebExMeetings Server and add it to a service profile, the client can access conferencing
features.

Before You Begin

Create a service profile.

Add Cisco WebEx Meetings Server on Cisco Unified Communications Manager, on page 82

Procedure

Step 1 Open the Cisco Unified CM Administration interface and select User Management > User Settings >
Service Profile

Step 2 Find and select your service profile.
Step 3 In the Conferencing Profile section, from the Primary, Secondary, and Tertiary drop-down lists, select up

to three instances of Cisco WebEx Meetings Server.
Step 4 From the Server Certificate Verification drop-down list, select the appropriate value.
Step 5 From the Credentials source for web conference service drop-down list, select one of the following:

• Not set—Select this option if the user does not have a credentials source that matches their CiscoWebEx
Meetings Server credentials or if you use SSO at the meeting site.

• Unified CM - IM and Presence—Select this option if the Cisco Unified Communications Manager IM
and Presence Service credentials for the user match their Cisco WebEx Meetings Server credentials.

• Voicemail—Select this option if the Cisco Unity Connection credentials for the user match their Cisco
WebEx Meetings Server credentials.

You cannot synchronize the credentials you specify in Cisco Unified CommunicationsManager with
credentials you specify in Cisco WebEx Meetings Server. For example, if you specify that instant
messaging and presence credentials for a user are synchronized with their Cisco WebEx Meetings
Server credentials, the instant messaging and presence credentials for that user change. You must
update the Cisco WebEx Meetings Server credentials for that user to match that change.

Note

Step 6 Select Save.
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Add Cisco WebEx Meetings Server on Cisco Unified Presence

Before You Begin

Add the Cisco WebEx Meetings Server to a Service Profile, on page 83

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Depending on your version of Cisco Unified Presence, select one of the following:.

• Application > Cisco Jabber > Conferencing Server

• Application > Cisco Unified Personal Communicator > Conferencing Server

Step 3 Select Add New.
The Conferencing Server Configuration window opens.

Step 4 Complete the following fields:

• Name— Enter a name for the configuration. The name is displayed when you add services to profiles.

• Hostname/IP Address— Enter the site URL for Cisco WebEx Meetings Server.

• Port— Accept the default value.

• Protocol— Select HTTPS.

• Server Type— SelectWebEx.

• Site ID— You do not need to specify a value for this field.

• Partner ID— You do not need to specify a value for this field.

Step 5 Select Save.

What to Do Next

Add Cisco WebEx Meetings Server to a Profile, on page 84

Add Cisco WebEx Meetings Server to a Profile

After you add Cisco WebEx Meetings Server on Cisco Unified Presence and add it to a service profile, the
client can access conferencing features.

Before You Begin

Add Cisco WebEx Meetings Server on Cisco Unified Presence, on page 84
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Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Depending on your version of Cisco Unified Presence, select one of the following:

• Application > Cisco Jabber > Conferencing Profile

• Application > Cisco Unified Personal Communicator > Conferencing Profile

Step 3 Select Add New.
The Conferencing Profile Configuration window opens.

Step 4 Complete the following fields:

• Name— Enter a name for the configuration.

• Description— Enter an optional description.

• Primary Conferencing Server— Select the primary instance of Cisco WebEx Meetings Server.

• Backup Conferencing Server— Select the backup instance of Cisco WebEx Meetings Server.

Step 5 From the Server Certificate Verification drop-down list, select one of the following:

• Any Certificate

• Self Signed or Keystore

• Keystore Only

Step 6 To set this profile as the system default, checkMake this the default Conferencing Profile for the system.
Step 7 In the Users in Profile section, select Add Users to Profile.
Step 8 In the Find and List Users window, select Find to retrieve a list of users.
Step 9 Select the appropriate users from the list and then select Add Selected.

The selected users are added to the profile.
Step 10 Select Save.

Configure Cloud-Based Conferencing Using WebEx Meeting Center

Procedure

PurposeCommand or Action

Integration with Cisco WebEx Meeting Center, on page 86.Step 1

Authenticate the client with
Cisco WebExMeeting Center

Authentication with Cisco WebEx Meeting Center, on page 86.Step 2

using tightly coupled
integration.
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PurposeCommand or Action

Provide conferencing
credentials to the client.

Provide Conferencing Credentials, on page 86.Step 3

Depending on your version of Cisco Unified Communications
Manager, select one of the following:

Step 4

• If you haveCiscoUnified CommunicationsManager release
9.x and later with Cisco Unified CommunicationsManager
IM and Presence Service, Add Cisco WebEx Meeting
Center, on page 87.

• If you have Cisco Unified Communications Manager
Release 8.6 with Cisco Unified Presence, Set Up Cisco
WebEx Meeting Center on Cisco Unified Presence , on
page 88.

Integration with Cisco WebEx Meeting Center
To integrate with Cisco WebEx Meeting Center in an on-premises deployment, select one of the following
integration options:

• Cloud-based integration— Cisco WebEx Meeting Center provides data, such as participant chat and
roster lists, and audio and video capabilities.

• Hybrid cloud-based integration— Cisco WebEx Meeting Center provides data, such as participant chat
and roster lists, and a conferencing bridge provides audio and video capabilities.

Authentication with Cisco WebEx Meeting Center
You can authenticate the client with Cisco WebEx Meeting Center using tightly coupled integration. Tightly
coupled integration refers to a configuration that you set up between Cisco WebEx Messenger and Cisco
WebEx Meeting Center. When users authenticate with Cisco WebEx Messenger, it passes an authentication
token back to the client. The client then passes that authentication token to Cisco WebEx Meeting Center.
See the Overview of Tightly Coupled Integration topic for more information.

Provide Conferencing Credentials
Choose one of the following methods to provide conferencing credentials to the client:

• Users individually specify their credentials in the Options window.

• Users individually specify their credentials in theMeetings tab on the Preferences window.

• You specify a credentials source on Cisco Unified Communications Manager when you apply the
conferencing service to the service profile. See the topic in this section that describes how to add the
conferencing server to the service profile for instructions.
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Add Cisco WebEx Meeting Center
The first step to setting up conferencing on Cisco Unified Communications Manager is to add your details
for Cisco WebEx Meeting Center.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.
Step 3 Select Add New.
Step 4 In the Add a UC Service section, from the UC Service Type drop-down list, select Conferencing and then

select Next.
Step 5 Complete the following fields:

• Product Type— SelectWebEx (Conferencing).

• Name— Enter a name for the configuration. The name is displayed when you add services to profiles.
Ensure the name you specify is unique, meaningful, and easy to identify.

• Description— Enter an optional description.

• Host Name/IP Address— Enter the Cisco WebEx Meeting Center site hostname. Do not enter an IP
address.

• Port— Enter the Cisco WebEx Meeting Center site port number.

• Protocol— Select HTTPS.

Step 6 To use Cisco WebEx as the single sign-on (SSO) identity provider, checkUser web conference server as
SSO identity provider.

This field is available only if you selectWebEx (Conferencing) as the Product
Type.

Note

Step 7 Select Save.

What to Do Next

Add Cisco WebEx Meeting Center to a service profile.

Add Cisco WebEx Meeting Center to a Profile

After you add Cisco WebEx Meeting Center on Cisco Unified Communications Manager, you add Cisco
WebEx Meeting Center to a service profile. The client can then retrieve the details for Cisco WebEx Meeting
Center from the profile and access the conferencing features.

Before You Begin

Create a service profile.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List Service Profiles window opens.

Step 3 Find and select your service profile.
The Service Profile Configuration window opens.

Step 4 Configure the Conferencing Profile section as follows:
a) Select your service from the Primary drop-down list.

The client uses only the service you select from the Primary drop-down list. You do not need to
select services from the Secondary or Tertiary drop-down lists.

Note

b) Select the appropriate value from the Server Certificate Verification drop-down list.
c) Select one of the following from the Credentials source for web conference service drop-down list:

• Not set— The user does not have a credentials source that matches their Cisco WebEx Meeting
Center credentials.

• Unified CM - IM and Presence— The user’s Cisco Unified Communications Manager IM and
Presence Service credentials match their Cisco WebEx Meeting Center credentials.

• Voicemail— The user’s Cisco Unity Connection credentials match their Cisco WebEx Meeting
Center credentials.

You cannot specify a credentials source if you use an identity provider for authentication
with Cisco WebEx Meeting Center.

Restriction

If you select a credentials source, you must ensure that those credentials match the user’s
Cisco WebEx Meeting Center credentials.

There is no mechanism to synchronize the credentials you specify in Cisco Unified
Communications Manager with credentials you specify in Cisco WebEx Meeting Center.
For example, you specify that a user’s instant messaging and presence credentials are
synchronized with the user’s Cisco WebEx Meeting Center credentials. The user’s instant
messaging and presence credentials then change. You must update the user’s Cisco WebEx
Meeting Center credentials to match that change.

Important

Step 5 Select Save.

Set Up Cisco WebEx Meeting Center on Cisco Unified Presence
The client retrieves Cisco WebEx Meeting Center details from the conferencing profile on Cisco Unified
Presence. You must add:

• Details for Cisco WebEx Meeting Center

• A Cisco WebEx Meeting Center profile

• Users to the Cisco WebEx Meeting Center profile
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Add Cisco WebEx Meeting Center

The first step to setting up conferencing on Cisco Unified Presence is to add your details for Cisco WebEx
Meeting Center.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > Conferencing Server.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified Personal
Communicator > Conferencing Server.

Step 3 Select Add New.
The Conferencing Server Configuration window opens.

Step 4 Specify details for Cisco WebEx Meeting Center in the following fields:

• Name— Enter a name for the configuration. The name you specify displays when you add services to
profiles.

• Hostname/IP Address— Specify the hostname of the Cisco WebEx Meeting Center site.
You must specify a hostname, not an IP
address.

Note

• Port— Specify a port number for the Cisco WebEx Meeting Center site.

• Protocol— Select HTTPS from the drop-down list.

• Server Type— SelectWebEx from the drop-down list.

• Site ID— Specify the optional primary site ID for Cisco WebEx Meeting Center.

• Partner ID— Specify the optional appropriate partner ID for Cisco WebEx Meeting Center.

Step 5 Select Save.

Add Cisco WebEx Meeting Center to a Profile

After you add Cisco WebEx Meeting Center on Cisco Unified Presence, you add Cisco WebEx Meeting
Center to a conferencing profile. The client can then retrieve the details for Cisco WebEx Meeting Center
from the profile and access the conferencing features.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > Conferencing Profile.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified Personal
Communicator > Conferencing Profile.

Step 3 Select Add New.
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The Conferencing Profile Configuration window opens.

Step 4 Specify details for the profile in the following fields:

• Name— Enter a name for the configuration.

• Description— Enter an optional description.

• Primary Conferencing Server— Select the primary Cisco WebEx Meeting Center site from the
drop-down list.

The client uses only the site you select from the Primary Conferencing Server drop-down
list. You do not need to select a site from the Backup Conferencing Server drop-down list.

Note

• Server Certificate Verification— Select one of the following from the drop-down list:

• Any Certificate

• Self Signed or Keystore

• Keystore Only

Step 5 Select theMake this the default Conferencing Profile for the system checkbox to set this profile as the
system default.

Step 6 Add users to the conferencing profile as follows:
a) Select Add Users to Profile in the Users in Profile section.

The Find and List Users dialog box opens.

b) Select Find to retrieve a list of users.
c) Select the appropriate users from the list.
d) Select Add Selected.

The selected users are added to the profile and the Find and List Users dialog box closes.

Step 7 Select Save.

Configure Conferencing for a Cloud-Based Deployment using
Cisco WebEx Meeting Center

Youmust configure the appropriate settings with the CiscoWebEx Administration Tool and assign the meeting
and conferencing capabilities to the appropriate users.

You can add additional Cisco WebEx meeting sites in the Cisco Jabber client. However, you cannot add a
meeting site that is configured for SSO, this site must be created in the Cisco WebEx Administration Tool.

Authentication with Cisco WebEx Meeting Center
• Tightly Coupled Integration with the Cisco WebEx Messenger Service— Tightly coupled integration
refers to a configuration that you set up between Cisco WebEx Messenger and Cisco WebEx Meeting
Center.
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When users authenticate with Cisco WebEx Messenger, it passes an authentication token back to the
client. The client then passes that authentication token to Cisco WebEx Meeting Center.

See the Overview of Tightly Coupled Integration topic for more information.

• Authentication with an Identity Provider— The client can redirect authentication from Cisco WebEx
Meeting Center to an identity provider.

To enable authentication with an identity provider, complete the following steps:

1 Set up your identity provider as appropriate.

When users attempt to authenticate with Cisco WebEx Meeting Center, the client redirects that
authentication to your identity provider. Your identity provider then validates the credentials and
passes an authentication token back to the client. The client then passes that token to Cisco WebEx
Meeting Center to complete the authentication process.

2 Specify Cisco WebEx Meeting Center credentials in the client interface.

See the Using SSO with the Cisco WebEx and Cisco WebEx Meeting applications topic for more
information about managing user identities with the Cisco WebEx Messenger service.

You can authenticate the client with Cisco WebEx Meeting Center using tightly coupled integration. Tightly
coupled integration refers to a configuration that you set up between Cisco WebEx Messenger and Cisco
WebEx Meeting Center. When users authenticate with Cisco WebEx Messenger, it passes an authentication
token back to the client. The client then passes that authentication token to Cisco WebEx Meeting Center.
See the Overview of Tightly Coupled Integration topic for more information.

Specify Conferencing Credentials in the Client
Users can specify their credentials in theMeetings tab on the Options window.

To open the Options window, select File > Options.

Users can specify their credentials in the Settings.

On the Settings screen, under Accounts, tapWebEx Meeting.

Users can specify their credentials in theMeetings tab on the Preferences window.
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C H A P T E R  11
Configure Client

• Introduction to Client Configuration, page 93

• Configure Service Profiles, page 94

• Create and Host Client Configuration Files, page 101

• Configure Proxy Settings, page 108

• Configure Problem Reporting, page 109

• Configure Automatic Updates, page 110

• Custom Embedded Tabs for Cisco Jabber for Windows, page 112

Introduction to Client Configuration
Cisco Jabber can retrieve configuration settings from the following sources:

• Service Profiles— You can configure some client settings in UC service profiles on Cisco Unified
Communications Manager release 9 and later. When users launch the client, it discovers the Cisco
Unified Communications Manager home cluster using a DNS SRV record and automatically retrieves
the configuration from the UC service profile.

Applies to on-premises deployments only.

• Phone Configuration— You can set some client settings in the phone configuration on Cisco Unified
Communications Manager release 9 and later. The client retrieves the settings from the phone
configuration in addition to the configuration in the UC service profile.

Applies to on-premises deployments only.

• Cisco Unified CommunicationsManager IM and Presence Service—You can enable instant messaging
and presence capabilities and configure certain settings such as presence subscription requests.

In theAdvanced settingswindow, if you select eitherCisco IM&Presence orCisco Communications
Manager 8.x, the client retrieves UC services from Cisco Unified Presence or Cisco Unified
Communications Manager IM and Presence Service. The client does not use service profiles or SSO
discovery.

Applies to on-premises deployments only.
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• Client Configuration Files—You can create XML files that contain configuration parameters. You then
host the XML files on a TFTP server. When users sign in, the client retrieves the XML file from the
TFTP server and applies the configuration.

Applies to on-premises and cloud-based deployments.

• Cisco WebEx Administration Tool— You can configure some client settings with the Cisco WebEx
Administration Tool.

Applies to cloud-based deployments only.

Configure Service Profiles
You can configure some client settings in UC service profiles on Cisco Unified Communications Manager
version 9 and later.

Important • Cisco Jabber only retrieves configuration from service profiles on Cisco Unified Communications
Manager if the client gets the _cisco-uds SRV record from a DNS query.

In a hybrid environment, if the CAS URL lookup is successful Cisco Jabber retrieves the
configurations from CiscoWebExMessenger service and the _cisco-uds SRV record is ignored.

• In an environment with multiple Cisco Unified CommunicationsManager clusters, you can configure
the Intercluster Lookup Service (ILS). ILS enables the client to find the user's home cluster and
discover services.

If you do not configure ILS, then you must manually configure remote cluster information, similar
to the EMCC remote cluster set up. For more information on Remote Cluster Configuration, see the
Cisco Unified Communications Manager Features and Services Guide.

Related Topics

Remote Cluster Configuration on Cisco Unified Communications Manager 10.0

Set Parameters on Service Profile
The client can retrieve UC service configuration and other settings from service profiles.

Parameters in Service Profiles
Learn which configuration parameters you can set in service profiles. Review the corresponding parameters
in the client configuration file.

IM and Presence Service Profile

The following table lists the configuration parameters you can set in the IM and Presence Service profile:
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DescriptionParameter

Provides the source of authentication to Cisco Jabber
and has the following values:

• Unified CM (IM and Presence Service)— Cisco
Unified Communications Manager IM and
Presence Service is the authenticator.

•WebEx (IM and Presence Service)— The Cisco
WebEx Messenger service is the authenticator.

As of this release, the client issues an
HTTP query in addition to the query for
SRV records. The HTTP query allows
the client to determine if it should
authenticate to the Cisco WebEx
Messenger service.

As a result of the HTTP query, the client
connects to the Cisco WebEx Messenger
service in cloud-based deployments
before getting the _cisco-uds SRV
record. Setting the value of the Product
type field toWebEx may have no
practical effect if the WebEx service has
already been discovered by a CAS
lookup.

Note

• Not set— If the service profile does not contain
an IM and presence service configuration, the
authenticator is Cisco Unified Communications
Manager.

Product type

Specifies the address of your primary presence server.

• On-Premises Deployments—You should specify
the fully qualified domain name (FQDN) of Cisco
Unified Communications Manager IM and
Presence Service.

• Cloud-Based Deployments— The client uses the
followingURL as default when you selectWebEx
as the value for the Product type parameter:
https://loginp.webexconnect.com/cas/auth.do

This default URL overrides any value that you
set.

Primary server

Voicemail Profile

The following table lists the configuration parameters you can set in the voicemail profile:
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DescriptionParameter

Specifies connection settings for the voicemail server.Voicemail server

Specifies that the client uses the credentials for the
instant messaging and presence or conferencing service
to authenticate with the voicemail service.

Ensure that the credentials source that you set match
the user's voicemail credentials. If you set a value for
this parameter, users cannot specify their voicemail
service credentials in the client user interface.

Credentials source for voicemail service

Conferencing Profile

The following table lists the configuration parameters you can set in the conferencing profile:
DescriptionConferencing Service Configuration

Specifies connection settings for the conferencing
server.

Conferencing server

Specifies that the client uses the credentials for the
instant messaging and presence or voicemail service
to authenticate with the conferencing service.

Ensure that the credentials source that you set match
the user's conferencing credentials.

Credentials source for web conference service

Directory Profile

See the Client Configuration for Directory Integration chapter for information about configuring directory
integration in a service profile.

CTI Profile

The following table lists the configuration parameters you can set in the CTI profile:
DescriptionCTI Service Configuration

Specifies connection settings for the CTI server.CTI server

Add Cisco Unified Communications Manager Services
Add Cisco Unified Communications Manager services to specify the address, ports, protocols, and other
settings for services such as IM and Presence Service, voicemail, conferencing, and directory.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.

Step 3 Select Add New.
The UC Service Configuration window opens.

Step 4 Select the UC service type you want to add and then select Next.
Step 5 Configure the UC service as appropriate and then select Save.

What to Do Next

Add your UC services to service profiles.

Create Service Profiles
After you add and configure Cisco Unified Communications Manager services, you add them to a service
profile. You can apply additional configuration in the service profile.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > Service Profile.

The Find and List UC Services window opens.

Step 3 Select Add New.
The Service Profile Configuration window opens.

Step 4 Enter a name for the service profile in the Name field.
Step 5 SelectMake this the default service profile for the system if you want the service profile to be the default

for the cluster.
On Cisco Unified CommunicationsManager release 9.x only, users who have only instant messaging
capabilities (IM only) must use the default service profile. For this reason, you should set the service
profile as the default if you plan to apply the service profile to IM only users.

Note

Step 6 Add your UC services, apply any additional configuration, and then select Save.

What to Do Next

Apply service profiles to end user configuration.
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Apply Service Profiles
After you add UC services and create a service profile, you apply the service profile to users. When users
sign in to Cisco Jabber, the client can then retrieve the service profile for that user from Cisco Unified
Communications Manager.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > End User.

The Find and List Users window opens.

Step 3 Enter the appropriate search criteria to find existing users and then select a user from the list.
The End User Configuration window opens.

Step 4 Locate the Service Settings section.
Step 5 Select a service profile to apply to the user from the UC Service Profile drop-down list.

Cisco Unified Communications Manager release 9.x only: If the user has only IIM and
Presence Service capabilities (IM only), you must select Use Default. For IM only users, Cisco
Unified CommunicationsManager release 9.x always applies the default service profile regardless
of what you select from the UC Service Profile drop-down list.

Important

Step 6 Apply any other configuration as appropriate and then select Save.

Associate Users with Devices
On Cisco Unified Communications Manager version 9.x only, when the client attempts to retrieve the service
profile for the user, it first gets the device configuration file from Cisco Unified Communications Manager.
The client can then use the device configuration to get the service profile that you applied to the user.

For example, you provision Adam McKenzie with a CSF device named CSFAKenzi. The client retrieves
CSFAKenzi.cnf.xml fromCisco Unified CommunicationsManager whenAdam signs in. The client then
looks for the following in CSFAKenzi.cnf.xml:
<userId serviceProfileFile="identifier.cnf.xml">amckenzi</userId>

For this reason, if you are using Cisco Unified Communications Manager version 9.x, you should do the
following to ensure that the client can successfully retrieve the service profiles that you apply to users:

• Associate users with devices.

• Set the User Owner ID field in the device configuration to the appropriate user. The client will retrieve
the Default Service Profile if this value is not set.

A CSF should not be associated to multiple users if you intend to use different service profiles for these
users.

Note
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Procedure

Step 1 Associate users with devices.
a) Open the Unified CM Administration interface.
b) Select User Management > End User.
c) Find and select the appropriate user.

The End User Configuration window opens.
d) Select Device Association in the Device Information section.
e) Associate the user with devices as appropriate.
f) Return to the End User Configuration window and then select Save.

Step 2 Set the User Owner ID field in the device configuration.
a) Select Device > Phone.
b) Find and select the appropriate device.

The Phone Configuration window opens.
c) Locate the Device Information section.
d) Select User as the value for the Owner field.
e) Select the appropriate user ID from the Owner User ID field.
f) Select Save.

Set Parameters on Phone Configuration for Desktop Clients
The client can retrieve configuration settings in the phone configuration from the following locations on Cisco
Unified Communications Manager:

Enterprise Phone Configuration

Applies to the entire cluster.

For users with only IM and Presence Service capabilities (IM only), you must
set phone configuration parameters in the Enterprise Phone Configuration
window.

Note

Common Phone Profile Configuration

Applies to groups of devices and takes priority over the cluster configuration.

Cisco Unified Client Services Framework (CSF) Phone Configuration

Applies to individual CSF devices and takes priority over the group configuration.
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Parameters in Phone Configuration
The following table lists the configuration parameters you can set in the Product Specific Configuration
Layout section of the phone configuration and maps corresponding parameters from the client configuration
file:

DescriptionDesktop Client Settings Configuration

Enables or disables video capabilities.

Enabled (default)

Users can send and receive video calls.

Disabled

Users cannot send or receive video calls.

This parameter is available only on the CSF
device configuration.

Restriction

Video Calling

Restricts users from transferring specific file types.

Set a file extension as the value, for example, .exe.

Use a semicolon to delimit multiple values, for example,
.exe;.msi;.rar;.zip

File Types to Block in File Transfer

Sets the phone type for users when the client starts for the
first time. Users can change their phone type after the initial
start. The client then saves the user preference and uses it
for subsequent starts.

Enabled

Use the desk phone device for calls.

Disabled (default)

Use the software phone (CSF) device for calls.

Automatically Start in Phone Control

Specifies the URL to the XML file that holds client update
information. The client uses this URL to retrieve the XML
file from your web server.

In hybrid cloud-based deployments, you should use the Cisco
WebEx Administration Tool to configure automatic updates.

Jabber For Windows Software Update
Server URL

Specifies the URL for the custom script that allows users to
submit problem reports.

Problem Report Server URL
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Set Parameters on Phone Configuration for Mobile Clients
The client can retrieve configuration settings in the phone configuration from the following locations on Cisco
Unified Communications Manager:

• Cisco Dual Mode for iPhone (TCT) Configuration— Applies to individual TCT devices and takes
priority over the group configuration.

• Cisco Jabber for Tablet (TAB) Configuration— Applies to individual TAB devices and takes priority
over the group configuration.

Parameters in Phone Configuration
The following table lists the configuration parameters you can set in the Product Specific Configuration
Layout section of the phone configuration and maps corresponding parameters from the client configuration
file:

DescriptionParameter

URL for initiating on-demand VPN.
Applicable for iOS
only.

Note
On-Demand VPN URL

Enter the SSIDs for Wi-Fi networks (SSIDs) approved by
your organization. Separate SSIDs with a forward slash (/).
Devices do not connect to secure connect if connected to one
of the entered Wi-Fi networks.

Preset Wi-fi Networks

Sets the default ringtone to Normal or Loud.Default Ringtone

Enables or disables video capabilities.

• Enabled (default)— Users can send and receive video
calls.

• Disabled— Users cannot send or receive video calls.

Video Capabilities

Enables or disables Dial via Office.

• Enabled— Users can dial via office.

• Disabled (default)— Users cannot dial via office.

Dial via Office
TCT and BOT devices
only.

Note

Create and Host Client Configuration Files
For on-premises and hybrid cloud-based deployments, create client configuration files and host them on the
Cisco Unified Communications Manager TFTP service.
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For cloud-based deployments, configure the client with the Cisco WebEx Administration Tool. However,
you can optionally set up a TFTP server to configure the client with settings that are not available in Cisco
WebEx Administration Tool.

For Cisco Jabber for iPhone and iPad and Cisco Jabber for Android, you must create a global configuration
file to set up:

• Directory integration for on-premises deployments.

• Voicemail service credentials for hybrid-cloud deployments.

In most environments, Cisco Jabber forWindows and Cisco Jabber forMac do not require any configuration
to connect to services. Create a configuration file only if you require custom content such as automatic
updates, problem reporting, or user policies and options.

Note

Before You Begin

Note the following configuration file requirements:

• Configuration filenames are case-sensitive. Use lowercase letters in the filename to prevent errors and
to ensure the client can retrieve the file from the TFTP server.

• You must use utf-8 encoding for the configuration files.

• The client cannot read configuration files that do not have a valid XML structure. Check the structure
of your configuration file for closing elements and confirm that elements are nested correctly.

• Valid XML character entity references only are permitted in your configuration file. For example, use
&amp; instead of &. If your XML contains invalid characters, the client cannot parse the configuration
file.
To validate your configuration file, open the file in Microsoft Internet Explorer.

◦If Internet Explorer displays the entire XML structure, your configuration file does is valid.

◦If Internet Explorer displays only part of the XML structure, it is likely that your configuration file
contains invalid characters or entities.

Procedure

PurposeCommand or Action

Specify your TFTP server address for client to
enable access to your configuration file.

Specify Your TFTP Server Address, on
page 103

Step 1

Configure the clients for users in your deployment.Create Global Configurations, on page
105

Step 2

Apply different configuration to different set of
users.

Create Group Configurations, on page
106

Step 3

Host configuration files on any TFTP server.Host Configuration Files, on page 106Step 4
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PurposeCommand or Action

Restart the TFTP server before the client can
access the configuration files.

Restart Your TFTP Server, on page 107Step 5

Specify Your TFTP Server Address
The client gets configuration files from a TFTP server. The first step in configuring the client is to specify
your TFTP server address so the client can access your configuration file.

If Cisco Jabber gets the _cisco-uds SRV record from a DNS query, it can automatically locate the
user's home cluster. As a result, the client can also locate the Cisco Unified Communications Manager
TFTP service.

You do not need to specify your TFTP server address if you deploy the _cisco-uds SRV record.

Attention

Specify Your TFTP Server on Cisco Unified Presence
If you are using Cisco Unified CommunicationsManager release 8.x, complete the steps to specify the address
of your TFTP server on Cisco Unified Presence. If you are using Cisco Unified Communications Manager
release 9.x, then you do not need to follow the steps below.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Jabber > Settings.

In some versions of Cisco Unified Presence, this path is as follows: Application > Cisco Unified
Personal Communicator > Settings.

Note

The Cisco Jabber Settings window opens.

Step 3 Locate the fields to specify TFTP servers in one of the following sections, depending on your version of Cisco
Unified Presence:

• Cisco Jabber Security Settings

• CUPC Global Settings

Step 4 Specify the IP address of your primary and backup TFTP servers in the following fields:

• Primary TFTP Server

• Backup TFTP Server

• Backup TFTP Server
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Ensure that you enter the fully qualified domain name (FQDN) or IP address for the TFTP servers
rather than a host name.

Note

Step 5 Select Save.

Specify Your TFTP Server on Cisco Unified Communications Manager IM and Presence Service
If you are using Cisco Unified Communications Manager release 9.x, then you do not need to follow the steps
below.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 Select Application > Legacy Clients > Settings.

The Legacy Client Settings window opens.

Step 3 Locate the Legacy Client Security Settings section.
Step 4 Specify the IP address of your primary and backup TFTP servers in the following fields:

• Primary TFTP Server

• Backup TFTP Server

• Backup TFTP Server

Step 5 Select Save.

Specify TFTP Servers in Phone Mode
If you deploy the client in phone mode you can provide the address of the TFTP server as follows:

• Users manually enter the TFTP server address when they start the client.

• You specify the TFTP server address during installation with the TFTP argument.

• You specify the TFTP server address in the Microsoft Windows registry.

Specify TFTP Servers with the Cisco WebEx Administration Tool
If the client connects to the Cisco WebEx Messenger service, you specify your TFTP server address with the
Cisco WebEx Administrator Tool.
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Procedure

Step 1 Open the Cisco WebEx Administrator Tool.
Step 2 Select the Configuration tab.
Step 3 Select Unified Communications in the Additional Services section.

The Unified Communications window opens.
Step 4 Select the Clusters tab.
Step 5 Select the appropriate cluster from the list.

The Edit Cluster window opens.
Step 6 SelectAdvanced Server Settings in theCisco Unified CommunicationsManager Server Settings section.
Step 7 Specify the IP address of your primary TFTP server in the TFTP Server field.
Step 8 Specify the IP address of your backup TFTP servers in the Backup Server #1 and Backup Server #2 fields.
Step 9 Select Save.

The Edit Cluster window closes.
Step 10 Select Save in the Unified Communications window.

Create Global Configurations
The client downloads the global configuration file from your TFTP server during the login sequence. Configure
the client for all users in your deployment.

Before You Begin

If the structure of your configuration file is not valid, the client cannot read the values you set. Review the
XML samples in this chapter for more information.

Procedure

Step 1 Create a file named jabber-config.xml with any text editor.

• Use lowercase letters in the filename.

• Use UTF-8 encoding.

Step 2 Define the required configuration parameters in jabber-config.xml.
Step 3 Host the group configuration file on your TFTP server.

If your environment has multiple TFTP servers, ensure that the configuration file is the same on all TFTP
servers.
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Create Group Configurations
Group configuration files apply to subsets of users and are supported on Cisco Jabber for Windows (CSF
devices) and on Cisco Jabber for mobile devices. Group configuration files take priority over global
configuration files.

If you provision users with CSF devices, specify the group configuration file names in the Cisco Support
Field field on the device configuration. If users do not have CSF devices, set a unique configuration file name
for each group during installation with the TFTP_FILE_NAME argument.

Before You Begin

• If the structure of your configuration file is not valid, the client cannot read the values you set. Review
the XML samples in this chapter for more information.

Procedure

Step 1 Create an XML group configuration file with any text editor.
The group configuration file can have any appropriate name; for example,jabber-groupa-config.xml.

Step 2 Define the required configuration parameters in the group configuration file.
Step 3 Add the group configuration file to applicable CSF devices.

a) Open the Cisco Unified CM Administration interface.
b) Select Device > Phone.
c) Find and select the appropriate CSF device to which the group configuration applies.
d) In the Phone Configuration window, navigate to Product Specific Configuration Layout > Desktop

Client Settings.
e) In the Cisco Support Field field, enter

configurationfile=group_configuration_file_name.xml. For example, enter
configurationfile=groupa-config.xml.

If you host the group configuration file on your TFTP server in a location other than the default
directory, you must specify the path and the filename; for example,
configurationfile=/customFolder/groupa-config.xml.

Do not add more than one group configuration file. The client uses only the first group
configuration in the Cisco Support Field field.

Note

f) Select Save.

Step 4 Host the group configuration file on your TFTP server.

Host Configuration Files
You can host configuration files on any TFTP server. However, Cisco recommends hosting configuration
files on the Cisco Unified Communications Manager TFTP server, which is the same as that where the device
configuration file resides.

   Cisco Jabber 11.0 Deployment and Installation Guide
106

Configure Client
Create Group Configurations



Procedure

Step 1 Open the Cisco Unified OS Administration interface on Cisco Unified Communications Manager.
Step 2 Select Software Upgrades > TFTP File Management.
Step 3 Select Upload File.
Step 4 Select Browse in the Upload File section.
Step 5 Select the configuration file on the file system.
Step 6 Do not specify a value in the Directory text box in the Upload File section.

You should leave an empty value in the Directory text box so that the configuration file resides in the default
directory of the TFTP server.

Step 7 Select Upload File.

Restart Your TFTP Server
You must restart your TFTP server before the client can access the configuration files.

Procedure

Step 1 Open the Cisco Unified Serviceability interface on Cisco Unified Communications Manager.
Step 2 Select Tools > Control Center - Feature Services.
Step 3 Select Cisco Tftp from the CM Services section.
Step 4 Select Restart.

A window displays to prompt you to confirm the restart.

Step 5 Select OK.
The Cisco Tftp Service Restart Operation was Successful status displays.

Step 6 Select Refresh to ensure the Cisco Tftp service starts successfully.

What to Do Next

To verify that the configuration file is available on your TFTP server, open the configuration file in any
browser. Typically, you can access the global configuration file at the following URL:
http://tftp_server_address:6970/jabber-config.xml

Configuration File
For detailed information on the jabber-config.xml configuration file structure, group elements, parameters,
and examples, see the Jabber Parameters Reference guide.
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Configure Proxy Settings
The client uses proxy settings to connect to services.

The following limitations apply when using a proxy for these HTTP requests:

• Proxy Authentication is not supported.

•Wildcards in the bypass list are not supported. Use example.com instead of *.example.com.

•Web Proxy Auto-Discovery (WPAD) protocol lookup is only supported for iOS devices.

• Cisco Jabber supports proxy for HTTP request using HTTP CONNECT, but does not support proxy
when using HTTPS CONNECT.

Configure Proxy Settings for Cisco Jabber for Windows
Configure proxy settings for Windows in the Local Area Network (LAN) settings for Internet properties.

Procedure

Step 1 In the Connections tab select LAN Settings.
Step 2 Configure a proxy using one of the following options:

• For automatic configuration, specify a .pac file URL.

• For Proxy Server, specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Mac
Configure proxy settings for Mac in System Preferences.

Procedure

Step 1 Select System Preferences > Network
Step 2 Choose your network service from the list and select Advanced > Proxies .
Step 3 Configure a proxy using one of the following options:

• For automatic configuration, specify a .pac file URL.

• For Proxy Server, specify an explicit proxy address.
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Configure Proxy Settings for Cisco Jabber iPhone and iPad
Configure proxy settings in the Wi-Fi settings of an iOS device using one of the following methods:

Procedure

Step 1 SelectWi-Fi > HTTP PROXY > Auto and use Web Proxy Auto-Discovery (WPAD) protocol lookup, do
not specify a .pac file URL.

Step 2 SelectWi-Fi > HTTP PROXY > Auto and specify a .pac file URL as the automatic configuration script.
Step 3 SelectWi-Fi > HTTP PROXY >Manual and specify an explicit proxy address.

Configure Proxy Settings for Cisco Jabber for Android

Procedure

Configure proxy settings in the Wi-Fi settings of an Android device using one of the following methods:

• Specify a .pac file URL as the automatic configuration script in theWi-Fi >Modify Network > Show
Advanced Options > Proxy Settings > Auto tab.

This method is only supported on devices with Android OS 5.0 and later, and Cisco DX series
devices.

Note

• Specify an explicit proxy address in theWi-Fi Networks >Modify Network > ShowAdvancedOptions
> Proxy Settings > Auto tab.

Configure Problem Reporting
Setting up problem reporting enables users to send a summary of issues that they encounter with the client.
There are two methods for submitting problem reports as follows:

• Users submit the problem report directly through the client interface.

• Users save the problem report locally and then upload it at a later time.

The client uses an HTTP POST method to submit problem reports. Create a custom script to accept the POST
request and specify the URL of the script on your HTTP server as a configuration parameter. Because users
can save problem reports locally, you should also create an HTML page with a form to enable users to upload
problem reports.

Before You Begin

Complete the following steps to prepare your environment:

1 Install and configure an HTTP server.
2 Create a custom script to accept the HTTP POST request.
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3 Create an HTML page that enables users to upload problem reports that are saved locally. Your HTML
page should contain a form that accepts the problem report saved as a .ZIP archive and contains an action
to post the problem report using your custom script.

The following is an example form that accepts problem reports:
<form name="uploadPrt" action="http://server_name.com/scripts/UploadPrt.php" method="post"
enctype="multipart/form-data">
<input type="file" name="zipFileName" id="zipFileName" /><br />
<input type="submit" name="submitBtn" id="submitBtn" value="Upload File" />
</form>

Procedure

Step 1 Host your custom script on your HTTP server.
Step 2 Specify the URL of your script as the value of the PrtLogServerUrl parameter in your configuration file.

Configure Automatic Updates
To enable automatic updates, you create an XML file that contains the information for the most recent version,
including the URL of the installation package on the HTTP server. The client retrieves the XML file when
users sign in, resume their computer from sleep mode, or perform a manual update request from the Help
menu.

If you use the CiscoWebExMessenger service for instant messaging and presence capabilities, you should
use the Cisco WebEx Administration Tool to configure automatic updates.

Note

Before You Begin

• Install and configure an HTTP server to host the XML file and installation package.

• Ensure users have permission to install software updates on their workstations.
Microsoft Windows stops update installations if users do not have administrative rights on their
workstations. You must be logged in with administrative rights to complete installation.

Procedure

Step 1 Host the update installation program on your HTTP server.
Step 2 Create an update XML file with any text editor.

XML files for automatic updates have the following structure:

<JabberUpdate>
<App name=”JabberWin”>

<LatestBuildNum>12345</LatestBuildNum>
<LatestVersion>10.5.x</LatestVersion>
<Mandatory>true</Mandatory>
<Message>
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<![CDATA[<b>This new version of Cisco Jabber lets you do the
following:</b><ul><li>Feature 1</li><li>Feature 2</li></ul>For
more information click <a target="_blank"
href="http://cisco.com/go/jabber">here</a>.]]>

</Message>
<DownloadURL>http://http_server_name/CiscoJabberSetup.msi</DownloadURL>

</App>
</JabberUpdate>

Step 3 Specify values in the XML as follows:

• name— Specify the following ID as the value of the name attribute for the App element:

• JabberWin— The update applies to Cisco Jabber for Windows.

• JabberMac— The update applies to Cisco Jabber for Mac.

• LatestBuildNum— Build number of the update.

• LatestVersion— Version number of the update.

• Mandatory— (Windows clients only) True or False. Determines whether users must upgrade their
client version when prompted.

• Message— HTML in the following format:

<![CDATA[your_html]]>

• DownloadURL— URL of the installation package on your HTTP server.

For Cisco Jabber for Mac the format of the URL file must be in the following format:
Cisco-Jabber-Mac-version-size-dsaSignature.zip

Example:
The following is example XML for automatic updates:
<JabberUpdate>
<App name="JabberWin">
<LatestBuildNum>12345</LatestBuildNum>
<LatestVersion>9.x</LatestVersion>
<Message><![CDATA[<b>This new version of Cisco Jabber lets you do the

following:</b><ul><li>Feature 1</li><li>Feature 2</li></ul>For
more information click <a target="_blank"

href="http://cisco.com/go/jabber">here</a>.]]></Message>
<DownloadURL>http://http_server_name/CiscoJabberSetup.msi</DownloadURL>

</App>
</JabberUpdate>

Example:
The following is an example XML for automatic updates for both Cisco Jabber forWindows and Cisco Jabber
for Mac:
<JabberUpdate>
<App name="JabberMac">
<LatestBuildNum>12345</LatestBuildNum>
<LatestVersion>9.6.1</LatestVersion>
<Message><![CDATA[<b>This new version of Cisco Jabber lets you do the

following:</b><ul><li>Feature 1</li><li>Feature 2</li>
</ul>For more information click <a target="_blank"

href="http://cisco.com/go/jabber">here</a>.]]>
</Message>
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<DownloadURL>http://http_server_name/Cisco-Jabber-Mac-9.6.1-12345-MrbCdd.zip</DownloadURL>

</App>
<App name="JabberWin">
<LatestBuildNum>12345</LatestBuildNum>
<LatestVersion>9.0</LatestVersion>
<Message><![CDATA[<b>This new version of Cisco Jabber lets you do the

following:</b><ul><li>Feature 1</li><li>Feature 2
</li></ul>For more information click <a target="_blank"

href="http://cisco.com/go/jabber">here</a>.]]>
</Message>
<DownloadURL>http://http_server_name/CiscoJabberSetup.msi
</DownloadURL>

</App>
</JabberUpdate>

Step 4 Save and close your update XML file.
Step 5 Host your update XML file on your HTTP server.
Step 6 Specify the URL of your update XML file as the value of the UpdateUrl parameter in your configuration file.

Custom Embedded Tabs for Cisco Jabber for Windows
Custom embedded tabs display HTML content in the client interface. Learn how to create custom embedded
tab definitions for Cisco Jabber.

Custom Embedded Tab Definitions
The custom embedded tab can only be configured using the jabber-config.xml file. The following
XML snippet shows the structure for custom tab definitions:
<jabber-plugin-config>
<browser-plugin>
<page refresh="" preload="">
<tooltip></tooltip>
<icon></icon>
<url></url>
</page>
</browser-plugin>
</jabber-plugin-config>

The following table describes the parameters for custom embedded tab definitions:
DescriptionParameter

Contains all definitions for custom embedded tabs.

The value includes all custom tab definitions.

browser-plugin

Contains one custom embedded tab definition.page
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DescriptionParameter

Controls when the content refreshes.

• true— Content refreshes each time users select the tab.

• false (default)— Content refreshes when users restart the client or sign
in.

This parameter is optional and is an attribute of the page element.

refresh

Controls when the content loads.

• true— Content loads when the client starts.

• false (default)— Content loads when users select the tab.

This parameter is optional and is an attribute of the page element.

preload

Defines hover text for the custom embedded tab.

This parameter is optional. If you do not specify the hover text, the client will
use Custom tab.

The value is string of unicode characters.

tooltip

Specifies an icon for the tab. You can specify a local or hosted icon as follows:

• Local icon— Specify the URL as follows:
file://file_path/icon_name

• Hosted icon— Specify the URL as follows:
http://path/icon_name

You can use any icon that Microsoft Internet Explorer can render, including
.JPG, .PNG, and .GIF formats.

This parameter is optional. If you do not specify an icon, the client loads the
favicon from the HTML page. If no favicon is available, the client loads the
default icon.

icon

Specifies the URL where the content for the embedded tab resides.

The client uses the Internet Explorer rendering engine to display the content
of the embedded tab. For this reason, you can specify any content that Internet
Explorer supports.

The client supports Internet Explorer version 9 or earlier. The client
uses Internet Explorer in version 9 mode if a later version is on the
workstation.

Note

This parameter is required.

url

Cisco Jabber 11.0 Deployment and Installation Guide    
113

Configure Client
Custom Embedded Tab Definitions



User Custom Tabs
Users can create their own custom embedded tabs through the client user interface.

You must enable users to create custom embedded tabs. Set true as the value for the AllowUserCustomTabs
parameter in your configuration file as follows:
<Options>
<AllowUserCustomTabs>true</AllowUserCustomTabs>

</Options>

User custom embedded tabs are set to true by default.Note

Custom Icons
To achieve optimal results, your custom icon should conform to the following guidelines:

• Dimensions: 20 x 20 pixels

• Transparent background

• PNG file format

Chats and Calls from Custom Tabs
You can use protocol handlers to start chats and calls from custom embedded tabs.

Use the XMPP: or IM: protocol handler to start chats.
Use the TEL: protocol handler to start audio and video calls.

Related Topics

Protocol Handlers, on page 234

UserID Tokens
You can specify the ${UserID} token as part of the value for the url parameter. When users sign in, the
client replaces the ${UserID} token with the username of the logged in user.

You can also specify the ${UserID} token in query strings; for example,
www.cisco.com/mywebapp.op?url=${UserID}.

Tip

The following is an example of how you can use the ${UserID} token:

1 You specify the following in your custom embedded tab:
<url>www.cisco.com/${UserID}/profile</url>

2 Mary Smith signs in. Her username is msmith.
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3 The client replaces the ${UserID} token with Mary's username as follows:
<url>www.cisco.com/msmith/profile</url>

JavaScript Notifications
You can implement JavaScript notifications in custom embedded tabs. This topic describes the methods the
client provides for JavaScript notifications. This topic also gives you an example JavaScript form that you
can use to test notifications. It is beyond the scope of this documentation to describe how to implement
JavaScript notifications for asynchronous server calls and other custom implementations. You should refer
to the appropriate JavaScript documentation for more information.

Notification Methods

The client includes an interface that exposes the following methods for JavaScript notifications:

• SetNotificationBadge— You call this method from the client in your JavaScript. This method takes a
string value that can have any of the following values:

• Empty— An empty value removes any existing notification badge.

• A number from 1 to 999

• Two digit alphanumeric combinations, for example, A1

• onPageSelected()— The client invokes this method when users select the custom embedded tab.

• onPageDeselected()— The client invokes this method when users select another tab.

• onHubResized()— The client invokes this method when users resize or move the client hub window.

• onHubActivated()— The client invokes this method when the client hub windows is activated.

• onHubDeActivated()— The client invokes this method when the client hub window is deactivated.

Subscribe to Presence in Custom Tabs

You can use the following JavaScript functions to subscribe to the presence of a contact and receive presence
updates from the client:

• SubscribePresence()— Specify a string value using the IM address of a user for this method.

• OnPresenceStateChanged— This method enables users to receive updates from the client on the presence
of a contact. You can specify one of the following values as the string:

• IM address

• Basic presence (Available, Away, Offline, Do Not Disturb)

• Rich presence (In a meeting, On a call, or a custom presence state)
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If you subscribe to the presence of a person who is not on your contact list (also called temporary presence
subscription), the subscription expires after 68minutes. After the subscription expires, youmust re-subscribe
to the person’s presence in order to continue to receive presence updates.

Note

Get Locale Information in Custom Tabs

You can use the following JavaScript functions to retrieve the current locale information of a contact from
the client:

• GetUserLocale()— This method enables users to request locale information from the client.

• OnLocaleInfoAvailable— This method enables users to receive locale information from client. You
can use a string value that contains the client locale information.

Example JavaScript

The following code is an example of an HTML page that uses JavaScript to display a form into which you
can input a number from 1 to 999:
<html>

<head>
<script type="text/javascript">

function OnPresenceStateChanged(jid, basicPresence,
localizedPresence)

{
var cell = document.getElementById(jid);
cell.innerText = basicPresence.concat(",

",localizedPresence);
}

function GetUserLocale()
{

window.external.GetUserLocale();
}

function SubscribePresence()
{

window.external.SubscribePresence('johndoe@example.com');
}

function OnLocaleInfoAvailable(currentLocale)
{

var cell = document.getElementById("JabberLocale");

cell.innerText = currentLocale;
}

function onHubActivated()
{

var cell = document.getElementById("hubActive");
cell.innerText = "TRUE";

}

function onHubDeActivated()
{

var cell = document.getElementById("hubActive");
cell.innerText = "FALSE";

}

function onHubResized()
{

alert("Hub Resized or Moved");
}
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function OnLoadMethods()
{

SubscribePresence();
GetUserLocale();

}
</script>

</head>

<body onload="OnLoadMethods()">
<table>

<tr>
<td>John Doe</td>
<td id="johndoe@example.com">unknown</td>

</tr>
</table>
<table>

<tr>
<td>Jabber Locale: </td>
<td id="JabberLocale">Null</td>

</tr>
<tr>

<td>Hub Activated: </td>
<td id="hubActive">---</td>

</tr>
</table>

</body>

</html>

To test this example JavaScript form, copy the preceding example into an HTML page and then specify that
page as a custom embedded tab.

Show Call Events in Custom Tabs
You can use the following JavaScript function to show call events in a custom tab:

OnTelephonyConversationStateChanged— An API in the telephony service enables the client to show call
events in a custom embedded tab. Custom tabs can implement the
OnTelephonyConversationStateChanged JavaScript function. The client calls this function every
time a telephony conversation state changes. The function accepts a JSON string that the client parses to get
call events.

The following snippet shows the JSON that holds the call events:
{

"conversationId": string,
"acceptanceState": "Pending" | "Accepted| | "Rejected",
"state": "Started" | "Ending" | "Ended",
"callType": "Missed" | "Placed" | "Received" | "Passive" | "Unknown",
"remoteParticipants": [{participant1}, {participant2}, …, {participantN}],
"localParticipant": {
}

}

Each participant object in the JSON can have the following properties:
{

"voiceMediaDisplayName": "<displayName>",
"voiceMediaNumber": "<phoneNumber>",
"translatedNumber": "<phoneNumber>",
"voiceMediaPhoneType": "Business" | "Home" | "Mobile" | "Other" | "Unknown",
"voiceMediaState": "Active" | "Inactive" | "Pending" | "Passive" | "Unknown",

}
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The following is an example implementation of this function in a custom embedded tab. This example gets
the values for the state and acceptanceState properties and shows them in the custom tab.
function OnTelephonyConversationStateChanged(json) {

console.log("OnTelephonyConversationStateChanged");
try {
var conversation = JSON.parse(json);
console.log("conversation id=" + conversation.conversationId);
console.log("conversation state=" + conversation.state);
console.log("conversation acceptanceState=" + conversation.acceptanceState);
console.log("conversation callType=" + conversation.callType);

}
catch(e) {
console.log("cannot parse conversation:" + e.message);

}
}

The following is an example implementation of this function with all possible fields:
function OnTelephonyConversationStateChanged(json) {

console.log("OnTelephonyConversationStateChanged");
try {
var conversation = JSON.parse(json);
console.log("conversation state=" + conversation.state);
console.log("conversation acceptanceState=" + conversation.acceptanceState);
console.log("conversation callType=" + conversation.callType);
for (var i=0; i<conversation.remoteParticipants.length; i++) {
console.log("conversation remoteParticipants[" + i + "]=");
console.log("voiceMediaDisplayName=" +

conversation.remoteParticipants[i].voiceMediaDisplayName);
console.log("voiceMediaNumber=" +

conversation.remoteParticipants[i].voiceMediaNumber);
console.log("translatedNumber=" +

conversation.remoteParticipants[i].translatedNumber);
console.log("voiceMediaPhoneType=" +

conversation.remoteParticipants[i].voiceMediaPhoneType);
console.log("voiceMediaState=" +

conversation.remoteParticipants[i].voiceMediaState);
}
console.log("conversation localParticipant=");
console.log(" voiceMediaDisplayName=" +

conversation.localParticipant.voiceMediaDisplayName);
console.log(" voiceMediaNumber=" + conversation.localParticipant.voiceMediaNumber);

console.log(" translatedNumber=" + conversation.localParticipant.translatedNumber);

console.log(" voiceMediaPhoneType=" +
conversation.localParticipant.voiceMediaPhoneType);

console.log(" voiceMediaState=" + conversation.localParticipant.voiceMediaState);
}
catch(e) {
console.log("cannot parse conversation:" + e.message);

}
}

Custom Embedded Tab Example
The following is an example of a configuration file with one embedded tab:
<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
<Client>
<jabber-plugin-config>
<browser-plugin>
<page refresh ="true" preload="true">
<tooltip>Cisco</tooltip>
<icon>http://www.cisco.com/web/fw/i/logo.gif</icon>
<url>www.cisco.com</url>
</page>
</browser-plugin>
</jabber-plugin-config>
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</Client>
</config>

Cisco Jabber 11.0 Deployment and Installation Guide    
119

Configure Client
Custom Embedded Tab Example



   Cisco Jabber 11.0 Deployment and Installation Guide
120

Configure Client
Custom Embedded Tab Example



C H A P T E R  12
Integrate with Directory Sources

• Integrate with Directory Sources for an On-Premises Deployment, page 121

• Configure Contact Sources, page 121

• Federation, page 128

• Client Configuration for Directory Integration, page 130

Integrate with Directory Sources for an On-Premises
Deployment

Before You Begin

Configure Directory Integration for an On-Premises Deployment, on page 7.

Procedure

PurposeCommand or Action

Configure Contact Sources, on page 121Step 1

Client Configuration for Directory Integration, on page 130Step 2

Configure Contact Sources
The client requires a contact source to search for users and to support contact resolution.

You can configure Enhanced Directory Integration (EDI), Basic Directory Integration (BDI), and Cisco
Unified Communications Manager User Data Service (UDS) as contact sources.
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Procedure

PurposeCommand or Action

EDI is an LDAP-based contact source and is the
default contact source used by Cisco Jabber for
Windows.

To configure EDI as a contact source, see
Domain Name Retrieval, on page 122 and
Directory Server Discovery, on page 123.

Step 1

BDI is an LDAP-based contact source and is the
default contact source used by Cisco Jabber for Mac,
iOS, and Android clients.

To configure BDI as a contact source, see
Authentication with Contact Sources, on
page 123.

Step 2

Cisco Unified Communications Manager UDS is a
Cisco Unified Communications Manager contact

To configure UDS as a contact source, see
Enable Integration with UDS, on page 126

Step 3

source and is available as a contact source for alland Set UDS Service Parameters, on page
127 Cisco Jabber clients. UDS is the contact source used

for Expressway Mobile and Remote Access.

Enhanced Directory Integration
Enhanced directory integration (EDI) uses native Microsoft Windows APIs to retrieve contact data from the
directory service.

Domain Name Retrieval
Cisco Jabber forWindows retrieves the fully qualified DNS domain from the USERDNSDOMAIN environment
variable on the client workstation.

After the client gets the DNS domain, it can locate the Domain Name Server and retrieve SRV records.

In some instances, the value of the USERDNSDOMAIN environment variable does not resolve to the DNS
domain that corresponds to the domain of the entire forest. For example, when an organization uses a
sub-domain or resource domain. In this case, the USERDNSDOMAIN environment variable resolves to a child
domain, not the parent domain. As a result, the client cannot access information for all users in the organization.

If the USERDNSDOMAIN environment variable resolves to a child domain, you can use one of the following
options to enable Cisco Jabber for Windows to connect to a service in the parent domain:

• Ensure that the Global Catalog or LDAP directory server can access all users in the organization.

• Configure your DNS server to direct the client to a server that can access all users in the organization
when Cisco Jabber for Windows requests a Global Catalog or LDAP directory server.

• Configure Cisco Jabber for Windows to use the FQDN of the parent domain.

Specify the FQDN of the parent domain as the value of the PrimaryServerName parameter in your client
configuration as follows:
<PrimaryServerName>parent-domain-fqdn</PrimaryServerName>
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Related Topics

Configuring DNS for the Forest Root Domain
Assigning the Forest Root Domain Name
Deploying a GlobalNames Zone
Support for DNS Namespace planning in Microsoft server products

Directory Server Discovery
Cisco Jabber can automatically discover and connect to the directory server if:

• The workstation on which you install Cisco Jabber is on the Microsoft Windows domain.

• The client can retrieve the address of the directory server from a DNS SRV record.

SRV RecordDirectory Server

_gc._msdcs._tcp.domain.comGlobal Catalog

_ldap._msdcs._tcp.domain.comDomain Controller

LDAP-based directory servers

Basic Directory Integration
BDI is an LDAP-based contact source and is the default contact source used by Cisco Jabber for Mac, iOS,
and Android clients.

Authentication with Contact Sources
BDI requires users to authenticate with the directory source to resolve contacts. You can use the following
methods to authenticate with the contact source, in order of priority:

• Specify credentials in Cisco Unified Presence or Cisco Unified Communications Manager— Specify
credentials in a profile on the server. The client can then retrieve the credentials from the server to
authenticate with the directory. This method is the most secure option for storing and transmitting
credentials.

• Set common credentials in the client configuration file— Specify a shared username and password in
the client configuration file. The client can then authenticate with the directory server.

The client transmits and stores these credentials as plain text.

Use a well-known or public set of credentials for an account that has read-only
permissions.

Important

• Use anonymous binds— Configure the client to connect to the directory source with anonymous binds.
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Specify LDAP Directory Configuration on Cisco Unified Presence

If your environment includes Cisco Unified Presence release 8.x, you can specify directory configuration in
the LDAP profile. The client can then get the directory configuration from the server to authenticate with the
directory source.

Complete the steps to create an LDAP profile that contains authentication credentials, and then assign that
profile to users.

Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Application > Cisco Unified Personal Communicator > LDAP Profile.
Step 3 Select Add New.
Step 4 Specify a name and optional description for the profile.
Step 5 Specify a distinguished name for a user ID that is authorized to run queries on the LDAP server. Cisco Unified

Presence uses this name for authenticated bind with the LDAP server.
Step 6 Specify a password that the client can use to authenticate with the LDAP server.
Step 7 Select Add Users to Profile and add the appropriate users to the profile.
Step 8 Select Save.

What to Do Next

Specify any additional BDI information in the client configuration file.

Specify LDAP Directory Configuration on Cisco Unified Communications Manager

If your environment includes Cisco Unified Communications Manager release 9.x and later, you can specify
credentials when you add a directory service. The client can then get the configuration from the server to
authenticate with the directory source.

Complete the steps to add a directory service, apply the directory service to the service profile, and specify
the LDAP authentication configuration for the directory service.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.
Step 3 Select Add New.

The UC Service Configuration window opens.
Step 4 In the Add a UC Service section, select Directory from the UC Service Type drop-down list.
Step 5 Select Next.
Step 6 Enter details for the directory service:

• Product Type— Select Directory
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• Name— Enter a unique name for the directory service

• Hostname/IP Address— Enter the Hostname, IP Address, or FQDN of the directory server.

• Protocol Type— From the drop-down list, select:

• TLS if you want Cisco Jabber to connect to the Directory by using TLS.

• TCP if you want Cisco Jabber to connect to the Directory by using TCP.

Step 7 Select Save.
Step 8 Apply the directory service to your service profile as follows:

a) Select User Management > User Settings > Service Profile.
The Find and List Service Profiles window opens.

b) Find and select your service profile.
The Service Profile Configuration window opens.

c) In the Directory Profile section, select up to three services from the Primary, Secondary, and Tertiary
drop-down lists:

d) Specify the Username and Password that the client can use to authenticate with the LDAP server in the
following fields:

e) Select Save.

Set Credentials in the Client Configuration

You can set credentials in the client configuration with the following parameters:

• BDIConnectionUsername

• BDIConnectionPassword

The client transmits and stores these credentials as plain text.

Use a well-known or public set of credentials for an account that has read-only permissions.

Important

The following is an example configuration:
<Directory>
<BDIConnectionUsername>admin@example.com</BDIConnectionUsername>
<BDIConnectionPassword>password</BDIConnectionPassword>

</Directory>

Use Anonymous Binds

To use anonymous binds, you set the following parameters in the client configuration file:

ValueParameter

BDIDirectoryServerType
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ValueParameter

IP address

FQDN

BDIPrimaryServerName

TrueBDIEnableTLS

Searchable organizational unit (OU) in the directory
tree

BDISearchBase1

Object class that your directory service uses; for
example, inetOrgPerson

BDIBaseFilter

UID or other search filter

A search filter is optional.

BDIPredictiveSearchFilter

The following is an example configuration:
<Directory>
<DirectoryServerType>BDI</DirectoryServerType>
<BDIPrimaryServerName>11.22.33.456</BDIPrimaryServerName>
<BDIEnableTLS>True</BDIEnableTLS>
<BDISearchBase1>ou=people,dc=cisco,dc=com</BDISearchBase1>
<BDIBaseFilter>(&amp;(objectClass=inetOrgPerson)</BDIBaseFilter>
<BDIPredictiveSearchFilter>uid</BDIPredictiveSearchFilter>

</Directory>

Cisco Unified Communications Manager User Data Service
User Data Service (UDS) is a REST interface on Cisco Unified Communications Manager that provides
contact resolution.

Enable Integration with UDS
To enable integration with UDS, perform the following steps:

Procedure

Step 1 Create your directory source in Cisco Unified Communications Manager.
Step 2 Synchronize the contact data to Cisco Unified Communications Manager.

After the synchronization occurs, your contact data resides in Cisco Unified Communications Manager.

Step 3 Specify UDS as the value of the DirectoryServerType parameter in your configuration file.
The following is an example configuration where UDS is the directory server type:
<Directory>
<DirectoryServerType>UDS</DirectoryServerType>
</Directory>
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This step is required only if you want to use UDS for all contact resolution (that is, both inside
and outside the firewall). If you configure Expressway for Mobile and Remote Access, the client
automatically uses UDS when outside the firewall, regardless of the value of the
DirectoryServerType parameter. When using Expressway for Mobile and Remote Access, you
can set the value of the DirectoryServerType parameter to either UDS or an LDAP-based contact
source for use inside the firewall.

Important

Step 4 For manual connections, specify the IP address of the Cisco Unified Communications Manager server to
ensure that the client can discover the server.
The following is an example configuration for the Cisco Unified Communications Manager server:
<UdsServer>11.22.33.444</UdsServer>

Step 5 Configure the client to retrieve contact photos with UDS.
The following is an example configuration for contact photo retrieval:
<UdsPhotoUriWithToken>http://server_name.domain/%%uid%%.jpg</UdsPhotoUriWithToken>

Set UDS Service Parameters
You can set service parameters for UDS on Cisco Unified Communications Manager.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Enterprise Parameters.

The Enterprise Parameters Configuration window opens.

Step 3 Locate the User Data Service Parameters section.

UDS Service Parameters

Set values for the following service parameters to configure UDS:
DescriptionParameter

Allows searches for all users in the directory (search
with no last name, first name, or directory number
specified).

The default value is true.

Enable All User Search

Limits the number of users returned in a query.

The default value is 64.

User Search Limit
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DescriptionParameter

Specifies the number of digits to match when users
search for phone numbers.

To resolve PSTN numbers, set the value equal
to the number of digits in the PSTN numbers.
For example, if the PSTN numbers have 10
digits, set the value to 10.

Tip

Number of Digits to Match

Contact Resolution with Multiple Clusters
For contact resolution with multiple Cisco Unified Communications Manager clusters, synchronize all users
on the corporate directory to each cluster. Provision a subset of those users on the appropriate cluster.

For example, your organization has 40,000 users. 20,000 users reside in North America. 20,000 users reside
in Europe. Your organization has the following Cisco Unified Communications Manager clusters for each
location:

• cucm-cluster-na for North America

• cucm-cluster-eu for Europe

In this example, synchronize all 40,000 users to both clusters. Provision the 20,000 users in North America
on cucm-cluster-na and the 20,000 users in Europe on cucm-cluster-eu.

When users in Europe call users in North America, Cisco Jabber retrieves the contact details for the user in
Europe from cucm-cluster-na.

When users in North America call users in Europe, Cisco Jabber retrieves the contact details for the user in
North America from cucm-cluster-eu.

Federation
Federation lets Cisco Jabber users communicate with users who are provisioned on different systems and who
are using client applications other than Cisco Jabber.

Configure Intradomain Federation for BDI or EDI
In addition to configuring intradomain federation on the presence server, you might need to specify some
configuration settings in the Cisco Jabber configuration files.

To resolve contacts during contact search or retrieve contact information from your directory, Cisco Jabber
requires the contact ID for each user. Cisco Unified Communications Manager IM & Presence server uses a
specific format for resolving contact information that does not always match the format on other presence
servers such as Microsoft Office Communications Server or Microsoft Live Communications Server.

The parameters that you use to configure intradomain federation depend on whether you use Enhanced
Directory Integration (EDI) or Basic Directory Integration (BDI). EDI uses native Microsoft Windows APIs
to retrieve contact data from the directory service and is only used by Cisco Jabber for Windows. For BDI,
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the client retrieves contact data from the directory service and is used by Cisco Jabber for Mac, Cisco Jabber
for Android, and Cisco Jabber for iPhone and iPad.

Procedure

Step 1 Set the value of the relevant parameter to true:

• For BDI: BDIUseSipUriToResolveContacts

• For EDI: UseSIPURIToResolveContacts

Step 2 Specify an attribute that contains the Cisco Jabber contact ID that the client uses to retrieve contact information.
The default value is msRTCSIP-PrimaryUserAddress, or you can specify another attribute in the
relevant parameter:

• For BDI: BDISipUri

• For EDI: SipUri

When you deploy intradomain federation and the client connects with Expressway for Mobile and
Remote Access from outside the firewall, contact search is supported only when the contact ID uses
one of the following formats:

Note

• sAMAccountName@domain

• UserPrincipleName (UPN)@domain

• EmailAddress@domain

• employeeNumber@domain

• phoneNumber@domain

Step 3 In the UriPrefix parameter, specify any prefix text that precedes each contact ID in the relevant SipUri
parameter.

Example:
For example, you specify msRTCSIP-PrimaryUserAddress as the value of SipUri. In your directory
the value of msRTCSIP-PrimaryUserAddress for each user has the following format:
sip:username@domain.

• For BDI: BDIUriPrefix

• For EDI: UriPrefix

The following XML snippet provides an example of the resulting configuration for BDI:
<Directory>
<BDIUseSIPURIToResolveContacts>true</BDIUseSIPURIToResolveContacts>
<BDISipUri>non-default-attribute</BDISipUri>
<BDIUriPrefix>sip:</BDIUriPrefix>

</Directory>

The following XML snippet provides an example of the resulting configuration for EDI:
<Directory>
<UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
<SipUri>non-default-attribute</SipUri>
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<UriPrefix>sip:</UriPrefix>
</Directory>

Client Configuration for Directory Integration
You can configure directory integration through service profiles using Cisco Unified CommunicationsManager
release 9 or later or with the configuration file. Use this section to learn how to configure the client for directory
integration.

When both a service profile and a configuration file are present, the following table describes which parameter
value takes precedence.

Which Parameter Value Takes
Precedence?

Configuration FileService Profile

Service profileParameter value is setParameter value is set

Service profileParameter value is blankParameter value is set

Configuration fileParameter value is setParameter value is blank

Service profile blank (default) valueParameter value is blankParameter value is blank

Cisco Unified Presence, Release 8.x profiles cannot be used for directory integration.Note

Configure Directory Integration in a Service Profile
With Cisco Unified CommunicationsManager release 9 and later, you can provision users with service profiles
and deploy the _cisco-uds SRV record on your internal domain server.

The client can then automatically discover Cisco Unified Communications Manager and retrieve the service
profile to get directory integration configuration. For information about service discovery, see Configure
Service Discovery.

Procedure

PurposeCommand or Action

Add a Directory Service, on page 131Step 1

Apply Directory Service to a Service Profile, on page 134Step 2

   Cisco Jabber 11.0 Deployment and Installation Guide
130

Integrate with Directory Sources
Client Configuration for Directory Integration



Add a Directory Service

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select User Management > User Settings > UC Service.

The Find and List UC Services window opens.
Step 3 Select Add New.

The UC Service Configuration window opens.
Step 4 Select Directory from the UC Service Type menu and then select Next.
Step 5 Set all appropriate values for the directory service and then select Save.

What to Do Next

Apply Directory Service.

Directory Profile Parameters

The following table lists the configuration parameters you can set in the directory profile:
DescriptionDirectory Service Configuration

Specifies the address of the primary directory server.

This parameter is required for manual connections where the
client cannot automatically discover the directory server.

Primary server

Specifies the address of the backup directory server.Secondary server

Specifies the address of the tertiary directory server.Tertiary Server

Specifies if the client uses UDS as a contact source.

When this option is selected the following
parameters are not used.

Important

By default, UDS provides contact resolution when users
connect to the corporate network through Expressway
for Mobile and Remote Access.

Note

Use UDS for Contact Resolution

Specifies if the client uses the logged on username and password.

True

Use credentials. This is the default value.

False

Do not use credentials.
Specify credentials with the BDIConnectionUsername
and BDIConnectionPassword parameters.

Use Logged On User Credential
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DescriptionDirectory Service Configuration

Lets you manually specify a shared username that the client can
use to authenticate with the directory server.

By default, the client uses Integrated Windows Authentication
when connecting to the directory server. This parameter lets you
manually specify a username in scenarios where it is not possible
to authenticate with the directory server with the user's Microsoft
Windows credentials.

Use only a well-known or public set of credentials for an account
that has read-only permissions.

Username

Lets you manually specify a shared password that the client can
use to authenticate with the directory server.

By default, the client uses Integrated Windows Authentication
when connecting to the directory server. This parameter lets you
manually specify a password in scenarios where it is not possible
to authenticate with the directory server with the user's Microsoft
Windows credentials.

Use only a well-known or public set of credentials for an account
that has read-only permissions.

Password

Specifies a location in the directory server from which searches
begin. In other words, a search base is the root from which the
client executes a search.

By default, the client searches from the root of the directory tree.
You can specify the value of up to three search bases in your
OU to override the default behavior.

Active Directory does not typically require a search base. Specify
search bases for Active Directory only for specific performance
requirements.

Specify a search base for directory servers other than Active
Directory to create bindings to specific locations in the directory.

Specify an OU to restrict searches to certain user groups.

For example, a subset of your users have instant
messaging capabilities only. Include those users in an
OU and then specify that as a search base.

Tip

Search Base 1

Search Base 2

Search Base 3

Specifies a location in the directory server fromwhich Enterprise
Group searches begin. In other words, a search base is the root
from which the client executes a search.

Group Search Base 1

Group Search Base 2

Group Search Base 3

Group Search Base 4

Group Search Base 5
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DescriptionDirectory Service Configuration

Select this option to perform a recursive search of the directory
starting at the search base. Use recursive searches to allow the
Cisco Jabber client contact search queries to search all of the
LDAP directory tree from a given search context (search base).
This is a common option when searching LDAP.

This is a required field.

The default value is True.

Recursive Search on All Search Bases

Specifies a base filter for Active Directory queries.

Specify a directory subkey name only to retrieve objects other
than user objects when you query the directory.

The default value is (&(objectCategory=person)(
objectClass=user).

Base Filter

Specifies a base filter for Enterprise Group Active Directory
queries.

Specify a directory subkey name only to retrieve objects other
than user objects when you query the directory.

The default value is
(&(objectCategory=group)(!(groupType:1.2.840.113556.1.4.803:=2147483648)).

Group Base Filter

Defines filters to apply to predictive search queries.

You can define multiple, comma-separated values to filter search
queries.

The default value is Ambiguous Name Resolution (ANR).

When Cisco Jabber for Windows performs a predictive search,
it issues a query using Ambiguous Name Resolution (ANR).
This query disambiguates the search string and returns results
that match the attributes that are set for ANR on your directory
server.

You must configure your directory server to set
attributes for ANR if you want the client to search
for those attributes.

Important

Predictive Search Filter

Service Discovery will use UDS search when the Use UDS for Contact Resolution option is selected,
otherwise it uses BDI or EDI search. During service discovery the Username, Password, SearchBase1,
PrimaryServerName, ServerPort1,UriPrefix,UseJabberCredentials,BaseFilter,PredictiveSearchFilter,
and DirectoryServerType in the directory profile will be used to connect to LDAP server for contact search.

Manual sign on uses the Username and Password from the directory profile to connect to the LDAP server
for contact search.
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Attribute Mappings

It is not possible to change the default attribute mappings in a service profile. If you plan to change any default
attribute mappings, you must define the required mappings in a client configuration file.

Apply Directory Service to a Service Profile

Procedure

Step 1 Select User Management > User Settings > Service Profile.
The Find and List Service Profiles window opens.

Step 2 Select Add New.
The Service Profile Configuration window opens.

Step 3 Add the directory services to the directory profile. See theDirectory Profile Parameters topic for information
about the specific settings that are needed for the directory profile.

Step 4 Select Save.

Advanced Directory Integration in the Configuration File
You can configure directory integration in the Cisco Jabber configuration file. For more information see the
Directory chapter in the Cisco Jabber 11.0 Parameters Reference Guide.

When a Service Profile and a configuration file are present, settings in the Service Profile always take
priority.

Important
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C H A P T E R  13
Install Client

• Install Cisco Jabber for Windows, page 135

• Install Cisco Jabber for Mac, page 157

• Install Cisco Jabber Mobile Clients, page 157

Install Cisco Jabber for Windows
Cisco Jabber for Windows provides an MSI installation package that you can use in the following ways:

• Use the Command Line—You can specify arguments in a command line window to set installation
properties.

Choose this option if you plan to install multiple instances.

• Run the MSI Manually—Run the MSI manually on the file system of the client workstation and then
specify connection properties when you start the client.

Choose this option if you plan to install a single instance for testing or evaluation purposes.

• Create a Custom Installer—Open the default installation package, specify the required installation
properties, and then save a custom installation package.

Choose this option if you plan to distribute an installation package with the same installation properties.

• Deploy with Group Policy—Install the client on multiple computers in the same domain.

Before You Begin

You must be logged in with local administrative rights.

Use the Command Line
Specify installation arguments in a command line window.
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Procedure

Step 1 Open a command line window.
Step 2 Enter the following command:

msiexec.exe /i CiscoJabberSetup.msi

Step 3 Specify command line arguments as parameter=value pairs.
msiexec.exe /i CiscoJabberSetup.msi argument=value

Step 4 Run the command to install Cisco Jabber for Windows.

Example Installation Commands
Review examples of commands to install Cisco Jabber for Windows.

Cisco Unified Communications Manager, Release 9.x
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1

Where:

CLEAR=1— Deletes any existing bootstrap file.
/quiet— Specifies a silent installation.

Cisco Unified Communications Manager, Release 8.x in Default Mode
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=CUP CUP_ADDRESS=1.2.3.4

Where:

CLEAR=1— Deletes any existing bootstrap file.
AUTHENTICATOR=CUP— Sets Cisco Unified Presence as the authenticator.
CUP_ADDRESS=1.2.3.4— Sets 1.2.3.4 as the IP address of the presence server.
/quiet— Specifies a silent installation.

Cisco Unified Communications Manager, Release 8.x in Phone Mode

If you are integrating with UDS when you are installing in phone mode, you must first define the
<PresenceDomain>Domain address of your Presence server</PresenceDomain> parameter.
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 PRODUCT_MODE=Phone_Mode AUTHENTICATOR=CUCM
TFTP=1.2.3.4 CTI=5.6.7.8

Where:

CLEAR=1— Deletes any existing bootstrap file.
PRODUCT_MODE=Phone_Mode— Sets the client to phone mode.
AUTHENTICATOR=CUCM— Sets Cisco Unified Communications Manager as the authenticator.
TFTP=1.2.3.4— Sets 1.2.3.4 as the IP address of the TFTP server that hosts the client configuration.
CTI=5.6.7.8— Sets 5.6.7.8 as the IP address of the CTI server.
/quiet— Specifies a silent installation.
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Cisco WebEx Messenger Service
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=WEBEX

Where:

CLEAR=1— Deletes any existing bootstrap file.
AUTHENTICATOR=WEBEX— Sets the Cisco WebEx Messenger service as the authenticator.
/quiet— Specifies a silent installation.

Cisco WebEx Messenger Service with SSO
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=WEBEX
SSO_ORG_DOMAIN=example.com

Where:

CLEAR=1— Deletes any existing bootstrap file.
AUTHENTICATOR=WEBEX— Sets the Cisco WebEx Messenger service as the authenticator.
SSO_ORG_DOMAIN=example.com— Sets example.com as the single sign-on (SSO) domain.
/quiet— Specifies a silent installation.

Command Line Arguments
Review the command line arguments you can specify when you install Cisco Jabber for Windows.

Override Argument

The following table describes the parameter you must specify to override any existing bootstrap files from
previous installations:

DescriptionValueArgument

Specifies if the client overrides any existing bootstrap
file from previous installations.

The client saves the arguments and values you set
during installation to a bootstrap file. The client then
loads settings from the bootstrap file at startup.

1CLEAR

If you specify CLEAR, the following occurs during installation:

1 The client deletes any existing bootstrap file.

2 The client creates a new bootstrap file.

If you do not specify CLEAR, the client checks for existing bootstrap files during installation.

• If no bootstrap file exists, the client creates a bootstrap file during installation.

• If a bootstrap file exists, the client does not override that bootstrap file and preserves the existing settings.
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If you are reinstalling Cisco Jabber for Windows, you should consider the following:Note

• The client does not preserve settings from existing bootstrap files. If you specify CLEAR, you must
also specify all other installation arguments as appropriate.

• The client does not save your installation arguments to an existing bootstrap file. If you want to
change the values for installation arguments, or specify additional installation arguments, you must
specify CLEAR to override the existing settings.

To override existing bootstrap files, specify CLEAR in the command line as follows:
msiexec.exe /i CiscoJabberSetup.msi CLEAR=1

Mode Type Argument

The following table describes the command line argument with which you specify the product mode:
DescriptionValueArgument

Specifies the product mode for the client. You can set
the following value:

• Phone_Mode—CiscoUnified Communications
Manager is the authenticator.

Choose this value to provision users with audio
devices as base functionality.

Phone_ModePRODUCT_MODE

When to Set the Product Mode
In phone mode deployments Cisco Unified Communications Manager is the authenticator. When the client
gets the authenticator, it determines the product mode is phone mode. However, because the client always
starts in the default product mode on the initial launch, users must restart the client to enter phone mode after
sign in.

• CiscoUnified CommunicationsManager, Release 9.x and Later—You should not set PRODUCT_MODE
during installation. The client gets the authenticator from the service profile. After the user signs in, the
client requires a restart to enter phone mode.

• Cisco Unified CommunicationsManager, Release 8.x—You can specify phone mode during installation
if you set Cisco Unified Communications Manager as the authenticator. The client reads the bootstrap
file on the initial launch and determines it should start in phone mode. The client then gets Cisco Unified
Communications Manager as the authenticator from the bootstrap file or manual settings. After the user
signs in, the client does not require a restart.

Change Product Modes
To change the product mode, you must change the authenticator for the client. The client can then determine
the product mode from the authenticator.

The method for changing from one product mode to another after installation, depends on your deployment.
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In all deployments, the user can manually set the authenticator in the Advanced settings window.

In this case, you must instruct the user to change the authenticator in the Advanced settings window to
change the product mode. You cannot override the manual settings, even if you uninstall and then reinstall
the client.

Note

Change Product Modes with Cisco Unified Communications Manager Version 9.x and Later
To change product modes with Cisco Unified Communications Manager version 9.x and later, you change
the authenticator in the service profile.

Procedure

Step 1 Change the authenticator in the service profiles for the appropriate users.

Change Default Mode > Phone Mode

Do not provision users with an IM and Presence service.

If the service profile does not contain an IM and presence service configuration, the authenticator is
Cisco Unified Communications Manager.

Change Phone Mode > Default Mode

Provision users with an IM and Presence service.

If you set the value of the Product type field in the IM and Presence profile to:

• Unified CM (IM and Presence) the authenticator is Cisco Unified Communications Manager
IM and Presence Service.

•WebEx (IM and Presence) the authenticator is the Cisco WebEx Messenger service.

Step 2 Instruct users to sign out and then sign in again.
When users sign in to the client, it retrieves the changes in the service profile and signs the user in to the
authenticator. The client then determines the product mode and prompts the user to restart the client.

After the user restarts the client, the product mode change is complete.

Change Product Modes with Cisco Unified Communications Manager Version 8.x
To change product modes with Cisco Unified CommunicationsManager version 8.x, you must reinstall Cisco
Jabber for Windows to change the authenticator.

Change Default Mode > Phone Mode

Set the following arguments, at a minimum:

• CLEAR=1 to delete any existing bootstrap file.

• AUTHENTICATOR=CUCM to set the authenticator to CiscoUnified CommunicationsManager.

• PRODUCT_MODE=Phone_Mode to set phone mode as the product mode.
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Change Phone Mode > Default Mode

Set the following arguments, at a minimum:

• CLEAR=1 to delete any existing bootstrap file.

• AUTHENTICATOR= one of the following:

• CUP to set the authenticator to Cisco Unified Presence or Cisco Unified Communications
Manager.

•WEBEX to set the authenticator to the Cisco WebEx Messenger service.

Authentication Arguments

The following table describe the command line arguments you can set to specify the source of authentication:
DescriptionValueArgument

Specifies the source of authentication for the client.
This value is used if Service Discovery fails. Set one
of the following as the value:

• CUP—Cisco Unified CommunicationsManager
IM and Presence. On-premises deployments in
the default product mode. The default product
mode can be either full UC or IM only.

• CUCM— Cisco Unified Communications
Manager. On-premises deployments in phone
mode.

•WEBEX— Cisco WebEx Messenger Service.
Cloud-based or hybrid cloud-based deployments.

In on-premises deployments with Cisco Unified
Communications Manager version 9.x and later, you
should deploy the _cisco-uds SRV record. The
client can then automatically determine the
authenticator.

CUP

CUCM

WEBEX

AUTHENTICATOR

Specifies the address of Cisco Unified Communications
Manager IM and Presence Service. Set one of the
following as the value:

• Hostname (hostname)

• IP address (123.45.254.1)

• FQDN (hostname.domain.com)

IP address

Hostname

FQDN

CUP_ADDRESS
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DescriptionValueArgument

Specifies the address of your TFTP server. Set one of
the following as the value:

• Hostname (hostname)

• IP address (123.45.254.1)

• FQDN (hostname.domain.com)

You should specify this argument if you set Cisco
Unified CommunicationsManager as the authenticator.

If you deploy:

• In phone mode, you should specify the address
of the TFTP server that hosts the client
configuration.

• In default mode, you can specify the address of
the Cisco Unified Communications Manager
TFTP service that hosts the device configuration.

IP address

Hostname

FQDN

TFTP

Sets the address of your CTI server.

Specify this argument if:

• You set Cisco Unified CommunicationsManager
as the authenticator.

• Users have desk phone devices and require a CTI
server.

IP address

Hostname

FQDN

CTI

Sets the address of your CCMCIP server.

Specify this argument if:

• You set Cisco Unified CommunicationsManager
as the authenticator.

• The address of your CCMCIP server is not the
same as the TFTP server address.

The client can locate the CCMCIP server with the
TFTP server address if both addresses are the
same.

Cisco Unified Communications Manager release 9.x
and earlier—If you enable Cisco Extension Mobility,
the Cisco Extension Mobility service must be
activated on the Cisco Unified Communications
Manager nodes that are used for CCMCIP. For
information about Cisco Extension Mobility, see the
Feature and Services guide for your Cisco Unified
Communications Manager release.

IP address

Hostname

FQDN

CCMCIP
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DescriptionValueArgument

Sets the value of the domain where the DNS SRV
records for Service Discovery reside.

This argument can be set to a domain where no DNS
SRV records reside if you want the client to use installer
settings or manual configuration for this information.
If this argument is not specified and Service Discovery
fails, the user will be prompted for services domain
information.

DomainSERVICES_DOMAIN

InHybrid Deployments the domain required to discover
Webex via CAS lookupmay be a different domain than
where the DNS records are deployed. If this is the case
then set the SERVICES_DOMAIN to be the domain
used forWebex discovery (or let the user enter an email
address) and set the VOICE_SERVICES_DOMAIN to
be the domain where DNS records are deployed. If this
setting is specified, the client will use the value of
VOICE_SERVICES_DOMAIN to lookup the following
DNS records for the purposes of Service Discovery and
Edge Detection:

• _cisco-uds

• _cuplogin

• _collab-edge

This setting is optional and if not specified, the DNS
records are queried on the Services Domain which is
obtained from the SERVICES_DOMAIN, email address
input by the user, or cached user configuration.

DomainVOICE_SERVICES_DOMAIN
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DescriptionValueArgument

Lists the services that you want Jabber to exclude from
Service Discovery. For example, you may have done
a trial with WebEx which means that your company
domain is registered on WebEx, but you do not want
Jabber users to authenticate using WebEx. You want
Jabber to authenticate with an on-premises CUP server.
In this case set:

• EXCLUDED_SERVICES=WEBEX

Possible values are CUP, CUCM, WEBEX.

To excludemore than one service, use comma separated
values. For example, to exclude CUP and CUCM,
specify: EXCLUDED_SERVICEs=CUP,CUCM. To
exclude all services, specify:
EXCLUDED_SERVICES=CUP,CUCM,WEBEX

If you exclude all services, you need to use manual
configuration or bootstrap configuration to configure
the Jabber client.

One or more of:

• CUP

•WEBEX

• CUCM

EXCLUDED_SERVICES

Allows you to define whether the client uses the User
Principal Name (UPN) of aWindows session to get the
domain for a user when discovering services.

• true (default) - The UPN is used to find the
domain of the user, which is used during service
discovery.

• false - The UPN is not used to find the domain of
the user. The user is prompted to enter credentials
to find the domain for service discovery.

Example installation command: msiexec.exe /i

CiscoJabberSetup.msi /quiet

UPN_DISCOVERY_ENABLED=false

true

false

UPN_DISCOVERY_ENABLED

TFTP Server Address
Cisco Jabber for Windows retrieves two different configuration files from the TFTP server:

• Client configuration files that you create.

• Device configuration files that reside on the Cisco Unified Communications Manager TFTP service
when you provision users with devices.

To minimize effort, you should host your client configuration files on the Cisco Unified Communications
Manager TFTP service. You then have only one TFTP server address for all configuration files and can specify
that address as required.

Cisco Jabber 11.0 Deployment and Installation Guide    
143

Install Client
Use the Command Line



You can, however, host your client configuration on a different TFTP server to the one that contains the device
configuration. In this case, you have two different TFTP server addresses, one address for the TFTP server
that hosts device configuration and another address for the TFTP server that hosts client configuration files.

Default Deployments

This section describes how you should handle two different TFTP server addresses in deployments that have
a presence server.

You should do the following:

1 Specify the address of the TFTP server that hosts the client configuration on the presence server.

2 During installation, specify the address of the Cisco Unified CommunicationsManager TFTP service with
the TFTP argument.

When the client starts for the first time, it:

1 Retrieves the address of the Cisco Unified Communications Manager TFTP service from the bootstrap
file.

2 Gets device configuration from the Cisco Unified Communications Manager TFTP service.

3 Connects to the presence server.

4 Retrieves the address of the TFTP service that hosts the client configuration from the presence server.

5 Gets client configuration from the TFTP server.

Phone Mode Deployments

This section describes how you should handle two different TFTP server addresses in phonemode deployments.

You should do the following:

1 During installation, specify the address of the TFTP server that hosts the client configuration with the
TFTP argument.

2 Specify the address of the TFTP server that hosts the device configuration in your client configuration file
with the following parameter: TftpServer1.

3 Host the client configuration file on the TFTP server.

When the client starts for the first time, it:

1 Retrieves the address of the TFTP server from the bootstrap file.

2 Gets client configuration from the TFTP server.

3 Retrieves the address of the Cisco Unified Communications Manager TFTP service from the client
configuration.

4 Gets device configuration from the Cisco Unified Communications Manager TFTP service.

Common Installation Arguments

The following table describes command line arguments that are common to all deployments:

   Cisco Jabber 11.0 Deployment and Installation Guide
144

Install Client
Use the Command Line



DescriptionValueArgument

Defines the Locale ID (LCID), in decimal, of the
language that Cisco Jabber for Windows uses. The
value must be an LCID in decimal that corresponds to
a supported language.

For example, you can specify one of the following:

• 1033 specifies English.

• 1036 specifies French.

See the Cisco Jabber Planning Guide for a full list of
the languages you can specify.

This argument is optional.

If you do not specify a value, Cisco Jabber forWindows
uses the regional language for the current user as the
default.

From Release 11.1(1) onwards, if you do not specify
a value, Cisco Jabber for Windows checks the value
for the UseSystemLanguage parameter. If the
UseSystemLanguage parameter is set to true, the same
language is used as for the operating system. If the
UseSystemLanguage parameter is to set to false or not
defined, then the client uses the regional language for
the current user as the default.

The regional language is set atControl Panel >Region
and Language > Change the date, time, or number
format > Formats tab > Format dropdown.

LCID in decimalLANGUAGE

Specifies the URL where users can reset lost or
forgotten passwords.

This argument is optional but recommended.

In cloud-based deployments, you can specify
a forgot password URL using the Cisco
WebEx Administration Tool. However, the
client cannot retrieve that forgot password
URL until users sign in.

Note

URLFORGOT_PASSWORD_URL
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DescriptionValueArgument

Applies to Release 11.1(1) onwards.

Specifies whether the Sign me in when Cisco Jabber
starts check box is checked when the user installs the
client.

• true—The Signme in whenCisco Jabber starts
check box is checked when the user installs the
client.

• false (default)—The Sign me in when Cisco
Jabber starts check box is not checked when the
user installs the client.

true

false

AUTOMATIC_SIGN_IN

Specifies the unique name of a group configuration
file.

You can specify either an unqualified or fully qualified
filename as the value. The filename you specify as the
value for this argument takes priority over any other
configuration file on your TFTP server.

This argument is optional.

You can specify group configuration
files in the Cisco Support Field on the
CSF device configuration on Cisco
Unified Communications Manager.

Remember

FilenameTFTP_FILE_NAME

Controls user sign in to multiple client instances.

By default, users can sign in to multiple instances of
Cisco Jabber at the same time. Set one of the following
values to change the default behavior:

•WBX—Users can sign in to one instance of Cisco
Jabber for Windows at a time.

Cisco Jabber for Windows appends the
wbxconnect suffix to the user's JID. Users
cannot sign in to any other Cisco Jabber client
that uses the wbxconnect suffix.

• MUT—Users can sign in to one instance of Cisco
Jabber for Windows at a time, but can sign in to
other Cisco Jabber clients at the same time.

Each instance of Cisco Jabber for Windows
appends the user's JID with a unique suffix.

WBX

MUT

LOGIN_RESOURCE
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DescriptionValueArgument

Defines the directory where the client writes log files.

Use quotation marks to escape space characters in the
path, as in the following example:

"C:\my_directory\Log Directory"

The path you specifymust not containWindows invalid
characters.

The default value is
%USER_PROFILE%\AppData\Local\Cisco\Unified
Communications\Jabber\CSF\Logs

Absolute path on the
local filesystem

LOG_DIRECTORY

Disables click-to-x functionality with Cisco Jabber.

If you specify this argument during installation, the
client does not register as a handler for click-to-x
functionality with the operating system. This argument
prevents the client from writing to the Microsoft
Windows registry during installation.

You must re-install the client and omit this argument
to enable click-to-x functionality with the client after
installation.

DISABLECLICK2X

• true (default)—TheReport a problemmenu item
is enabled in the Help menu in the client.

• false—The Jabber menu item option Report a
problem is removed from the Help menu in the
client.

If you set the argument to false, users can still manually
use the Start Menu > Cisco Jabber directory, or the
Program files directory and launch the ProblemReport
Tool manually. If a user manually creates a PRT, and
this parameter value is set to false, then the zip file
created from the PRT has no content.

true

false

ENABLE_PRT

Enables problem report encryption. Youmust configure
this argument with the PRT_CERTIFICATE_NAME
argument.

• true—PRT files sent by Jabber clients are
encrypted.

• false (default)—PRT files sent by Jabber clients
are not encrypted.

PRT encryption requires a public/private key pair to
encrypt and decrypt the Cisco Jabber problem report.

true

false

ENABLE_PRT_ENCRYPTION
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DescriptionValueArgument

Specifies the name of a certificate with a public key in
the Enterprise Trust or Trusted Root Certificate
Authorities certificate store. The certificate public key
is used to encrypt Jabber Problem reports. You must
configure this argument with the
ENABLE_PRT_ENCRYPTION argument.

Certificate namePRT_CERTIFICATE_NAME

Specifies the client behavior for invalid certificates.

• RejectAndNotify—A warning dialog displays
and the client doesn't load.

• PromptPerSession—A warning dialog displays
and the user can accept or reject the invalid
certificate.

For invalid certificates in FIPS mode, this argument is
ignored, the client displays a warning message and
doesn't load.

RejectAndNotify

PromptPerSession

INVALID_CERTIFICATE_BEHAVIOR

Specifies whether analytics data is gathered. The default
value is true.

To improve your experience and product performance,
Cisco Jabber may collect and send non-personally
identifiable usage and performance data to Cisco. The
aggregated data is used by Cisco to understand trends
in how Jabber clients are being used and how they are
performing.

Full details on what analytics data Cisco Jabber does
and does not collect can be found in the Cisco Jabber
Supplement to Cisco’s On-Line Privacy Policy at http:/
/www.cisco.com/web/siteassets/legal/privacy_
02Jun10.html.

true

false

Telemetry_Enabled

Specifies whether the Location feature is enabled and
whether users are notified when new locations are
detected.

• ENABLED(default)—Location feature is turned
on. Users are notified when new locations are
detected.

• DISABLED—Location feature is turned off.
Users are not notified when new locations are
detected.

• ENABLEDNOPROMPT—Location feature is
turned on. Users are not notified when new
locations are detected.

ENABLED

DISABLED

ENABLEDNOPROMPT

LOCATION_MODE
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SSO Arguments

This section describes the command line arguments you can use to deploy Cisco Jabber for Windows with
single sign on (SSO) capabilities.

Cloud-Based SSO Arguments
The arguments in the following table apply to cloud-based deployments only:

DescriptionValueArgument

Specifies the domain name for the Cisco WebEx Org
that contains the URL for the SSO service.

Cisco Jabber for Windows uses this argument to
retrieve the URL of the SSO service from the Org.
When Cisco Jabber for Windows gets the SSO service
URL, it can request login tokens to authenticate with
Cisco WebEx Messenger.

You specify the URL for the SSO service as
the value of the Customer SSO Service Login
URL in the Cisco WebEx Administration
Tool.

Note

Domain nameSSO_ORG_DOMAIN

Run the MSI Manually
You can run the installation program manually to install a single instance of the client and specify connection
settings in the Advanced settings window.

Procedure

Step 1 Launch CiscoJabberSetup.msi.
The installation program opens a window to guide you through the installation process.

Step 2 Follow the steps to complete the installation process.
Step 3 Start Cisco Jabber for Windows.
Step 4 SelectManual setup and sign in.

The Advanced settings window opens.

Step 5 Specify values for the connection settings properties.
Step 6 Select Save.
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Create a Custom Installer
You can transform the default installation package to create a custom installer.

You use Microsoft Orca to create custom installers. Microsoft Orca is available as part of the Microsoft
Windows SDK for Windows 7 and .NET Framework 4.

Download and install MicrosoftWindows SDK forWindows 7 and .NET Framework 4 from theMicrosoft
website.

Note

Related Topics

Microsoft Windows SDK for Windows 7 and .NET Framework 4

Get the Default Transform File
You must have the default transform file to modify the installation package with Microsoft Orca.

Procedure

Step 1 Download the Cisco Jabber administration package from cisco.com.
Step 2 CopyCiscoJabberProperties.msi from the Cisco Jabber administration package to your file system.

Related Topics

Software Downloads

Create Custom Transform Files
To create a custom installer, you use a transform file. Transform files contain installation properties that you
apply to the installer.

The default transform file lets you specify values for properties when you transform the installer. You should
use the default transform file if you are creating one custom installer.

You can optionally create custom transform files. You specify values for properties in a custom transform
file and then apply it to the installer.

Create custom transform files if you require more than one custom installer with different property values.
For example, create one transform file that sets the default language to French and another transform file that
sets the default language to Spanish. You can then apply each transform file to the installation package
separately. The result is that you create two installers, one for each language.
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Procedure

Step 1 Start Microsoft Orca.
Step 2 Open CiscoJabberSetup.msi and then apply CiscoJabberProperties.msi.
Step 3 Specify values for the appropriate installer properties.
Step 4 Generate and save the transform file.

a) Select Transform > Generate Transform.
b) Select a location on your file system to save the transform file.
c) Specify a name for the transform file and select Save.

The transform file you created is saved as file_name.mst. You can apply this transform file to modify
the properties of CiscoJabberSetup.msi.

Transform the Installer
Apply a transform file to customize the installer.

Applying transform files will alter the digital signature of CiscoJabberSetup.msi. Attempts to
modify or rename CiscoJabberSetup.msi will remove the signature entirely.

Note

Procedure

Step 1 Start Microsoft Orca.
Step 2 Open CiscoJabberSetup.msi in Microsoft Orca.

a) Select File > Open.
b) Browse to the location of CiscoJabberSetup.msi on your file system.
c) Select CiscoJabberSetup.msi and then select Open.
The installation package opens in Microsoft Orca. The list of tables for the installer opens in the Tables pane.

Step 3 Remove all language codes except for 1033 (English).
You must remove all language codes from the custom installer except for 1033 (English).

Microsoft Orca does not retain any language files in custom installers except for the default,
which is 1033. If you do not remove all language codes from the custom installer, you cannot
run the installer on any operating system where the language is other than English.

Restriction

a) Select View > Summary Information.
The Edit Summary Information window displays.

b) Locate the Languages field.
c) Delete all language codes except for 1033.
d) Select OK.
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English is set as the language for your custom installer.

Step 4 Apply a transform file.
a) Select Transform > Apply Transform.
b) Browse to the location of the transform file on your file system.
c) Select the transform file and then select Open.

Step 5 Select Property from the list of tables in the Tables pane.
The list of properties for CiscoJabberSetup.msi opens in the right panel of the application window.

Step 6 Specify values for the properties you require.
Step 7 Drop any properties that you do not require.

It is essential to drop any properties that are not being set, otherwise the properties being set will not take
effect. Drop each property that is not needed one at a time.
a) Right-click the property you want to drop.
b) Select Drop Row.
c) Select OK when Microsoft Orca prompts you to continue.

Step 8 Enable your custom installer to save embedded streams.
a) Select Tools > Options.
b) Select the Database tab.
c) Select Copy embedded streams during 'Save As'.
d) Select Apply and then OK.

Step 9 Save your custom installer.
a) Select File > Save Transformed As.
b) Select a location on your file system to save the installer.
c) Specify a name for the installer and then select Save.

Related Topics

Installer Properties, on page 152

Installer Properties
The following are the properties you can modify in a custom installer:

• CLEAR

• PRODUCT_MODE

• AUTHENTICATOR

• CUP_ADDRESS

• TFTP

• CTI

• CCMCIP

• LANGUAGE
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• TFTP_FILE_NAME

• FORGOT_PASSWORD_URL

• SSO_ORG_DOMAIN

• LOGIN_RESOURCE

• LOG_DIRECTORY

• CLICK2X

• SERVICES_DOMAIN

These properties correspond to the installation arguments and have the same values.

Deploy with Group Policy
Install Cisco Jabber for Windows with Group Policy using the Microsoft Group Policy Management Console
(GPMC) on Microsoft Windows Server.

To install Cisco Jabber forWindows with Group Policy, all computers or users to which you plan to deploy
Cisco Jabber for Windows must be in the same domain.

Note

Set a Language Code
Altering the installation language is not necessary in Group Policy deployment scenarios where the exact MSI
file provided by Cisco will be used. The installation language will be determined from the Windows User
Locale (Format) in these situations. You must use this procedure and set the Language field to 1033 only if
the MSI is to be modified by Orca in any way.

Procedure

Step 1 Start Microsoft Orca.
Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and ,NET Framework 4
that you can download from the Microsoft website.

Step 2 Open CiscoJabberSetup.msi.
a) Select File > Open.
b) Browse to the location of CiscoJabberSetup.msi on your file system.
c) Select CiscoJabberSetup.msi and then select Open.

Step 3 Select View > Summary Information.
Step 4 Locate the Languages field.
Step 5 Set the Languages field to 1033.
Step 6 Select OK.
Step 7 Enable your custom installer to save embedded streams.

a) Select Tools > Options.
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b) Select the Database tab.
c) Select Copy embedded streams during 'Save As'.
d) Select Apply and then OK.

Step 8 Save your custom installer.
a) Select File > Save Transformed As.
b) Select a location on your file system to save the installer.
c) Specify a name for the installer and then select Save.

Related Topics

Supported Languages

Deploy the Client with Group Policy
Complete the steps in this task to deploy Cisco Jabber for Windows with Group Policy.

Procedure

Step 1 Copy the installation package to a software distribution point for deployment.
All computers or users to which you plan to deploy Cisco Jabber for Windows must be able to access the
installation package on the distribution point.

Step 2 Select Start > Run and then enter the following command:
GPMC.msc

The Group Policy Management console opens.

Step 3 Create a new group policy object.
a) Right-click on the appropriate domain in the left pane.
b) Select Create a GPO in this Domain, and Link it here.

The New GPO window opens.

c) Enter a name for the group policy object in the Name field.
d) Leave the default value or select an appropriate option from the Source Starter GPO drop-down list and

then select OK.
The new group policy displays in the list of group policies for the domain.

Step 4 Set the scope of your deployment.
a) Select the group policy object under the domain in the left pane.

The group policy object displays in the right pane.

b) Select Add in the Security Filtering section of the Scope tab.
The Select User, Computer, or Group window opens.

c) Specify the computers and users to which you want to deploy Cisco Jabber for Windows.

Step 5 Specify the installation package.
a) Right-click the group policy object in the left pane and then select Edit.

The Group Policy Management Editor opens.
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b) Select Computer Configuration and then select Policies > Software Settings.
c) Right-click Software Installation and then select New > Package.
d) Enter the location of the installation package next to File Name; for example,

\\server\software_distribution.
You must enter a Uniform Naming Convention (UNC) path as the location of the installation
package. If you do not enter a UNC path, Group Policy cannot deploy Cisco Jabber for
Windows.

Important

e) Select the installation package and then select Open.
f) In the Deploy Software dialog box, select Assigned and then OK.

Group Policy installs Cisco Jabber for Windows on each computer the next time each computer starts.

Cisco Media Services Interface
Cisco Jabber for Windows supports Cisco Media Services Interface version 4.1.2 for Microsoft Windows 7
and later.

Desk Phone Video Capabilities
Youmust install CiscoMedia Services Interface to enable desk phone video capabilities. CiscoMedia Services
Interface provides a driver that enables Cisco Jabber for Windows to do the following:

• Discover the desk phone device.

• Establish and maintain a connection to the desk phone device using the CAST protocol.

Install Cisco Media Services Interface

Procedure

Step 1 Download the Cisco Media Services Interface installation program from the download site on cisco.com.
Step 2 Install Cisco Media Services Interface on each computer on which you install Cisco Jabber.

See the appropriate Cisco Medianet documentation for installing Cisco Media Services Interface.

Related Topics

Download software
Medianet Knowledge Base Portal
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Uninstall Cisco Jabber for Windows
You can uninstall Cisco Jabber for Windows using either the command line or the Microsoft Windows control
panel. This document describes how to uninstall Cisco Jabber for Windows using the command line.

Use the Installer
If the installer is available on the file system, use it to remove Cisco Jabber for Windows.

Procedure

Step 1 Open a command line window.
Step 2 Enter the following command:

msiexec.exe /x path_to_CiscoJabberSetup.msi

For example,
msiexec.exe /x C:\Windows\Installer\CiscoJabberSetup.msi /quiet

Where /quiet specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.

Use the Product Code
If the installer is not available on the file system, use the product code to remove Cisco Jabber for Windows.

Procedure

Step 1 Find the product code.
a) Open the Microsoft Windows registry editor.
b) Locate the following registry key: HKEY_CLASSES_ROOT\Installer\Products
c) Select Edit > Find.
d) Enter Cisco Jabber in the Find what text box in the Find window and select Find Next.
e) Find the value of the ProductIcon key.

The product code is the value of the ProductIcon key, for example,
C:\Windows\Installer\{product_code}\ARPPRODUCTICON.exe.

The product code changes with each version of Cisco Jabber for
Windows.

Note

Step 2 Open a command line window.
Step 3 Enter the following command:

msiexec.exe /x product_code

For example,
msiexec.exe /x 45992224-D2DE-49BB-B085-6524845321C7 /quiet

Where /quiet specifies a silent uninstall.
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The command removes Cisco Jabber for Windows from the computer.

Install Cisco Jabber for Mac

Distribute the Cisco Jabber for Mac client
Visit the Cisco Software Center to download the Cisco Jabber for Mac client.

Upgrading in theMac OSX environment is performed automatically by the application, with permission from
the user.

Install Cisco Jabber Mobile Clients
Procedure

Step 1 To install Cisco Jabber for Android, download the app from Google Play from your mobile device.
Step 2 To install Cisco Jabber for iPhone and iPad, download the app from the App Store from your mobile device.
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C H A P T E R  14
Remote Access

• Expressway for Mobile and Remote Access Deployments, page 159

• Cisco AnyConnect Deployment, page 161

Expressway for Mobile and Remote Access Deployments
Expressway for Mobile and Remote Access for Cisco Unified Communications Manager allows users to
access their collaboration tools from outside the corporate firewall without a VPN client. Using Cisco
collaboration gateways, the client can connect securely to your corporate network from remote locations such
as public Wi-Fi networks or mobile data networks.

You must do the following to set up the Expressway for Mobile and Remote Access feature:

1 Set up servers to support Expressway forMobile and Remote Access using Cisco Expressway-E and Cisco
Expressway-C.*

a See the following documents to set up the Cisco Expressway servers:

• Cisco Expressway Basic Configuration Deployment Guide

• Mobile and Remote Access via Cisco Expressway Deployment Guide

* If you currently deploy a Cisco TelePresence Video Communications Server (VCS) environment,
you can set up Expressway forMobile and Remote Access. For more information, seeCisco VCS Basic
Configuration (Control with Expressway) Deployment Guide andMobile and Remote Access via Cisco
VCS Deployment Guide.

b Add any relevant servers to the whitelist for your Cisco Expressway-C server to ensure that the client
can access services that are located inside the corporate network.

To add a server to the Cisco Expressway-C whitelist, use the HTTP server allow setting.

This list can include the servers on which you host voicemail or contact photos.

2 Configure an external DNS server that contains the _collab-edge DNS SRV record to allow the client to
locate the Expressway for Mobile and Remote Access server.

3 If you deploy a hybrid cloud-based architecture where the domain of the IM and presence server differs
from the domain of the voice server, ensure that you configure the Voice Services Domain.
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The Voice Services Domain allows the client to locate the DNS server that contains the _collab-edge
record.

You can configure the voice services domain using one of the following methods:

• Client configuration file (all Cisco Jabber clients)

• Configuration URL (all Cisco Jabber clients except Cisco Jabber for Windows)

• Installer options (Cisco Jabber for Windows only)

In most cases, users can sign in to the client for the first time using Expressway for Mobile and Remote
Access to connect to services from outside the corporate firewall. In the following cases, however, users
must perform initial sign in while on the corporate network:

Important

• If the voice services domain is different from the services domain. In this case, users must be inside
the corporate network to get the correct voice services domain from the jabber-config.xml file.

• If the client needs to complete the CAPF enrollment process, which is required when using a secure
or mixed mode cluster.

The following diagram illustrates the architecture of an Expressway for Mobile and Remote Access
environment.

Figure 1: How the Client Connects to the Expressway for Mobile and Remote Access

Related Topics

Cisco Expressway Configuration Guides
Cisco VCS Configuration Guides
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Cisco AnyConnect Deployment

Application Profiles
After you download the Cisco AnyConnect Secure Mobility Client to their device, the ASA must provision
a configuration profile to the application.

The configuration profile for the Cisco AnyConnect Secure Mobility Client includes VPN policy information
such as the company ASA VPN gateways, the connection protocol (IPSec or SSL), and on-demand policies.

You can provision application profiles for Cisco Jabber for iPhone and iPad in one of the following ways:

ASDM

We recommend that you use the profile editor on the ASADeviceManager (ASDM) to define the VPN profile
for the Cisco AnyConnect Secure Mobility Client.

When you use this method, the VPN profile is automatically downloaded to the Cisco AnyConnect Secure
Mobility Client after the client establishes the VPN connection for the first time. You can use this method for
all devices and OS types, and you can manage the VPN profile centrally on the ASA.

For more information, see the Creating and Editing an AnyConnect Profile topic of the Cisco AnyConnect
Secure Mobility Client Administrator Guide for your release.

iPCU

You can provision iOS devices using an Apple configuration profile that you create with the iPhone
Configuration Utility (iPCU). Apple configuration profiles are XML files that contain information such as
device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1 Use iPCU to create an Apple configuration profile.

For more information, see the iPCU documentation.

2 Export the XML profile as a .mobileconfig file.

3 Email the .mobileconfig file to users.

After a user opens the file, it installs the AnyConnect VPN profile and the other profile settings to the
client application.

MDM

You can provision iOS devices using an Apple configuration profile that you create with third-party Mobile
Device Management (MDM) software. Apple configuration profiles are XML files that contain information
such as device security policies, VPN configuration information, and Wi-Fi, mail, and calendar settings.

The high-level procedure is as follows:

1 Use MDM to create the Apple configuration profiles.

For information on using MDM, see the Apple documentation.

2 Push the Apple configuration profiles to the registered devices.
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To provision application profiles for Cisco Jabber for Android, use the profile editor on the ASA Device
Manager (ASDM) to define the VPN profile for the Cisco AnyConnect Secure Mobility Client. The VPN
profile is automatically downloaded to the Cisco AnyConnect SecureMobility Client after the client establishes
the VPN connection for the first time. You can use this method for all devices and OS types, and you can
manage the VPN profile centrally on the ASA. For more information, see the Creating and Editing an
AnyConnect Profile topic of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your
release.

Automate VPN Connection
When users open Cisco Jabber from outside the corporateWi-Fi network, Cisco Jabber needs a VPN connection
to access the Cisco UC application servers. You can set up the system to allow Cisco AnyConnect Secure
Mobility Client to automatically establish a VPN connection in the background, which helps ensure a seamless
user experience.

VPN will not be launched because Expressway for Mobile and Remote Access has the higher connection
priority even if VPN is set to automatic connection.

Note

Set Up Trusted Network Connection
The Trusted Network Detection feature enhances the user experience by automating the VPN connection
based on the user's location. When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the
Cisco UC infrastructure directly.When the user leaves the corporateWi-Fi network, Cisco Jabber automatically
detects that it is outside the trusted network. After this occurs, Cisco AnyConnect Secure Mobility Client
initiates the VPN to ensure connectivity to the UC infrastructure.

The Trusted Network Detection feature works with both certificate- and password-based authentication.
However, certificate-based authentication provides the most seamless user experience.

Note

Procedure

Step 1 Using ASDM, open the Cisco AnyConnect client profile.
Step 2 Enter the list of Trusted DNS Servers and Trusted DNS Domain Suffixes that an interface can receive when

the client is within a corporate Wi-Fi network. The Cisco AnyConnect client compares the current interface
DNS servers and domain suffix with the settings in this profile.

You must specify all your DNS servers to ensure that the Trusted Network Detection feature works
properly. If you set up both the TrustedDNSDomains and TrustedDNSServers, sessions must match
both settings to be defined as a trusted network.

For detailed steps for setting up Trusted Network Detection, see the Trusted Network Detection
section in the Configuring AnyConnect Features chapter (Release 2.5) or Configuring VPN Access
(releases 3.0 or 3.1) of the Cisco AnyConnect Secure Mobility Client Administrator Guide for your
release.

Note
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Set Up Connect On-Demand VPN
The Apple iOS Connect On Demand feature enhances the user experience by automating the VPN connection
based on the user's domain.

When the user is inside the corporate Wi-Fi network, Cisco Jabber can reach the Cisco UC infrastructure
directly. When the user leaves the corporate Wi-Fi network, Cisco AnyConnect automatically detects if it is
connected to a domain that you specify in the AnyConnect client profile. If so, the application initiates the
VPN to ensure connectivity to the UC infrastructure. All applications on the device including Cisco Jabber
can take advantage of this feature.

Connect On Demand supports only certificate-authenticated connections.Note

The following options are available with this feature:

• Always Connect — Apple iOS always attempts to initiate a VPN connection for domains in this list.

• Connect If Needed — Apple iOS attempts to initiate a VPN connection to the domains in the list only
if it cannot resolve the address using DNS.

• Never Connect — Apple iOS never attempts to initiate a VPN connection to domains in this list.

Apple plans to remove the Always Connect option in the near future. After the Always Connect option is
removed, users can select the Connect If Needed option. In some cases, Cisco Jabber users may have
issues when using the Connect If Needed option. For example, if the hostname for the Cisco Unified
Communications Manager is resolvable outside the corporate network, iOS will not trigger a VPN
connection. The user can work around this issue bymanually launching Cisco AnyConnect SecureMobility
Client before making a call.

Attention

Procedure

Step 1 Use the ASDM profile editor, iPCU, or MDM software to open the AnyConnect client profile.
Step 2 In the AnyConnect client profile, under the Connect if Needed section, enter your list of on-demand domains.

The domain list can include wild-card options (for example, cucm.cisco.com, cisco.com, and *.webex.com).

Set Up Automatic VPN Access on Cisco Unified Communications Manager

Before You Begin

• The mobile device must be set up for on-demand access to VPN with certificate-based authentication.
For assistance with setting up VPN access, contact the providers of your VPN client and head end.

• For requirements for Cisco AnyConnect SecureMobility Client and Cisco Adaptive Security Appliance,
see the Software Requirements topic.
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• For information about setting up Cisco AnyConnect, see the Cisco AnyConnect VPN Client Maintain
and Operate Guides.

Procedure

Step 1 Identify a URL that will cause the client to launch VPN on Demand.
a) Use one of the following methods to identify a URL that will cause the client to launch VPN on Demand.

• Connect if Needed

• Configure Cisco Unified Communications Manager to be accessed through a domain name
(not an IP address) and ensure that this domain name is not resolvable outside the firewall.

• Include this domain in the “Connect If Needed” list in the Connect On Demand Domain List
of the Cisco AnyConnect client connection.

• Always Connect

• Set the parameter in step 4 to a nonexistent domain. A nonexistent domain causes a DNS query
to fail when the user is inside or outside the firewall.

• Include this domain to the “Always Connect” list in the Connect On Demand Domain List of
the Cisco AnyConnect client connection.

The URLmust include only the domain name. Do not include a protocol or a path (for example,
use “cm8ondemand.company.com” instead of “https://cm8ondemand.company.com/vpn”.

b) Enter the URL in Cisco AnyConnect and verify that a DNS query on this domain fails.

Step 2 Open the Cisco Unified CM Administration interface.
Step 3 Navigate to the device page for the user.
Step 4 In the Product Specific Configuration Layout section, in theOn-Demand VPN URL field, enter the URL

that you identified and used in Cisco AnyConnect in Step 1.
The URL must be a domain name only, without a protocol or path.

Step 5 Select Save.
When Cisco Jabber opens, it initiates a DNS query to the URL (for example, ccm-sjc-111.cisco.com). If this
URL matches the On-Demand domain list entry that you defined in this procedure (for example, cisco.com),
Cisco Jabber indirectly initiates the AnyConnect VPN connection.

What to Do Next

• Test this feature.

◦Enter this URL into the Internet browser on the iOS device and verify that VPN launches
automatically. You should see a VPN icon in the status bar.

◦Verify that the iOS device can connect to the corporate network using VPN. For example, access
a web page on your corporate intranet. If the iOS device cannot connect, contact the provider of
your VPN technology.
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◦Verify with your IT department that your VPN does not restrict access to certain types of traffic
(for example, if the administrator set the system to allow only email and calendar traffic).

• Verify that you set up the client to connect directly to the corporate network.

Set Up Certificate-Based Authentication
Cisco recommends that you use certificate-based authentication for negotiating a secure connection to Cisco
Adaptive Security Appliance from Cisco AnyConnect Secure Mobility Client.

ASA supports certificates issued by standard Certificate Authority (CA) servers such as Cisco IOS CA,
Microsoft Windows 2003, Windows 2008R2, Entrust, VeriSign, and RSA Keon. This topic gives you a,
high-level procedure for setting up ASA for certificate-based authentication. See the Configuring Digital
Certificates topic in the appropriate ASA configuration guide for step-by-step instructions.

Procedure

Step 1 Import a root certificate from the CA to the ASA.
Step 2 Generate an identity certificate for the ASA.
Step 3 Use the ASA identity certificate for SSL authentication.
Step 4 Configure a Certificate Revocation List (CRL) or an Online Certificate Status Protocol (OCSP).
Step 5 Configure the ASA to request client certificates for authentication.

What to Do Next

After you set up certificate-based authentication on ASA, you must distribute certificates to your users. You
can use one of the following methods:

• Distribute Certificates with SCEP

• Distribute Client Certificate with Mobileconfig File

Distribute Certificates with SCEP
You can use Simple Certificate Enrollment Protocol (SCEP) on Microsoft Windows Server to securely issue
and renew certificates for client authentication.

To distribute certificates with SCEP, you must install the SCEP module on Microsoft Windows Server. See
the following topics for more information:

• ASA 8.X: AnyConnect SCEP Enrollment Configuration Example

• Simple Certificate Enrollment Protocol (SCEP) Add-on for Certificate Services

Distribute Client Certificate with Mobileconfig File
Use this procedure to create a mobile configuration file that includes a certificate. You can use this file to
distribute the certificate to users.
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Procedure

Step 1 Use the iPCU software to create a mobileconfig file and include the certificate (.pfx) file.
Step 2 Forward the mobileconfig file to the user.
Step 3 Use the Cisco ISE native supplicant provisioning process to distribute user certificates.
Step 4 Use the Enterprise MDM software to provision and publish certificates to registered devices.

Session Parameters
You can configure ASA session parameters to improve performance for secure connections. For the best user
experience, you should configure the following ASA session parameters:

• Datagram Transport Layer Security (DTLS)— DTLS is an SSL protocol that provides a data path that
prevents latency and data loss.

• Auto Reconnect— Auto reconnect, or session persistence, lets Cisco AnyConnect Secure Mobility
Client recover from session disruptions and re-establish sessions.

• Session Persistence— This parameter allows the VPN session to recover from service disruptions and
re-establish the connection.

• Idle Timeout— Idle timeout defines a period of time after which ASA terminates secure connections,
if no communication activity occurs.

• Dead-Peer Detection (DTD)— DTD ensures that ASA and Cisco AnyConnect Secure Mobility Client
can quickly detect failed connections.

Set ASA Session Parameters
Cisco recommends that you set up the ASA session parameters as follows to optimize the end user experience
for Cisco AnyConnect Secure Mobility Client.

Procedure

Step 1 Set up Cisco AnyConnect to use DTLS.
For more information, see the Enabling Datagram Transport Layer Security (DTLS) with AnyConnect (SSL)
Connections topic in the Configuring AnyConnect Features Using ASDM chapter of the Cisco AnyConnect
VPN Client Administrator Guide, Version 2.0.

Step 2 Set up session persistence (auto-reconnect).
a) Use ASDM to open the VPN client profile.
b) Set the Auto Reconnect Behavior parameter to Reconnect After Resume.
For more information, see the Configuring Auto Reconnect topic in the Configuring AnyConnect Features
chapter (Release 2.5) orConfiguring VPN Access chapter (releases 3.0 or 3.1) of theCisco AnyConnect Secure
Mobility Client Administrator Guide for your release.
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Step 3 Set the idle timeout value.
a) Create a group policy that is specific to Cisco Jabber clients.
b) Set the idle timeout value to 30 minutes.
For more information, see the vpn-idle-timeout section of the Cisco ASA 5580 Adaptive Security Appliance
Command Reference for your release

Step 4 Set up Dead Peer Detection (DPD).
a) Disable server-side DPD.
b) Enable client-side DPD.
For more information, see the Enabling and Adjusting Dead Peer Detection topic of the Configuring VPN
chapter of the Cisco ASA 5500 Series Configuration Guide using the CLI, 8.4 and 8.6.

Group Policies and Profiles
You should use the ASA Device Manager (ASDM) to create group policies, client profiles, and connection
profiles. Create your group policies first and then apply those policies to the profiles. Using the ASDM to
create profiles ensures that Cisco AnyConnect SecureMobility Client downloads the profiles after it establishes
a connection to ASA for the first time. The ASDM also lets you manage and maintain your policies and
profiles in a central location.

See the Cisco AnyConnect Secure Mobility Client Administrator Guide for instructions on creating policies
and profiles with the ASDM.

Trusted Network Detection
Trusted Network Detection is a feature that automates secure connections based on user location. When users
leave the corporate network, Cisco AnyConnect SecureMobility Client automatically detects that it is outside
the trusted network and then initiates secure access.

You configure Trusted Network Detection on ASA as part of the client profile. For more information, see the
Trusted Network Detection topic in the Cisco AnyConnect Secure Mobility Client Administrator Guide for
your release.

Tunnel Policies
Tunnel policies configure howCiscoAnyConnect SecureMobility Client directs traffic over a secure connection
and include the following:

• Full Tunnel Policy— Lets you send all traffic over the secure connection to the ASA gateway.

• Split Include Policy with Network ACL—Enables you to restrict secure connections based on destination
IP addresses. For example, in an on-premises deployment, you can specify the IP addresses for Cisco
Unified Communications Manager, Cisco Unified Presence, your TFTP server, and other servers to
restrict the secure connection only to your client's traffic.

• Split Exclude Policy—Allows you to exclude certain traffic from the secure connection. You can allow
client traffic over the secure connection and then exclude traffic from specific destination subnets.
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C H A P T E R  15
Cisco Jabber Options

• Cisco Jabber 11.0 Features, page 169

• Cisco Jabber Features for Windows, Mac, iOS and Android, page 172

• Cisco Jabber Features for Windows , page 191

• Cisco Jabber Features for Mac, page 212

• Cisco Jabber for Android and iOS, page 212

• Cisco Jabber for iOS, Android and Windows, page 227

• Cisco Jabber for iOS, Android and Mac, page 231

Cisco Jabber 11.0 Features
Cisco Jabber includes a broad range of features. As indicated in the following table, some features are
client-specific.

Cisco
Jabber for
Android,
Cisco
Jabber for
iPhone and
iPad

Cisco
Jabber for
Mac

Cisco
Jabber for
Windows

Feature

XAlert When Available

XXXAutomatic Upgrades

XAuto-Save Chat

XXXBridge Escalations

XCall Pickup
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Cisco
Jabber for
Android,
Cisco
Jabber for
iPhone and
iPad

Cisco
Jabber for
Mac

Cisco
Jabber for
Windows

Feature

XCall Park

XXXCall Preservation

XChat Search

XChat Security Labels

XXXCisco WebEx Meetings integration

XXCustom Contact

XXConfigure Silent Monitoring and Call Recording

XXXDefine a port range on the SIP profile

XDial via Office - Reverse

XXXDirectory Groups in Contact List

XXXExpressway Mobile and Remote Access

XXXFar End Camera Control

Some of
the file
transfer
features are
supported

XXFile Transfer

XFIPS Compliance

XXXFlexible Jabber ID

XXFlexible DSCP

XXXGroup Chat

XXHunt Group

XXXInstant Messaging

XXXInstant Messaging Encryption
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Cisco
Jabber for
Android,
Cisco
Jabber for
iPhone and
iPad

Cisco
Jabber for
Mac

Cisco
Jabber for
Windows

Feature

XXXJabber to Jabber Call

XXLocations

XXXMandatory Upgrade Support

XXXMultiple Resource Login

Some of
the
persistent
chat room
features are
supported.

XPersistent Chat Rooms

XXXPredictive Contact Search

XXXPresence

XSave Chat History to Outlook Folder

XPrint Chat

XSend to Mobile

XXXService Discovery

XXXSingle Sign-On

X (OS
feature)

X (Client
Options
feature)

Spell Check

XXXTelemetry

XXXURI Dialing

X (Mobile
clients only
support
BFCP
receiving.)

XXVideo Desktop Share (BFCP)
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Cisco
Jabber for
Android,
Cisco
Jabber for
iPhone and
iPad

Cisco
Jabber for
Mac

Cisco
Jabber for
Windows

Feature

XXXVoice and Video Calling

XXXVoice and Video Encryption

XXXVoicemail

Cisco Jabber Features for Windows, Mac, iOS and Android

Jabber to Jabber Call
Jabber to Jabber voice and video calling provides basic calling capabilities between two Cisco Jabber clients
without using Cisco Unified Communications Manager. If Cisco Jabber users are not registered with Cisco
Unified Communications Manager, they can still make Jabber to Jabbercalls from Cisco Jabber.

Note • Jabber to Jabber calling is only supported for users who authenticate to the CiscoWebExMessenger
service.

• For Cisco Jabber for Windows clients, we recommend running Internet Explorer 10 or greater while
using the Jabber to Jabber calling feature. Using the feature with previous versions of Internet
Explorer or with Internet Explorer in Compatibility Mode can cause issues. These issues are with
Cisco Jabber client login (non-SSO setup) or Jabber to Jabber calling capability (SSO setup).

Jabber to Jabber Call Cloud Deployment

Cloud deployment for Jabber to Jabber call uses the SDP/HTTPS setup. For cloud deployment, ensure the
following:

• Install the following root certificate to use the Jabber to Jabber call feature: GoDaddy Class 2
Certification Authority Root Certificate. To resolve anywarnings about this certificate
name, install the required GoDaddy certificate.

• Include the following servers in the proxy server bypass list:

• https://locus-a.wbx2.com/locus/api/v1

• https://conv-a.wbx2.com/conversation/api/v1

For information on proxy server lists, see the Configure Proxy Settings in the Deployment Guides.
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• Enable the range of media ports and protocols for RTP/SRTP over UDP: 33434-33598 and 8000-8100.
For Jabber to Jabber call setup over HTTPS, enable port 443.

• Before you enable the Jabber to Jabber calling feature, contact the Cisco Customer Support team or your
Cisco Customer Success Manager for the following:

• To request that your organization is added to the Cisco Common Identity server. This process to
add users to the Common Identity server takes some time to complete and is necessary to access
Jabber to Jabber calling capabilities.

• For Single Sign On (SSO) users, there are extra steps to perform to ensure that SSO setup is
completed successfully for your organization.

For cloud deployments, Jabber to Jabber calling is configured on the CiscoWebExMessenger Administration
tool using one of the following methods:

• Using the P2P settings in the Configuration Tab section. For more information, see the Cisco WebEx
Messenger Administrator's Guide.

• Jabber to Jabber calling can be enabled for groups of users or all users. Use the Internal VoIP and
External VoIP settings in the policy editor for Cisco WebEx Messenger Administration tool. You can
control the video services for Jabber to Jabber calls using the Internal Video andExternal Video policy
actions. For more information, see thePolicy Editor section of theCiscoWebExMessenger Administration
Guide.

Jabber to Jabber Call Experience

A Jabber to Jabber call does not support all the features of a Cisco Unified Communication Manager call.
Users can make a Jabber to Jabber call with only one contact at a time. In a Jabber to Jabber call, users can
experience any of the following scenarios:

• If two users start a Jabber to Jabber call to each other at the same time, the call is automatically connected.
In such case, users do not receive any incoming call notification.

•When users are on a Jabber to Jabber call and start another call. The ongoing call ends immediately,
even if the person they called does not answer.

•When on a Jabber to Jabber call and they receive an incoming Jabber to Jabber call, they get an End
Call AndAnswer.When they select this button, the ongoing Jabber to Jabber call ends and the incoming
call is answered.

• For Jabber to Jabber calls on Cisco Jabber for mobile clients:

•When users are on a Jabber to Jabber call and theymake a phone call. The ongoing Jabber to Jabber
call ends immediately, even if the remote party does not answer.

•When users are on a mobile call, they cannot answer any Jabber to Jabber call. The incoming
Jabber to Jabber call is listed as a missed call.

•When users are on a Jabber to Jabber call and they receive an incoming mobile call:

• On an iPhone, the Jabber to Jabber call ends immediately, even if they do not answer the
call.

• On an Android phone, the Jabber to Jabber call ends immediately when they answer the
incoming mobile call.
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Supported In-Call Features

The following features are supported during a Jabber to Jabber call:

• End a Jabber to Jabber call

• Mute or unmute the audio

• Start or stop the video

• Volume control

• Open or close or move the self-video

• Switch to front or back camera. This feature is only supported on the Cisco Jabber mobile clients.

Related Topics

http://www.cisco.com/c/en/us/support/unified-communications/webex-messenger/tsd-products-support-install-and-upgrade.html

Jabber to Jabber Hybrid Mode

Jabber to Jabber Call Experience in Hybrid Mode

In addition to the limitations for Jabber to Jabber, the following are the scenarios that occur when using Jabber
to Jabber calls and Cisco Unified Communications Manager calls:

•When users are on a Jabber to Jabber call and make a Cisco Unified Communications Manager call, the
ongoing Jabber to Jabber call ends immediately, even if the remote party does not answer.

•When users are on a Jabber to Jabber call and resume a Cisco Unified Communications Manager call
from on hold, the Jabber to Jabber call ends immediately.

•When users are on a Jabber to Jabber call and receive an incoming Cisco Unified Communications
Manager call, a notification with an End Call And Answer button displays. If your user selects this
button the ongoing Jabber to Jabber call ends and the incoming call is answered.

•When users receive a Cisco Unified Communications Manager call, they can place the ongoing Cisco
Unified Communications Manager call on hold to answer the new call.

•When users are on a Cisco Unified Communications Manager call and they choose to make a Jabber to
Jabber call, the Cisco Unified Communications Manager call is put on hold immediately, even if the
participant in the Jabber to Jabber call does not answer the call.

•When users are on a Cisco Unified Communications Manager call and they answer an incoming Jabber
to Jabber call, the Cisco Unified Communications Manager call is put on hold immediately.

• If your user’s line is configured on Cisco Unified Communications Manager to auto-answer calls and
they receive an incoming Cisco Unified Communications Manager call when they are on a Jabber to
Jabber call, the Jabber to Jabber call ends immediately without notification and the Cisco Unified
Communications Manager call is answered.
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Decrypt the Problem Report
The command line tool CiscoJabberPrtDecrypter.exe for decrypting the problem reports is only available
on Windows machines and is included in the Cisco Jabber for Windows installer. The tool has the following
arguments:

• --help—Show the help message.

• --privatekey—Specify the private key file, this is a privacy enhanced mail (.pem) or a personal
information exchange PKCS#12 (.pfx) format.

• --password—Optional, if the input private key file is password protected.

• --encryptionkey—Specify the encryption secret key file, for example file.zip.esk.

• --encryptedfile—Specify the encrypted file, for example file.zip.enc.

• --outputfile—Specify the output file, for example decryptedfile.zip.

• --mobile—Specify for the problem reports from mobile clients.

Before You Begin

To decrypt problem reports you need the following:

• Two files from the zip file created when you generated a problem report using encryption:

• file.zip.esk—The encrypted symmetric key.

• file.zip.enc—The original data encrypted using AES256.

• Private Key for the certificate used for encrypting the data.

Procedure

Step 1 Open a command prompt in Windows.
Step 2 Navigate to the C:\Program Files(x86)\Cisco Systems\Cisco Jabber\ directory.
Step 3 Enter the command and your parameters.

Example for desktop clients: CiscoJabberPrtDecrypter.exe --privatekey C:\PRT\PrivateKey.pfx

--password 12345 --encryptedfile C:\PRT\file.zip.enc --encryptionkey C:\PRT\file.zip.esk

--outputfile C:\PRT\decryptedfile.zip

Example for mobile clients: CiscoJabberPrtDecrypter.exe --privatekey C:\PRT\PrivateKey.pfx

--password 12345 --encryptedfile C:\PRT\file.zip.enc --encryptionkey C:\PRT\file.zip.esk

--outputfile C:\PRT\decryptedfile.zip --mobile

If the decryption is successful the output file is created. If there is an invalid parameter the decryption fails
and an error is shown on the command line.
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Define a Port Range on the SIP Profile
You can configure separate UDP port ranges for the audio stream and video stream for SIP calls. Since video
typically requires considerably more bandwidth than audio, you can use dedicated port ranges for each media
type to simplify network bandwidth management. It also helps against audio stream degradation by ensuring
that the audio stream have a dedicated channel separated from the higher-bandwidth video stream.

Telemetry

Cisco Jabber Analytics

To improve your experience and product performance, Cisco Jabber may collect and send non-personally
identifiable usage and performance data to Cisco. The aggregated data is used by Cisco to understand trends
in how Jabber clients are being used and how they are performing.

You must install the following root certificate to use the telemetry feature: GoDaddy Class 2
Certification Authority Root Certificate. The telemetry server certificate name is
"metrics-a.wbx2.com". To resolve any warnings about this certificate name, install the required GoDaddy
certificate.

For more information, see how to Set Up Certificate Validation.

By default, the telemetry data is on. You can configure the following telemetry parameters:

• Telemetry_Enabled— Specifies whether analytics data is gathered. The default value is true.

• TelemetryEnabledOverCellularData— Specifies whether analytics data is sent over cellular data and
Wi-Fi (true), or W-iFi only (false). The default value is true.

• TelemetryCustomerID— This optional parameter specifies the source of analytic information. This ID
can be a string that explicitly identifies an individual customer, or a string that identifies a common
source without identifying the customer. We recommend using a tool that generates a Global Unique
Identifier (GUID) to create a 36 character unique identifier, or to use a reverse domain name.

For more information on these parameters, see Policies Parameters.

Full details on what analytics data Cisco Jabber does and does not collect can be found in the Cisco Jabber
Supplement to Cisco’s On-Line Privacy Policy at http://www.cisco.com/web/siteassets/legal/privacy_
02Jun10.html.

Related Topics

About Certificate Validation
Cisco Jabber 11.0 Parameters Reference Guide

Enterprise Groups for Cisco Unified Communications Manager IM And Presence
Service

Users can add groups to their contact lists in Cisco Jabber. The groups are created in the enterprise's Microsoft
Active Directory and then are imported into Cisco Unified CommunicationsManager IM and Presence Service
Release 11.0.
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Once enterprise groups are set up, users have the option in their client to add enterprise groups to their contact
list.

Using enterprise groups is supported when on the Expressway for Mobile and Remote Access.

Prerequisites for Enabling Enterprise Groups in Cisco Jabber

• Cisco Unified Communications Manager Release 11.0

• Cisco Unified Communications Manager IM and Presence Service Release 11.0

Before you can set up enabling adding enterprise groups to contact lists for your users, youmust set the feature
up in the server. Use the Enable Enterprise Groups topic in the Cisco Unified Communications Manager
Release 11.0 documentation. Cisco Unified Communications Manager does not currently import Security
Groups from Active Directory, only Distribution Groups can be imported.

Limitations

Enterprise Groups for Cisco Unified Communications Manager IM And Presence Service is available to
on-premises deployments only. Enterprise Groups are already supported on cloud deployments.

Presence is unsupported for contacts in enterprise groups of over 100 people who are IM-enabled, unless the
user has other presence subscriptions for a contact. For example, if users have someone added to their personal
contact list who is also listed in an enterprise group of over 100 people, then presence is still displayed for
that person. Users who are not IM-enabled do not affect the 100 person presence limit.

Nested groups cannot be imported as part of an enterprise group. For example, in an AD group, only group
members are imported, not any embedded groups within it.

If your users and AD Group are in different organizational units (OUs), then before you add the contacts to
the AD Group, you must sync both OUs with Cisco Unified Communications Manager, and not just the OU
that the AD Group is in.

If you have the minimum character query set to the default value of 3 characters, then user searches for
enterprise groups will exclude any two letter group names (for example: HR). To change theminimum character
query for EDI, BDI, or UDS connections, change the value of the MinimumCharacterQuery parameter.

Enterprise groups with special characters cannot be located during searches if the special characters are among
the first 3 characters (or whatever value you have defined as the minimum character query) of the name.

We recommend that you only change the distinguished name of enterprise groups outside of core business
hours, as it would cause unreliable behavior from the Cisco Jabber client for users.

If you make changes to enterprise groups, you must synch the Active Directory with Cisco Unified
Communications Manager afterwards in order for the changes to be applied.

UDS Limitations (Applies to users on the Expressway for Mobile and Remote Access or with UDS on-premises)

There is no search capability for enterprise groups when connecting using UDS, so users must know the exact
enterprise group name that they want to add to their contact lists. There is a search capability for enterprise
groups when connecting using EDI or BDI.

Enterprise group names are case-sensitive.

If two enterprise groups within an AD Forest have the same name, then users get an error when trying to add
the group. This issue does not apply to clients using EDI or BDI.
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Far End Camera Control (FECC)
In calls that support far-end camera control (FECC), you can adjust the far-end camera to give you a better
view during video calls. FECC is available to users if the endpoint that they are calling supports it.

You can configure whether users can access FECC-enabled endpoints. Disabling the configuration parameter
means that users are not provided with the ability to control far-end camera endpoints, even if the endpoint
is capable. From a user experience, with FECC disabled, it works the same as dialing in to an endpoint that
is not FECC enabled.

To disable FECC, set the EnableFecc parameter to false. For more information on this parameter, see the
Client Parameters topic.

Limitations

FECC is only supported in point-to-point calls, but not in group calls or conferences where multiple video
connections are connecting to the same bridge.

FECC is only supported in Softphone mode.

Related Topics

Cisco Jabber 11.0 Parameters Reference Guide

Configure Bridge Escalations
Bridge escalations allow users to quickly escalate a group chat to a conference call. Participants are
automatically added without the need to merge them into the conference call.

Procedure

Step 1 Enable bridge escalations in Cisco Jabber clients by setting the EnableBridgeConferencing parameter to true
in the jabber-config.xml file.

Step 2 (Optional) Specify a mask for the room URI in the UserBridgeUriAdmin parameter in the
jabber-config.xml file. If you don't specify a mask the user can enter a DN or a SIP URI in the client.

Step 3 Enable URI dialing to allow your users enter a SIP URI for the conference call number. For more information
on URI dialing, see the Enable URI Dialing topic.

Configure Collaboration Meeting Rooms
Cisco Collaboration Meeting Rooms (CMR) Cloud provides easy access for users to join or start a Cisco
WebEx meeting. Cisco Jabber provides users with the ability to access the meeting either using Cisco WebEx
interface or join using video.

There is a limitation on CMR Cloud join experience for attendees of scheduled CMR Cloud meetings. This
limitation impacts Mac users and Windows users who have not enabled Outlook calendar integration. Due to
a server limitation, attendees for these deployment scenarios will only receive the option to join the meeting
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using Cisco WebEx. Hosts will enjoy the full experience, as will anyone invited to join ad hoc CMR Cloud
meetings.

Users who are in CTI control mode will only be able to join using WebEx.

Before You Begin

Cisco Collaboration Meeting Rooms Cloud is available on Cisco WebEx Meeting Center.

Procedure

Step 1 Configure the Collaboration Meeting Room options using the configuration guides available here: http://
www.cisco.com/c/en/us/support/conferencing/webex-meeting-center/
products-installation-and-configuration-guides-list.html

Step 2 Ensure Collaboration Meeting Rooms are enabled for your users on Cisco WebEx Meeting Center.
Step 3 Collaboration Meeting Room features uses SIP URI, you must enable URI dialing for your users on Cisco

Unified Communications Manager. For more information on URI dialing, see the Enable URI Dialing topic.

Configure Personal Rooms
A Personal room is a virtual conference room that is always available and can be used to meet with people.
Cisco Jabber uses the personal room feature of Cisco WebEx Meeting Center to allow users to easily meet
with their contacts using theMeet Now option in the client.

Procedure

Step 1 Personal Rooms are enabled by default for users on Cisco WebEx Meeting Center. For more information see
the Cisco WebEx Meeting Center documentation available here: http://www.cisco.com/c/en/us/support/
conferencing/webex-meeting-center/products-installation-and-configuration-guides-list.html

Step 2 Users can configure their personal rooms for all instant meetings by selecting Use Personal Room for all
my instant meetings in Cisco WebEx Meeting Center.

Call Preservation
TheCiscoUnified CommunicationManager call preservation feature ensures that an active call is not interrupted
when a Cisco Unified Communication Manager node fails or when communication fails between the device
and the Cisco Unified Communication Manager node that set up the call.

When a user on a call using Cisco Jabber for iPhone and iPad switches from wi-fi to mobile data network
or vice-versa, the interface IP address is lost and the call is preserved. When the user returns to the initial
network and the IP address is restored, they can continue with the call.

Note
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Configure Prompts for Presence Subscription Requests
You can enable or disable prompts for presence subscription requests from contacts within your organization.

The client always prompts users to allow presence subscription requests from contacts outside your organization.

Users specify privacy settings in the client as follows:

Inside Your Organization

Users can choose to allow or block contacts from inside your organization.

• If users choose to allow presence subscription requests and

• you select Allow users to view the availability of other users without being prompted
for approval, the client automatically accepts all presence subscription requests without
prompting users.

• you do not select Allow users to view the availability of other users without being
prompted for approval, the client prompts users for all presence subscription requests.

• If users choose to block contacts, only their existing contacts can see their availability status. In
other words, only those contacts who have already subscribed to the user's presence can see their
availability status.

When searching for contacts in your organization, users can see the temporary
availability status of all users in the organization. However, if User A blocks
User B, User B cannot see the temporary availability status of User A in the
search list.

Note

Outside Your Organization

Users can choose the following options for contacts from outside your organization:

• Have the client prompt them for each presence subscription request.

• Block all contacts so that only their existing contacts can see their availability status. In other
words, only those contacts who have already subscribed to the user's presence can see their
availability status.

Before You Begin

This feature is supported for on-premises deployment and is only available on Cisco Unified Communications
Manager, release 8.x or later.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 Select Presence > Settings.
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The Presence Settings window opens.

Step 3 SelectAllow users to view the availability of other users without being prompted for approval to disable
prompts and automatically accept all presence subscription requests within your organization.
This option has the following values:

• Selected— The client does not prompt users for presence subscription requests. The client automatically
accepts all presence subscription requests without prompting the users.

• Cleared— The client prompts users to allow presence subscription requests. This setting requires users
to allow other users in your organization to view their availability status.

Step 4 Select Save.

Disable Temporary Presence in Cisco Unified Communications Manager IM
and Presence

Disable temporary presence to increase privacy control. When you configure this parameter, Cisco Jabber
displays availability status only to contacts in a user's contact list.

Before You Begin

This feature is supported for on-premises deployment and requires Cisco Unified Communications Manager,
release 9.x or later.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 Select Presence > Settings.
Step 3 Uncheck Enable ad-hoc presence subscriptions and then select Save.

Cisco Jabber does not display temporary presence. Users can see availability status only for contacts in their
contact list.

Disable Temporary Presence in Cisco Unified Presence
Disable temporary presence to increase privacy control. When you configure this parameter, Cisco Jabber
displays availability status only to contacts in a user's contact list.

Before You Begin

This feature is supported for on-premises deployment and requires Cisco Unified Communications Manager,
release 8.x or later.
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Procedure

Step 1 Open the Cisco Unified Presence Administration interface.
Step 2 Select Presence > Settings.
Step 3 Uncheck Enable ad-hoc presence subscriptions and then select Save.

Cisco Jabber does not display temporary presence. Users can see availability status only for contacts in their
contact list.

Enable URI Dialing
URI dialing allows users to make calls and resolve contacts with Uniform Resource Identifiers (URI). For
example, a user named Adam McKenzie has the following SIP URI associated with his directory number:
amckenzi@example.com. URI dialing enables users to call Adam with his SIP URI rather than his
directory number.

For detailed information on URI dialing requirements, such as valid URI formats, as well as advanced
configuration including ILS setup, see theURI Dialing section of theCisco Unified CommunicationsManager
System Guide.

Before You Begin

This feature is supported for on-premises deployment. You can enable URI dialing on Cisco Unified
Communications Manager, release 9.1(2) or later.

Associate URIs to Directory Numbers
When users makeURI calls, Cisco Unified CommunicationsManager routes the inbound calls to the directory
numbers associated to the URIs. For this reason, you must associate URIs with directory numbers. You can
either automatically populate directory numbers with URIs or configure directory numbers with URIs.

Automatically Populate Directory Numbers with URIs

When you add users to Cisco Unified Communications Manager, you populate the Directory URI field with
a valid SIP URI. Cisco Unified Communications Manager saves that SIP URI in the end user configuration.

When you specify primary extensions for users, Cisco Unified Communications Manager populates the
directory URI from the end user configuration to the directory number configuration. In this way, automatically
populates the directory URI for the user's directory number. Cisco Unified Communications Manager also
places the URI in the default partition, which is Directory URI.

The following task outlines, at a high level, the steps to configure Cisco Unified Communications Manager
so that directory numbers inherit URIs:
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Procedure

Step 1 Add devices.
Step 2 Add directory numbers to the devices.
Step 3 Associate users with the devices.
Step 4 Specify primary extensions for users.

What to Do Next

Verify that the directory URIs are associated with the directory numbers.

Configure Directory Numbers with URIs
You can specify URIs for directory numbers that are not associated with users. You should configure directory
numbers with URIs for testing and evaluation purposes only.

To configure directory numbers with URIs, do the following:

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing > Directory Number.

The Find and List Directory Numbers window opens.

Step 3 Find and select the appropriate directory number.
The Directory Number Configuration window opens.

Step 4 Locate the Directory URIs section.
Step 5 Specify a valid SIP URI in the URI column.
Step 6 Select the appropriate partition from the Partition column.

You cannot manually add URIs to the system Directory URI partition. You should add the URI to
the same route partition as the directory number.

Note

Step 7 Add the partition to the appropriate calling search space so that users can place calls to the directory numbers.
Step 8 Select Save.

Associate the Directory URI Partition

You must associate the default partition into which Cisco Unified Communications Manager places URIs
with a partition that contains directory numbers.
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To enable URI dialing, you must associate the default directory URI partition with a partition that contains
directory numbers.

If you do not already have a partition for directory numbers within a calling search space, you should
create a partition and configure it as appropriate.

Important

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Enterprise Parameters.

The Enterprise Parameters Configuration window opens.

Step 3 Locate the End User Parameters section.
Step 4 In the Directory URI Alias Partition row, select the appropriate partition from the drop-down list.
Step 5 Click Save.

The default directory URI partition is associated with the partition that contains directory numbers. As a result,
Cisco Unified Communications Manager can route incoming URI calls to the correct directory numbers.

You should ensure the partition is in the appropriate calling search space so that users can place calls to the
directory numbers.

Enable FQDN in SIP Requests for Contact Resolution
To enable contact resolution with URIs, you must ensure that Cisco Unified Communications Manager uses
the fully qualified domain name (FQDN) in SIP requests.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Device Settings > SIP Profile.

The Find and List SIP Profiles window opens.

Step 3 Find and select the appropriate SIP profile.
You cannot edit the default SIP profile. If required, you should create a copy of the default SIP
profile that you can modify.

Remember

Step 4 Select Use Fully Qualified Domain Name in SIP Requests and then select Save.

What to Do Next

Associate the SIP profile with all devices that have primary extensions to which you associate URIs.
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Set Up Voicemail Avoidance
Voicemail avoidance is a feature that prevents calls from being answered by the mobile service provider voice
mail. This feature is useful if a user receives a Mobile Connect call from the enterprise on the mobile device.
It is also useful when an incoming DvO-R call is placed to the mobile device.

You can set up Voicemail Avoidance in one of two ways:

• Timer-controlled — (Default) With this method, you set timers on the Cisco Unified Communications
Manager to determine if the call is answered by the mobile user or mobile service provider voicemail.

• User-controlled —With this method, you set the Cisco Unified Communications Manager to require
that a user presses any key on the keypad of the device to generate a DTMF tone before the call can
proceed.

If you deploy DvO-R, Cisco recommends that you also set user-controlled Voicemail Avoidance. If you set
user-controlled Voicemail Avoidance, this feature applies to both DvO-R and Mobile Connect calls.

For more information about voicemail avoidance, see the Confirmed Answer and DvO VM detection section
in the Cisco Unified Communications Manager Features and Services Guide for your release.

Set Up Timer-Controlled Voicemail Avoidance
Set up the timer control method by setting the Answer Too Soon Timer and Answer Too Late Timer on
either the Mobility Identity or the Remote Destination. For more information, see the Add Mobility Identity
or Add Remote Destination (Optional) topics.

Before You Begin

Timer-controlled voicemail avoidance is supported on Cisco Unified Communications Manager, release 6.0
and later.

Set Up User-Controlled Voicemail Avoidance

User-controlled voicemail avoidance is available on Cisco Unified Communications Manager, release 9.0
and later.

Important

Set up User-Controlled Voicemail Avoidance as follows:

1 Set up Cisco Unified CommunicationsManager using the Set Up Cisco Unified CommunicationsManager
to Support Voicemail Avoidance topic.

2 Set up the device using one of the following topics:

• Enable Voicemail Avoidance on Mobility Identity

• Enable Voicemail Avoidance on Remote Destination
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Cisco does not support user-controlled voicemail avoidance when using DvO-R with alternate numbers
that the end user sets up in the client. An alternate number is any phone number that the user enters in the
DvO Callback Number field on the client that does not match the phone number that you set up on the
user's Mobility Identity.

If you set up this feature with alternate numbers, the Cisco Unified Communications Manager connects
the DvO-R calls even if the callback connects to a wrong number or a voicemail system.

Important

Set Up Cisco Unified Communications Manager to Support Voicemail Avoidance

Use this procedure to set up the Cisco Unified CommunicationsManager to support user-controlled Voicemail
Avoidance.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters.
Step 3 In the Server drop-down list, select the active Cisco Unified Communications Manager.
Step 4 In the Service drop-down list, select the Cisco Call Manager (Active) service.
Step 5 Configure the settings in theClusterwide Parameters (System -Mobility Single Number ReachVoicemail)

section.
The settings in this section are not specific to Cisco Jabber. For information about how to configure
these settings, see the Confirmed Answer and DvO VM detection section in the Cisco Unified
Communications Manager Administrator Guide for your release.

Note

Step 6 Click Save.

Enable Voicemail Avoidance on Mobility Identity

Use this procedure to enable user-controlled voicemail avoidance for the end user's mobility identity.

Before You Begin

• Set up the annunciator on the Cisco Unified Communications Manager. For more information, see the
Annunciator setup section in theCisco Unified CommunicationsManager Administrator Guide for your
release.

• If you set up a Media Resource Group on the Cisco Unified Communications Manager, set up the
annunciator on the Media Resource Group. For more information, see theMedia resource group setup
section in the Cisco Unified Communications Manager Administrator Guide for your release.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Navigate to the device that you want to configure as follows:

a) Select Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 3 In the Associated Mobility Identity section, click the link for the Mobility Identity.
To ensure that the Voicemail Avoidance feature works correctly, the DvO Callback Number that the
end user enters in the Cisco Jabber client must match the Destination Number that you enter on the
Mobility Identity Configuration screen.

Note

Step 4 Set the policies as follows:

• Cisco Unified Communications Manager release 9— In the Single Number Reach Voicemail Policy
drop-down list, select User Control.

• Cisco Unified Communications Manager release 10 without Dial via Office— In the Single Number
Reach Voicemail Policy drop-down list, select User Control.

• Cisco Unified Communications Manager release 10 with Dial via Office

◦In the Single Number Reach Voicemail Policy drop-down list, select Timer Control.

◦In the Dial-via-Office Reverse Voicemail Policy drop-down list, select User Control.

Step 5 Click Save.

Enable Voicemail Avoidance on Remote Destination

Use this procedure to enable user-controlled voicemail avoidance for the end user's remote destination.

Before You Begin

• Set up the annunciator on the Cisco Unified Communications Manager. For more information, see the
Annunciator setup section in the Cisco Unified CommunicationsManager Administrator Guide for your
release.

• If you set up a Media Resource Group on the Cisco Unified Communications Manager, set up the
annunciator on the Media Resource Group. For more information, see theMedia resource group setup
section in the Cisco Unified Communications Manager Administrator Guide for your release.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Navigate to the device that you want to configure as follows:

a) Select Device > Phone.
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b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 3 In the Associated Remote Destinations section, click the link for the associated remote destination.
Step 4 Set the policies as follows:

• Cisco Unified Communications Manager release 9— In the Single Number Reach Voicemail Policy
drop-down list, select User Control.

• Cisco Unified Communications Manager release 10 without Dial via Office— In the Single Number
Reach Voicemail Policy drop-down list, select User Control.

• Cisco Unified Communications Manager release 10 with Dial via Office

◦In the Single Number Reach Voicemail Policy drop-down list, select Timer Control.

◦In the Dial-via-Office Reverse Voicemail Policy drop-down list, select User Control.

Step 5 If using Cisco Unified Communications Manager Version 10 with the Dial via Office feature,
Step 6 Click Save.

Enable File Transfers and Screen Captures
File transfers and screen captures are enabled in Cisco Unified Communications Manager IM and Presence
Service. There are additional parameters that are specified in the Cisco Jabber client configuration file. For
more information on these parameters, see the Policies parameters.

To configure file transfers and screen captures in Cisco Unified Communications Manager IM and Presence
Service 9.x or later complete the Enable File Transfers and Screen Captures.

Cisco Unified CommunicationsManager IM and Presence Service, release 10.5(2) or later provides additional
file transfer options:

• For peer to peer chats complete the Enable File Transfer and Screen Captures for Peer to Peer Chats
only .

• For group chats and chat rooms complete the Enable File Transfer and Screen Captures for Group Chat
Rooms. Enable File Transfer and Screen Captures for Group Chats and Chat Rooms, on page 189

• To configure maximum file transfer size complete the Configuring Maximum File Transfer Size.

If your deployment includes earlier versions of the Cisco Jabber client that do not support these additional
file transfer methods, there is an option to select Managed and Peer-to-Peer File Transfer. For more detailed
information, see the Cisco Unified Communications Manager IM and Presence Service, Release 10.5(2)
guides.

Related Topics

Cisco Jabber 11.0 Parameters Reference Guide
Enable File Transfers and Screen Captures, on page 189
Enable File Transfer and Screen Captures for Group Chats and Chat Rooms, on page 189
Enable File Transfer and Screen Captures for Peer to Peer Chats Only , on page 190
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Configuring Maximum File Transfer Size, on page 190

Enable File Transfers and Screen Captures

File transfers and screen captures are supported for both desktop and mobile clients.Note

Before You Begin

You can enable or disable file transfers and screen captures on Cisco Unified Communication Manager IM
and Presence Service 9.x and later, through the Cisco XCP Router service on Cisco Unified Communications
Manager IM and Presence Service. File transfers and screen captures parameter is enabled by default. However,
you should verify the setting when you set up your deployment.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 Select System > Service Parameters.
Step 3 Select the appropriate server from the Server drop-down list.
Step 4 Select Cisco XCP Router from the Service drop-down list.

The Service Parameter Configuration window opens.

Step 5 Locate the Enable file transfer parameter.
Step 6 Select the appropriate value from the Parameter Value drop-down list.
Step 7 Select Save.

Enable File Transfer and Screen Captures for Group Chats and Chat Rooms
Files and screen captures transferred are stored on a file server and the metadata is logged to a database server.
For Cisco Jabber clients that do not support chat rooms, this option enables file transfer in group chats.

When you enable this option, file transfers and screen captures are also available in peer to peer chats and the
files and screen captures transferred are stored on a file server and the metadata is logged to a database server.

Before You Begin

File transfer and screen captures for group chats and chat rooms is only available on Cisco Unified
Communications Manager IM and Presence Service, release 10.5(2) or later.

Configure an external database to log metadata associated with the file transfer, see Database Setup for IM
and Presence Service on Cisco Unified Communications Manager, Release 10.5(2) for further information.

Configure a network file server to save the file being transferred, see Configuration and Administration of
IM and Presence Service on Cisco Unified CommunicationsManager, Release 10.5(2) for further information.
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Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 SelectMessaging > File Transfer.
Step 3 In the File Transfer Configuration section selectManaged File Transfer.
Step 4 In theManaged File Transfer Assignment section, assign the external database and the external file server

for each node in the cluster.
Step 5 Select Save.

What to Do Next

For each node:

• Copy the node's public key to the external file server's authorized_keys file, including the node's
IP address, hostname, or FQDN.

• Ensure the Cisco XCP File Transfer Manager service is active.

• Restart the Cisco XCP Router service.

Enable File Transfer and Screen Captures for Peer to Peer Chats Only
Enable file transfer for peer to peer chats on Cisco Unified CommunicationsManager IM and Presence Service,
release 10.5(2) or later. Files and screen captures are only transferred in a peer to peer chat. The file or screen
capture information is not logged or archived.

Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 SelectMessaging > File Transfer.
Step 3 In the File Transfer Configuration section, select Peer-to-Peer.
Step 4 Select Save.

What to Do Next

Restart the Cisco XCP Router service.

Configuring Maximum File Transfer Size
Themaximum file size is only available on Cisco Unified CommunicationsManager IM and Presence Service,
release 10.5(2) or later.

Before You Begin

The file transfer type selected isManaged File Transfer.
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Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 SelectMessaging > File Transfer.
Step 3 In theManaged File Transfer Configuration section enter the amount for theMaximum File Size.
Step 4 Select Save.

What to Do Next

Restart the Cisco XCP Router service.

Cisco Jabber Features for Windows

Call Pickup
Call pickup allows users to pick up incoming calls within their own group. Directory numbers are assigned
to call pickup groups and Cisco Unified Communications Manager automatically dials the appropriate call
pickup group number. Users select Pickup to answer the call.

Group call pickup allows users to pick up incoming calls in another group. Users enter the group pickup
number, select Pickup and Cisco Unified Communications Manager automatically dials the appropriate call
pickup group number.

Other group pickup allows users to pick up incoming calls in a group that is associated with their group.When
the user selectsOther PickupCiscoUnified CommunicationsManager automatically searches for the incoming
call in the associated groups.

Directed call pickup allows users to pick up an incoming call on a directory number. Users enter the directory
number, select Pickup and Cisco Unified Communications Manager connects the incoming call.

For more information on configuring call pickup, see the call pickup topics in the relevant Cisco Unified
Communications Manager documentation.

Call pickup notifications

For multiple incoming calls, the notification displayed is Call(s) available for pickup. When the user selects
the call, the call answered is the longest call in the group.

Deskphone mode

In desk phone mode the following limitations apply:

• The Cisco Unified Communications Manager notification settings are not supported for the pickup
group. The call pickup notification displayed is CallerA->CallerB.

• The Cisco Unified Communications Manager settings for audio and visual settings are not supported.
The visual alerts are always displayed.
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Shared line behavior

For users that have a deskphone and a CSF softphone with a shared line the following limitations occur:

• Attempt to pickup a call using the softphone when there is no call available,No call available for PickUp
is displayed on the deskphone.

• Attempt to pickup a call using the deskphone when there is no call available,No call available for PickUp
is displayed on the softphone.

User not a member of an associated group

For an incoming call to another pickup group where the user is not a member of an associated group:

• Directed call pickup can be used to pickup the incoming call.

• Group pickup does not work

Expected behavior using group call pickup and directed call pickup

The following are expected behaviors when using group call pickup and directed call pickup:

• Enter an invalid number

• Softphone mode—The conversation window appears and the annunciator is heard immediately

• Deskphone mode—The conversation window, fast busy tone, or the annunciator followed by the
fast busy tone, Pickup failed error message.

• Enter a valid number and no current call available to pick up

• Softphone mode—Tone in headset, no conversation window appears and No call available for
pickup error message.

• Deskphone mode—No conversation window and No call available for pickup error message.

• Enter directory number of a phone in an associated group and no current call available to pick up

• Softphone mode—Tone in headset, no conversation window appears and No call available for
pickup error message.

• Deskphone mode—No conversation window and No call available for pickup error message.

• Enter a directory number of a phone on the same Cisco Unified Communications Manager and not in
an associated group

• Softphone mode—Conversation window appears and fast busy tone.

• Deskphone mode—Conversation window appears, fast busy tone, and Pickup failed error message.

• Enter first digits of a valid group

• Softphonemode—Tone in headset, conversation window appears, and after 15 seconds annunciator
followed by the fast busy tone.

• Deskphone mode—Conversation window appears, after 15 seconds annunciator, fast busy tone,
and Pickup failed error message.
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Call pickup using a deskphone that is not in a call pickup group

User attempting a call pickup from a deskphone that is not in a call pickup group. The conversation window
will appear for a moment. The user should not be configured to use the call pickup feature if they are not
members of a call pickup group.

Original recipient information not available

When Cisco Unified Communications Manager Auto Call Pickup Enabled setting is true, the recipient
information is not available in the client when the call is picked up in softphone mode. If the setting is false,
the recipient information is available.

Configure Call Pickup Group
Call pickup groups allow users to pick up incoming calls in their own group.

Procedure

Step 1 Open the Cisco Unified Communication Manager interface.
Step 2 Select Call Routing > Call Pickup Group

The Find and List Call Pickup Groups window opens.

Step 3 Select Add New
The Call Pickup Group Configuration window opens.

Step 4 Enter call pickup group information:
a) Specify a unique name for the call pickup group.
b) Specify a unique directory number for the call pickup group number.
c) Enter a description.
d) Select a partition.

Step 5 (Optional) Configure the audio or visual notification in theCall PickupGroup Notification Settings section.
a) Select the notification policy.
b) Specify the notification timer.
For further information on call pickup group notification settings see the call pickup topics in the relevant
Cisco Unified Communications Manager documentation.

Step 6 Select Save.

What to Do Next

Assign a call pickup group to directory numbers.

Assign Directory Number
Assign a call pickup group to a directory number. Only directory numbers that are assigned to a call pickup
group can use call pickup, group call pickup, other group pickup, and directed call pickup.
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Before You Begin

Before you assign a call pickup group to a directory number, you must create the call pickup group.

Procedure

Step 1 Open the Cisco Unified Communications Manager Administration interface.
Step 2 Assign a call pickup group to a directory number using one of the following methods:

• SelectCall Routing >Directory Number, find and select your directory number and in the Call Forward
and Call Pickup Settings area select the call pickup group from the call pickup group drop down list.

• Select Device > Phone, find and select your phone and in the Association Information list choose the
directory number to which the call pickup group will be assigned.

Step 3 To save the changes in the database, select Save.

Configure Other Call Pickup
Other Group Pickup allows users to pick up incoming calls in an associated group. Cisco Unified
Communications Manager automatically searches for the incoming call in the associated groups to make the
call connection when the user selects Other Pickup.

Before You Begin

Before you begin, configure call pickup groups.

Procedure

Step 1 Open the Cisco Unified Communication Manager Administration interface.
Step 2 Select Call Routing > Call Pickup Group

The Find and List Call Pickup Groups window opens.

Step 3 Select your call pickup group.
The Call Pickup Group Configuration window opens.

Step 4 In the Associated Call Pickup Group Information section, you can do the following:

• Find call pickup groups and add to current associated call pickup groups.

• Reorder associated call pickup groups or remove call pickup groups.

Step 5 Select Save.
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Configure Directed Call Pickup
Directed call pickup allows you to pick up a incoming call directly. The user enters the directory number in
the client and selects Pickup. Cisco Unified Communications Manager uses the associated group mechanism
to control if the user can pick up an incoming call using Directed Call Pickup.

To enable directed call pickup, the associated groups of the user must contain the pickup group to which the
directory number belongs.

When the user invokes the feature and enters a directory number to pick up an incoming call, the user connects
to the call that is incoming to the specified phone whether or not the call is the longest incoming call in the
call pickup group to which the directory number belongs.

Procedure

Step 1 Configure call pickup groups and add associated groups. The associated groups list can include up to 10
groups.
For more information, see topics related to defining a pickup group for Other Group Pickup.

Step 2 Enable the Auto Call Pickup Enabled service parameter to automatically answer calls for directed call pickups.
For more information, see topics related to configuring Auto Call Pickup.

Auto Call Pickup
You can automate call pickup, group pickup, other group pickup, and directed call pickup by enabling the
Auto Call Pickup Enabled service parameter.

When this parameter is enabled, Cisco Unified Communications Manager automatically connects users to the
incoming call in their own pickup group, in another pickup group, or a pickup group that is associated with
their own group after users select the appropriate pickup on the phone. This action requires only one keystroke.

Auto call pickup connects the user to an incoming call in the group of the user. When the user selects Pickup
on the client, Cisco Unified Communications Manager locates the incoming call in the group and completes
the call connection. If automation is not enabled, the user must select Pickup and answer the call, to make
the call connection.

Auto group call pickup connects the user to an incoming call in another pickup group. The user enters the
group number of another pickup group and selects Pickup on the client. Upon receiving the pickup group
number, Cisco Unified Communications Manager completes the call connection. If auto group call pickup is
not enabled, dial the group number of another pickup group, select Pickup on the client, and answer the call
to make the connection.

Auto other group pickup connects the user to an incoming call in a group that is associated with the group of
the user. The user selectsOther Pickup on the client. Cisco Unified Communications Manager automatically
searches for the incoming call in the associated groups in the sequence that the administrator enters in the
Call Pickup Group Configuration window and completes the call connection after the call is found. If
automation is not enabled, the user must selectOther Pickup, and answer the call to make the call connection.

Auto directed call pickup connects the user to an incoming call in a group that is associated with the group
of the user. The user enters the directory number of the ringing phone and selects Pickup on the client. Upon
receiving the directory number, Cisco Unified Communications Manager completes the call connection. If
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auto directed call pickup is not enabled, the user must dial the directory number of the ringing phone, select
Pickup, and answer the call that will now ring on the user phone to make the connection.

Formore information onCall Pickup, see the relevant CiscoUnified CommunicationsManager documentation.

Configure Auto Call Pickup

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters
Step 3 Select your server from the Server drop down list and then select the Cisco Call Manager service from the

Service drop down list.
Step 4 In the Clusterwide Parameters (Feature - Call Pickup) section, select one of the following for Auto Call

Pickup Enabled:

• true— The auto call pickup feature is enabled.

• false— The auto call pickup feature is not enabled. This is the default value.

Step 5 Select Save.

Persistent Chat Rooms

Configure Persistent Chat
Persistent chat must be enabled and configured on Cisco Unified Communications Manager IM and Presence
Service before it can be used by the client.

Before You Begin

Persistent chat is only available on Cisco Unified Communications Manager IM and Presence Service 10.0
and later.

Refer to Database Setup for IM and Presence Service on Cisco Unified Communications Manager for your
release for information on the database configuration necessary to support the persistent chat feature. Database
configuration must be performed before continuing with this task.

Local chat message archiving must be enabled for persistent chat. Local chat message archiving is enabled
on Cisco Unified Communications Manager IM and Presence Service using the Allow clients to log instant
message history setting, for more information, see the Enable Message Settings topic.
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Procedure

Step 1 Open the Cisco Unified CM IM and Presence Administration interface.
Step 2 SelectMessaging > Group Chat and Persistent Chat.
Step 3 Select Enable Persistent Chat.
Step 4 Ensure the settingsHow many users can be in a room at one time andHow many hidden users can be in

a room at one time under the Occupancy Settings section contain the same, non-zero value.
Step 5 Configure the remaining settings as appropriate for your persistent chat deployment. We recommend the

persistent chat settings in following table.
NotesRecommended ValuePersistent Chat Setting

DisabledSystem automatically manages primary group
chat server aliases

EnabledEnable persistent chat

This value is not currently used by
for persistent chat.

Administrator
Defined

Archive all room joins and exits

EnabledArchive all room messages

Cisco recommends using the value
Enabled unless Cisco Unified
Personal Communicator is
deployed in the enterprise
environment.

Administrator
Defined

Allow only group chat system administrators to
create persistent chat rooms

Administrator
Defined

Maximum number of persistent chat rooms
allowed

Default ValueNumber of connections to the database

Default ValueDatabase connection heartbeat interval (seconds)

Default ValueTimeout value for persistent chat rooms
(minutes)

Default ValueMaximum number of rooms allowed

DisabledRooms are for members only by default

Cisco Jabber requires this value to
be Enabled.

EnabledRoom owners can change whether or not rooms
are for members only

Cisco Jabber requires this value to
be Enabled.

EnabledOnly moderators can invite people to
members-only rooms
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NotesRecommended ValuePersistent Chat Setting

EnabledRoom owners can change whether or not only
moderators can invite people to members-only
rooms

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledUsers can add themselves to rooms as members

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRoom owners can change whether users can add
themselves to rooms as members

Cisco Jabber requires this value to
be Enabled.

EnabledMembers and administrators who are not in a
room are still visible in the room

EnabledRoom owners can change whether members and
administrators who are not in a room are still
visible in the room

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRooms are backwards-compatible with older
clients

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRoom owners can change whether rooms are
backwards-compatible with older clients

This value is not currently
supported by Cisco Jabber for
persistent chat. Cisco Jabber cannot
join anonymous rooms.

DisabledRooms are anonymous by default

This value is not currently
supported by Cisco Jabber for
persistent chat. Cisco Jabber cannot
join anonymous rooms.

DisabledRoom owners can change whether or not rooms
are anonymous

This value is not currently used by
Cisco Jabber for persistent chat.

Default ValueLowest participation level a user can have to
invite others to the room

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRoom owners can change the lowest
participation level a user can have to invite
others to the room

Cisco recommends using the
default value.

Administrator
Defined

How many users can be in a room at one time

Administrator
Defined

Howmany hidden users can be in a room at one
time

Default ValueDefault maximum occupancy for a room
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NotesRecommended ValuePersistent Chat Setting

Default ValueRoom owners can change default maximum
occupancy for a room

Default ValueLowest participation level a user can have to
send a private message from within the room

Default ValueRoom owners can change the lowest
participation level a user can have to send a
private message from within the room

ModeratorLowest participation level a user can have to
change a room's subject

DisabledRoom owners can change the lowest
participation level a user can have to change a
room's subject

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRemove all XHTML formatting frommessages

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRoom owners can change XHTML formatting
setting

This value is not currently used by
Cisco Jabber for persistent chat.

DisabledRooms are moderated by default

This value is not currently used by
Cisco Jabber for persistent chat.

Default ValueRoom owners can change whether rooms are
moderated by default

Default ValueMaximum number of messages that can be
retrieved from the archive

Cisco recommends a value between
15 and 50. The Number of
messages in chat history
displayed by default setting does
not apply retroactively to persistent
chat rooms. Rooms created before
the setting is changed will continue
to use their originally configured
value.

Administrator
Defined

Number of messages in chat history displayed
by default

This value is not currently used by
Cisco Jabber for persistent chat.

Default ValueRoom owners can change the number of
messages displayed in chat history

Persistent Chat rooms inherit their settings at the time of creation. Values changed after a room is
created only apply to rooms created after the change has taken effect.

Note
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What to Do Next

Ensure you configure any client-specific parameters for persistent chat. For more information, see the Client
Parameters.

Enable file transfer in chat rooms. For more information, see Enable File Transfer and Screen Captures for
Group Chats and Chat Rooms

Related Topics

Database Setup for IM and Presence Service on Cisco Unified Communications Manager
Client Parameters, Cisco Jabber 11.0 Parameters Reference Guide
Enable Message Settings, on page 35

Administer and Moderate Persistent Chat Rooms

Note • Persistent Chat Rooms and their administration is for on-premises deployments only.

• Persistent Chat Rooms are not available for mobile clients.

You administer persistent chat rooms from the Jabber client by creating rooms, delegating their moderators,
and specifying members. The node on which the room is created is created automatically, although you can
override it and specify a specific node. Administrators and moderators are privileged users in Persistent Chat
rooms. You can administer Persistent Chat rooms on any service node that you are an administrator for on
Cisco Unified Communications Manager IM and Presence servers.

Administrator Capabilities

Administrators can perform the following tasks from the All Rooms tab of Persistent Chat in the client hub
window:

• Create rooms. When you create a room, you automatically become the room administrator.

• Define and change up to 30 moderators for a chat room (who become room owners).

• Specify and change the room name.

• Define the maximum number of participants in a room. This number cannot be less than the number of
participants already in a room.

• Add and remove room members.

• Block, remove, and revoke participants.

• Destroy rooms (which removes it from the server, but the history is not deleted).

Moderator Capabilities

Up to 30moderators can be defined by an administrator for one Persistent Chat room.Moderators can perform
the following tasks:

• Change the subject of a room.
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• Edit members (which includes adding, removing, and banning them).

Room Creation

When creating a room, you can provide the following types of information:

• Room name (required, maximum 200 characters)

• Description

• Room type (public or restricted)

After the room type has been defined, it cannot be changed by anyone.

• Specify whether to add the room to yourMy Rooms tab (off by default)

• Add up to 30 moderators (who must have a valid Jabber ID to moderate a room).

• Room password

After you create the room, you have the option to add members to the room immediately or at a later time.
Refresh the All Rooms list in order to see your new room in the list of available rooms.

Enable Persistent Chat Room Passwords
Persistent chat rooms that are password protected means that when users enter a roomwithin a Jabber session,
they must enter the password. Password protected rooms comply with the XEP-0045 specification from the
XMPP Standards Foundation.

Procedure

Step 1 To set a password for a room, from the Chat Rooms tab on the hub window, select All rooms > New room
> Password.

Step 2 To change the password for a room, open the chat room, click on Edit Room, select Password, then edit and
save the password.

Integrate with Microsoft Products
Cisco Jabber for Windows supports a range of Microsoft products that integrate with the application. This
section describes the support and integrations for these products.

Internet Explorer

Microsoft Internet Explorer 8 or later is required. Cisco Jabber for Windows uses the Internet Explorer
rendering engine to display HTML content.

Cisco Jabber for Windows requires Internet Explorer active scripting to render IMs. See http://
windows.microsoft.com/en-US/windows/help/genuine/ie-active-script for instructions on enabling active
scripting.
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Internet Explorer 9 users in Cloud-based deployments that use Single Sign On (SSO) get security alerts
when they sign in to Cisco Jabber for Windows. Add webexconnect.com to the list of websites in the
Compatibility View Settings window of Internet Explorer 9 to stop these alerts.

Note

Office

Integration with the following versions of Office is supported:

• Microsoft Office 2010, 32 and 64 bit

• Microsoft Office 2013, 32 and 64 bit

Office 365

Microsoft Office 365 supports different configuration types based on the plan or subscription type. Cisco
Jabber for Windows has been tested with small business plan P1 of Microsoft Office 365. This plan requires
an on-premises Active Directory server.

Client-side integration with Microsoft Office 365 is supported with the following applications:

• Microsoft Office 2013 32 bit and 64 bit

• Microsoft Office 2010 32 bit and 64 bit

• Microsoft SharePoint 2010

SharePoint

Integration with the following versions of SharePoint is supported:

• Microsoft SharePoint 2010

• Microsoft SharePoint 2013

Availability status in Microsoft SharePoint sites is supported only if users access those sites with Microsoft
Internet Explorer. You should add theMicrosoft SharePoint site to the list of trusted sites in Microsoft Internet
Explorer.

Calendar Integration
You can use the following client applications for calendar integration:

• Microsoft Outlook 2013 32 bit

• Microsoft Outlook 2013 64 bit

• Microsoft Outlook 2010 32 bit

• Microsoft Outlook 2010 64 bit

• IBM Lotus Notes 9 32 bit

• IBM Lotus Notes 8.5.3 32 bit

• IBM Lotus Notes 8.5.2 32 bit
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• IBM Lotus Notes 8.5.1 32 bit

• Google Calendar

Enable Calendar Events from Microsoft Outlook
You must apply a setting in Microsoft Outlook so that calendar events display in Cisco Jabber for Windows.

Procedure

Step 1 Open the email account settings in Microsoft Outlook, as in the following example:
a) Select File > Account Settings.
b) Select the Email tab on the Account Settings window.

Step 2 Double-click the server name.
In most cases, the server name isMicrosoft Exchange.

Step 3 Select the Use Cached Exchange Mode checkbox.
Step 4 Apply the setting and then restart Microsoft Outlook.

When users create calendar events in Microsoft Outlook, those events display in theMeetings tab.

Enable Presence Integration with Microsoft Outlook
To enable integration with Microsoft Outlook, you specify SIP:user@cupdomain as the value of the
proxyAddresses attribute in Microsoft Active Directory. Users can then share availability in Microsoft
Outlook. Use one of the following methods to modify the proxyAddresses attribute:

• An Active Directory administrative tool such as Active Directory User and Computers
The Active Directory User and Computers administrative tool allows you to edit attributes on Microsoft
Windows Server 2008 or later.

• ADSchemaWizard.exe utility

The ADSchemaWizard.exe utility is available in the Cisco Jabber administration package. This utility
generates an LDIF file that modifies your directory to add the proxyAddresses attribute to each
user with the following value: SIP:user@cupdomain.

You should use the ADSchemaWizard.exe utility on servers that do not support the edit attribute feature
in the Active Directory User and Computers administrative tool. You can use a tool such as ADSI Edit
to verify the changes that you apply with the ADSchemaWizard.exe utility.

The ADSchemaWizard.exe utility requires Microsoft .NET Framework version 3.5 or later.

• Create a script with Microsoft Windows PowerShell

Refer to the appropriate Microsoft documentation for creating a script to enable presence in Microsoft
Outlook.
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Enable Presence with the Active Directory User and Computers Tool

Complete the following steps to enable presence in Microsoft Outlook for individual users with the Active
Directory User and Computers administrative tool:

Procedure

Step 1 Start the Active Directory User and Computers administrative tool.
You must have administrator permissions to run the Active Directory User and Computers administrative
tool.

Step 2 Select View in the menu bar and then select the Advanced Features option from the drop-down list.
Step 3 Navigate to the appropriate user in the Active Directory User and Computers administrative tool.
Step 4 Double click the user to open the Properties dialog box.
Step 5 Select the Attribute Editor tab.
Step 6 Locate and select the proxyAddresses attribute in the Attributes list box.
Step 7 Select Edit to open theMulti-valued String Editor dialog box.
Step 8 In the Value to add text box, specify the following value: SIP:user@cupdomain.

For example, SIP:msmith@cisco.com.

Where the user@cupdomain value is the user's instant messaging address. cupdomain corresponds to
the domain for Cisco Unified Presence or Cisco Unified Communications Manager IM and Presence Service.

Add Local Contacts from Microsoft Outlook

Cisco Jabber for Windows lets users search for and add local contacts in Microsoft Outlook. To enable this
integration with Microsoft Outlook, you must enable Cached Exchange Mode on the Microsoft Exchange
server.

To search for local contacts in Microsoft Outlook with the client, users must have profiles set in Microsoft
Outlook. In addition, users must do the following:

1 Select File > Options.

2 Select the Integration tab (Calendar tab from release 11.0).

3 Select either None orMicrosoft Outlook.

To add local Microsoft Outlook contacts to contact lists in the client, local contacts must have instant message
addresses in Microsoft Outlook.

To show contact photos in the client interface, local contacts in Microsoft Outlook must have instant message
addresses.

To communicate with local contacts inMicrosoft Outlook using the client, local contacts must have the relevant
details. To send instant messages to contacts, local contacts must have an instant message address. To call
contacts in Microsoft Outlook, local contacts must have phone numbers.
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Save Chat History to an Outlook Folder
This feature is available to Cisco Jabber for Windows clients.

This feature is available in the following versions of the client:
Supported ServersVersion of Cisco Jabber for

Windows

Microsoft Exchange 2013

Microsoft Exchange 2010

10.6

Microsoft Office 365

Microsoft Exchange 2013

Microsoft Exchange 2010

11.0

You can enable the client to automatically save chat histories to aCisco Jabber Chats folder in users' Microsoft
Outlook application. When a user closes a chat window, the client saves the IM conversation to the Exchange
server.

To enable the feature, you must:

• Set the EnableSaveChatHistoryToExchange parameter to true in the jabber-config.xml file.

• (optional) Set up a method to authenticate users to the Exchange server. If you don't specify an
authentication method, then users can authenticate directly from the Outlook tab in the Options menu
of their clients.

• Specify the method for determining which server to use.

For more information about all of the parameters that are needed to enable this feature, see the Options
Parameters.

Related Topics

Options Parameters, Cisco Jabber 11.0 Parameters Reference Guide

Limitations for Saving Chat History to an Outlook Folder

This feature can only be enabled if users have a Cisco Unified Communications Manager account.

Limitations with Authentication Methods over Cisco Expressway for Mobile and Remote Access

If you are enabling this feature for users connecting via the Expressway for Mobile and Remote Access, the
following limitations apply:

• If the client detects that the user is connecting via the Expressway, then the client uses the External
Server option for the Exchange connection. If the external server is not set, then it uses the internal
server.

• If the client detects that the user is not connecting via the Expressway, then the client uses the Internal
Server option for the Exchange connection. If the internal server is not set, the client uses the external
server.
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• However, if either the internal or external server is set, but for some reason Cisco Jabber can't connect
to it, the client doesn't revert to using the other server.

Authentication Modes

You must set up a method of authentication for the client to authenticate with the Exchange server. When
authentication is complete, the client has access to the Exchange server which allows saving chat histories to
a folder in Outlook.

If you do not specify an authentication method, then users must manually input their Exchange credentials
into the client, in the Outlook tab of the Options menu.

Authenticate Using Single Sign On for the Operating System
The client uses the account details of the logged in user to authenticate with the Exchange server. This
authentication method uses the Windows NT Lan Manager (NTLM) security protocol.

Do not use this authentication method if some users share the same Windows account. The client
authenticates with the account on the Operating System, and not with the user who is logged in to Cisco
Jabber. For example, User A logs onto a Windows machine and then logs into Cisco Jabber for a morning
shift. When the shift is done, Jabber is reset and User B logs into the client for the afternoon shift. Because
User A is logged into the Windows account, then the chat messages from User B are saved in the Outlook
account for User A.

Note

Before You Begin

Users and their computers must use domains. Authentication using single sign on does not work if users are
local Windows users.

Procedure

In the jabber-config.xml file, set the ExchangeAuthenticateWithSystemAccount parameter to true.

Authenticate by Synching Credentials
You can sync the Exchange credentials with another set of credentials for users, such as the Cisco Unified
Presence credentials. Using this method, the client uses the credentials to authenticate to the Exchange server.

Before You Begin

Procedure

Step 1 In the jabber-config.xml file, configure the Exchange_UseCredentialsFrom parameter.
Step 2 Define the value of the parameter as the service that you want used to sync credentials. For example,

<Exchange_UseCredentialsFrom>CUCM</Exchange_UseCredentialsFrom>.
In this example, Cisco Unified CommunicationsManager is defined as the service which provides the Exchange
server with credentials for authentication.

   Cisco Jabber 11.0 Deployment and Installation Guide
206

Cisco Jabber Options
Integrate with Microsoft Products



Specify Server Addresses

After you enable an authentication method for the client to access the Exchange server, you must enable a
method for the client to specify the Exchange server address.

If you do not specify server addresses, then users must manually enter the internal and external Exchange
servers in the client, in the Outlook > Advanced tab of the Options menu.

Detect Server Addresses Automatically
You can configure the client to automatically discover the Exchange servers based on users' domain. This
domain is defined when you set up the authentication method by using the domain that was specified for the
user's credentials.

Procedure

Step 1 In the jabber-config.xml file, configure the ExchangeAutodiscoverDomain parameter.
Step 2 Define the value of the parameter as the domain to discover the Exchange server.

The client uses the domain to search for the Exchange server at one of the following Web addresses:
https://<domain>/autodiscover/autodiscover.svc

https://autodiscover.<domain>/autodiscover/autodiscover.svc

Define Server Addresses
You can define the internal and external Exchange server addresses in the configuration file.

Procedure

Step 1 In the jabber-config.xml file, configure the InternalExchangeServer and ExternalExchangeServer
parameters.

Step 2 Define the value of the parameters using the Exchange server addresses.

IBM Notes Contact Search and Calendar Integration
Cisco Jabber for Windows supports IBM Notes calendar integration in the Meetings tab of the client. Cisco
Jabber also lets users search for and add local contacts in IBM Notes. To enable this integration with IBM
Notes, you must set the following parameters:

• EnableLocalAddressBookSearch=true

• EnableLotusNotesContactResolution=true

• CalendarIntegrationType=2

The CalendarIntegrationType parameter can be overridden by users. To enable calendar integration and contact
resolution with IBM Notes, users must ensure that the Calendar integration type on the Calendar tab of the
Options window is set to IBM Notes.
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In order for users to be able to successfully add IBM Notes contacts to their contact lists, the Messaging
ID field in IBM Notes must contain a valid value.

Note

Add Custom Emoticons
You can add custom emoticons to Cisco Jabber for Windows by creating emoticon definitions in an XML
file and saving it to the file system.

To achieve optimal results, your custom emoticons should conform to the following guidelines:Note

• Dimensions: 17 x 17 pixels

• Transparent background

• PNG file format

• RGB colors

Procedure

Step 1 Create a file named emoticonDefs.xml with any text editor.
Step 2 Specify the emoticon definitions as appropriate in emoticonDefs.xml.

See Emoticon Definitions for more information on the structure and available parameters for
emoticonDefs.xml.

Step 3 Save and close emoticonDefs.xml.
Step 4 Save emoticonDefs.xml in the appropriate directory on the file system.

Cisco Jabber for Windows loads emoticon definitions from the following directories on the file system.

• The directory can differ depending on your operating system

◦For 32-bit operating systems:

◦Program Files\Cisco Systems\Cisco Jabber\Emoticons

◦Program Files\Cisco Systems\Cisco Jabber\CustomEmoticons

◦For 64-bit operating systems:

◦Program Files(x86)\Cisco Systems\Cisco Jabber\Emoticons

◦Program Files(x86)\Cisco Systems\Cisco Jabber\CustomEmoticons

The Emoticons folder contains the default emoticons for Cisco Jabber for Windows and the default
emoticonDefs.xml.

   Cisco Jabber 11.0 Deployment and Installation Guide
208

Cisco Jabber Options
Add Custom Emoticons



The CustomEmoticons folder does not exist by default. Administrators can create this folder to
contain custom emoticon definitions to include in organizational deployments.

Emoticons that you define in the CustomEmoticons folder take precedence over emoticon definitions
in the default Emoticons folder.

• %USERPROFILE%\AppData\Roaming\Cisco\Unified
Communications\Jabber\CSF\CustomEmoticons

This folder contains custom emoticon definitions for individual instances of Cisco Jabber for Windows.

Emoticons that you define in this directory take precedence over emoticon definitions in the
CustomEmoticons folder in the installation directory.

Step 5 Restart Cisco Jabber for Windows.

Cisco Jabber for Windows loads the custom emoticon definitions in emoticonDefs.xml.

Custom emoticon definitions are available to users only if they are defined locally in
emoticonDefs.xml. If you send custom emoticons to users who do not have the same emoticon
definitions, those users receive the default keys, not the icons; for example:

Remember

1 User A defines a custom emoticon in emoticonDefs.xml.

The custom emoticon definition exists only on User A's local file system.

2 User A sends that custom emoticon to User B.

3 User B receives only the default key for the custom emoticon. User B does not receive the icon.

Emoticon Definitions
Cisco Jabber for Windows loads emoticon definitions from emoticonDefs.xml.

The following XML snippet shows the basic structure for the emoticon definitions file:
<emoticons>
<emoticon defaultKey="" image="" text="" order="" hidden="">
<alt></alt>
</emoticon>
</emoticons>

The following table describes the elements and attributes for defining custom emoticons:
DescriptionElement or attribute

This element contains all emoticon definitions.emoticons

This element contains the definition of an emoticon.emoticon
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DescriptionElement or attribute

This attribute defines the default key combination that renders the
emoticon.

Specify any key combination as the value.

This attribute is required.

defaultKey is an attribute of the emoticon element.

defaultKey

This attribute specifies the filename of the emoticon image.

Specify the filename of the emoticon as the value. The emoticon image
must exist in the same directory as emoticonDefs.xml.

This attribute is required.

Cisco Jabber for Windows supports any icon that Internet Explorer can
render, including .jpeg, .png, and .gif.

image is an attribute of the emoticon element.

image

This attribute defines the descriptive text that displays in the Insert
emoticon dialog box.

Specify any string of unicode characters.

This attribute is optional.

text is an attribute of the emoticon element.

text

This attribute defines the order in which emoticons display in the Insert
emoticon dialog box.

Specify an ordinal number beginning from 1 as the value.

order is an attribute of the emoticon element.

This attribute is required. However, if the value of hidden is true this
parameter does not take effect.

order
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DescriptionElement or attribute

This attribute specifies whether the emoticon displays in the Insert
emoticon dialog box.

Specify one of the following as the value:

true

Specifies the emoticon does not display in the Insert emoticon
dialog box. Users must enter the key combination to render the
emoticon.

false

Specifies the emoticon displays in the Insert emoticon dialog box.
Users can select the emoticon from the Insert emoticon dialog
box or enter the key combination to render the emoticon. This is
the default value.

This attribute is optional.

hidden is an attribute of the emoticon element.

hidden

This element enables you to map key combinations to emoticons.

Specify any key combination as the value.

For example, if the value of defaultKey is :), you can specify :-) as the
value of alt so that both key combinations render the same emoticon.

This element is optional.

alt

The default emoticons definitions file contains the following key combinations that enable users to request
calls from other users:

Remember

• :callme

• :telephone

These key combinations send the callme emoticon, or communicon. Users who receive this emoticon can
click the icon to initiate an audio call. You should include these key combinations in any custom emoticons
definition file to enable the callme emoticon.

Emoticon Definition Example
<emoticons>
<emoticon defaultKey=":)" image="Emoticons_Smiling.png" text="Smile" order="1">
<alt>:-)</alt>
<alt>^_^</alt>
</emoticon>
<emoticon defaultKey=":(" image="Emoticons_Frowning.png" text="Frown" order="2">
<alt>:-(</alt>
</emoticon>
</emoticons>
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Cisco Jabber Features for Mac

Persistent Chat Room Support
Cisco Jabber for Mac provides support for persistent chat rooms as follows:

• Users can participate in persistent chat rooms

• Users can carry out text searches within the persistent chat rooms

For more information, see Configure Persistent Chat section.

Local Contacts in Mac Address Book
Cisco Jabber allows users search for and add local contacts in the Mac Address book.

To search for local contacts in Mac Address book with the client, users must install the Address Book plug-in:

1 Select Jabber > Install Mac Address Book Plug-In.

To enable the Address Book plug-in:

1 Select Jabber > Preferences > General > Enable "Mac Address Plug-in".

2 Restart the client for this to take effect.

To communicate with local contacts in Mac Address book using the client, local contacts must have the
relevant details. To send instant messages to contacts, local contacts must have an instant message address.
To call contacts in Mac Address book, local contacts must have phone numbers.

Cisco Jabber for Android and iOS

Configure Call Park
You can use call park to place a call on hold and pick it up from another phone in a Cisco Unified
Communication Manager system. Call park must be enabled and extension numbers must be defined on each
Cisco Unified Communication Manager node in a cluster. You can define either a single directory number or
a range of directory numbers for use as call park extension numbers.

Complete the following tasks to enable call park. For detailed instructions, see the Features and Services
Guide for Cisco Unified Communication Manager.
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Procedure

PurposeCommand or Action

[Optional] Configure call park for the entire cluster, or use the
procedure in Step 3 to configure call park on individual nodes
within the cluster.

Configure cluster wide call
park

Step 1

Create a partition to add a call park number.Configure a partitionStep 2

Configure a call park number to use call park across nodes in a
cluster.

Configure a call park numberStep 3

You can define either a single directory number or a range of
directory numbers for use as call park extension numbers. You
can park only one call at each call park extension number.

Set Up Cisco Unified Communications Manager to Support Dial via Office
To set up Cisco Unified Communications Manager to support Dial via Office-Reverse ( DvO-R), perform the
following procedures:

1 Complete one or both of the following procedures.

• Set Up Enterprise Feature Access Number

• Set Up Mobility Profile

2 Complete the Verify Device COP File Version procedure.

3 If necessary, create application dial rules to allow the system to route calls to the Mobile Identity phone
number to the outbound gateway. Ensure that the format of the Mobile Identity phone number matches
the application dial rules.

Set Up Enterprise Feature Access Number
Use this procedure to set up an Enterprise Feature Access Number for all Cisco Jabber calls that are made
using Dial via Office-Reverse.

The Enterprise Feature Access Number is the number that Cisco Unified Communications Manager uses to
call the mobile phone and the dialed number unless a different number is set up in Mobility Profile for this
purpose.

Before You Begin

• Reserve a Direct Inward Dial (DID) number to use as the Enterprise Feature Access Number (EFAN).
This procedure is optional if you already set up a mobility profile.

• Determine the required format for this number. The exact value you choose depends on the phone number
that the gateway passes (for example, 7 digits or 10 digits). The Enterprise Feature Access Number must
be a routable number.
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Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing >Mobility > Enterprise Feature Access Number Configuration.
Step 3 Select Add New.
Step 4 In the Number field, enter the Enterprise Feature Access number.

Enter a DID number that is unique in the system.

To support dialing internationally, you can prepend this number with \+.

Step 5 From theRoute Partition drop-down list, choose the partition of the DID that is required for enterprise feature
access.
This partition is set under System > Service Parameters, in theClusterwide Parameters (System -Mobility)
section, in the Inbound Calling Search Space for Remote Destination setting. This setting points either to
the Inbound Calling Search Space of the Gateway or Trunk, or to the Calling Search Space assigned on the
Phone Configuration window for the device.

If the user sets up the DvOCallback Number with an alternate number, ensure that you set up the trunk Calling
Search Space (CSS) to route to destination of the alternate phone number.

Step 6 In the Description field, enter a description of the Mobility Enterprise Feature Access number.
Step 7 (Optional) Check the Default Enterprise Feature Access Number check box if you want to make this

Enterprise Feature Access number the default for this system.
Step 8 Select Save.

Set Up Mobility Profile
Use this procedure to set up a mobility profile for Cisco Jabber devices. This procedure is optional if you
already set up an Enterprise Feature Access Number.

Mobility profiles allow you to set up the Dial via Office-Reverse settings for a mobile client. After you set
up a mobility profile, you can assign it to a user or to a group of users, such as the users in a region or location.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing >Mobility >Mobility Profile.
Step 3 In theMobility Profile Information section, in the Name field, enter a descriptive name for the mobility

profile.
Step 4 In the Dial via Office-Reverse Callback section, in the Callback Caller ID field, enter the caller ID for the

callback call that the client receives from Cisco Unified Communications Manager.
Step 5 Click Save.
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Verify Device COP File Version
Use the following procedure to verify that you are using the correct device COP file for this release of Cisco
Jabber.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Phone.
Step 3 Click Add New.
Step 4 From the Phone Type drop-down list, choose Cisco Dual Mode for iPhone.
Step 5 From the Phone Type drop-down list, choose Cisco Dual Mode for Android.
Step 6 Click Next.
Step 7 Scroll down to the Product Specific Configuration Layout section, and verify that you can see the Video

Capabilities drop-down list.
If you can see the Video Capabilities drop-down list, the COP file is already installed on your system.

If you cannot see the Video Capabilities drop-down list, locate and download the correct COP file.

Prerequisite for All Clients
• On-premises Deployment

• Cisco Unified Communications Manager 9.x and higher

Set Up Dial via Office

User-controlled voicemail avoidance, which can be used in conjunction with the DvO feature, is available
only on Cisco Unified Communications Manager release 9.0 and later. Timer-controlled voicemail
avoidance is available on Cisco Unified Communications Manager release 6.0 and later.

The DvO feature is not supported when users connect to the corporate network using Expressway for
Mobile and Remote Access.

Important

The DvO feature allows users to initiate Cisco Jabber outgoing calls with their work number using the mobile
voice network for the device.

Cisco Jabber supports DvO-R (DvO-Reverse) calls, which works as follows:

1 User initiates a DvO-R call.

2 The client notifies Cisco Unified Communications Manager to call the mobile phone number.

3 Cisco Unified Communications Manager calls and connects to the mobile phone number.
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4 Cisco Unified Communications Manager calls and connects to the number that the user dialed.

5 Cisco Unified Communications Manager connects the two segments.

6 The user and the called party continue as with an ordinary call.

Incoming calls use either Mobile Connect or the Voice over IP, depending on which Calling Options the user
sets on the client. Dial via Office does not require Mobile Connect to work. However, we recommend that
you enable Mobile Connect to allow the native mobile number to ring when someone calls the work number.
From the Cisco Unified Communications Manager user pages, users can enable and disable Mobile Connect,
and adjust Mobile Connect behavior using settings (for example, the time of day routing and Delay Before
Ringing Timer settings). For information about setting up Mobile Connect, see the Set Up Mobile Connect
topic.

The following table describes the calling methods used for incoming and outgoing calls. The calling method (VoIP, Mobile Connect,
DvO-R, or native cellular call) varies depending on the selected Calling Options and the network connection.

Table 1: Calling Methods used with Calling Options over Different Network Connections

Calling Options

Connection AutoselectMobile Voice NetworkVoice over IP

Incoming: VoIPOutgoing: VoIP

Incoming: Mobile
ConnectOutgoing:DvO-RIncoming:

VoIP
Outgoing:
VoIP

Corporate Wi-Fi

NoncorporateWi-Fi

Incoming: Mobile
Connect

Outgoing: DvO-R
Mobile Network

(3G, 4G)

Outgoing Native Cellular CallPhone Services are
not registered Incoming Mobile Connect

To set up Dial via Office-Reverse (DvO-R), you must do the following:

1 Set up the Cisco Unified Communications Manager to support DvO-R. See the Set Up Cisco Unified
Communications Manager to Support DvO topic for more information.

2 Enable DvO on each Cisco Dual Mode for iPhone device. See the Set Up Dial via Office for Each Device
topic for more information.

3 Enable DvO on each Cisco Dual Mode for Android device. See the Set Up Dial via Office for Each Device
topic for more information.
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Set Up Dial via Office for Each Device
Use the following procedures to set up Dial via Office - Reverse for each TCT device.

Use the following procedures to set up Dial via Office - Reverse for each BOT device.

1 Add a Mobility Identity for each user.

2 Enable Dial via Office on each device.

3 If you enabled Mobile Connect, verify that Mobile Connect works. Dial the desk phone extension and
check that the phone number that is specified in the associated Mobile Identity rings.

Add Mobility Identity

Use this procedure to add a mobility identity to specify the mobile phone number of the mobile device as the
destination number. This destination number is used by features such as Dial via Office or mobile connect.

You can specify only one number when you add a mobility identity. If you want to specify an alternate number
such as a second mobile phone number for a mobile device, you can set up a remote destination. The mobility
identity configuration characteristics are identical to those of the remote destination configuration.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Navigate to the device that you want to configure as follows:

a) Select Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 3 In the Associated Mobility Identity section, select Add a New Mobility Identity.
Step 4 Enter the mobile phone number as the destination number.

You must be able to rout this number to an outbound gateway. Generally, the number is the full E.164 number.

If you enable the Dial via Office— Reverse feature for a user, you must enter a destination number
for the user's mobility identity.

If you enable Dial via Office— Reverse and leave the destination number empty in the mobility
identity:

Note

• The phone service cannot connect if the user selects the Autoselect calling option while using
a mobile data network and VPN.

• The phone service cannot connect if the user selects theMobile Voice Network calling option
on any type of network.

• The logs do not indicate why the phone service cannot connect.

Step 5 Enter the initial values for call timers.
These values ensure that calls are not routed to the mobile service provider voicemail before they ring in the
client on the mobile device. You can adjust these values to work with the end user's mobile network. For more
information, see the online help in Cisco Unified Communications Manager.
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The following is an example of mobility Identity timers' information in Cisco Unified Communications
Manager 9.x.

Suggested Initial ValueSetting

3000Answer Too Soon Timer

20000Answer Too Late Timer

0

This setting does not apply to DvO-R
calls.

Note

Delay Before Ringing Timer

The following is an example of mobility Identity timers' information in Cisco Unified Communications
Manager 10.x.

Suggested Initial ValueSetting

0.0 secondsWait * before ringing this phone when my business
line is dialed.*

3.0 secondsPrevent this call from going straight to this phone's
voicemail by using a time delay of * to detect when
calls go straight to voicemail.*

20.0 secondsStop ringing this phone after * to avoid connecting
to this phone's voicemail.*

Step 6 Do one of the following:

• Cisco Unified Communications Manager release 9 or earlier— Check the Enable Mobile Connect
check box.

• Cisco Unified CommunicationsManager release 10—Check theEnable Single Number Reach check
box.

Step 7 If you are setting up the Dial via Office feature, in the Mobility Profile drop-down list, select one of the
following options.

DescriptionOption

Choose this option if you want users to use the Enterprise Feature Access
Number (EFAN).

Leave blank

Choose the mobility profile that you just created if you want users to use a
mobility profile instead of an EFAN.

Mobility Profile

Step 8 Set up the schedule for routing calls to the mobile number.
Step 9 Select Save.
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Enable Dial via Office on Each Device

Use this procedure to enable Dial via Office on each device.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Navigate to the device that you want to configure as follows:

a) Select Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 3 In the Device Information section, check the Enable Cisco Unified Mobile Communicator check box.
Step 4 In the Protocol Specific Information section, in theRerouting Calling Search Space drop-down list, select

a Calling Search Space (CSS) that can route the call to the DvO callback number.
Step 5 In the Product Specific Configuration Layout section, set the Dial via Office drop-down list to Enabled.
Step 6 Select Save.
Step 7 Select Apply Config.
Step 8 Instruct the user to sign out of the client and then to sign back in again to access the feature.

What to Do Next

Test this feature.

Set Up Mobile Connect
Mobile connect, formerly known as Single Number Reach (SNR), allows the native mobile phone number to
ring when someone calls the work number if:

• Cisco Jabber is not available.
After Cisco Jabber becomes available again and connects to the corporate network, the Cisco Unified
Communications Manager returns to placing VoIP calls rather than using mobile connect.

• The user selects theMobile Voice Network calling option.

• The user selects the Autoselect calling option and the user is outside of the Wi-Fi network.

Procedure

PurposeCommand or Action

Enable Mobile Connect, on page 220Step 1

To configure the mobile device phone number.Add Mobility Identity, on page 217Step 2
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PurposeCommand or Action

To configure an alternate phone number.Add Remote Destination (Optional),
on page 221

Step 3

Test your settings.Step 4 • Exit Cisco Jabber on the mobile device.

• Call the Cisco Jabber extension from another
phone.

• Verify that the native mobile network phone
number rings and that the call connects when
you answer it.

Enable Mobile Connect
Use the following procedure to enable mobile connect for an end user.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Search for and delete any existing remote destination or mobility Identity that is already set up with the mobile

phone number as follows:
a) Select Device > Remote Destination.
b) Search for the destination number.
c) Delete the destination number.

Step 3 Configure the end user for mobile connect as follows:
a) Select User Management > End User.
b) Search for the end user.
c) Select the user id to open the End User Configuration window.
d) In the Mobility Information section, check the Enable Mobility check box.
e) On Cisco Unified Communications Manager Release 9.0 and earlier, specify the Primary User Device.
f) Select Save.

Step 4 Configure the device settings for mobile connect as follows:
a) Navigate to Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.
d) Enter the following information:

InformationSetting

Choose a softkey template that includes theMobility button.

For information about setting up softkey templates, see the related information
in theCisco Unified CommunicationsManager Administration Guide for your
release. This documentation can be found in the maintenance guides list.

Softkey Template
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InformationSetting

Select the user.Mobility User ID

Select the user. The value must match the mobility user ID.Owner User ID

Choose a Rerouting Calling Search Space that includes both of the following:

• The partition of the desk phone extension of the user. This requirement
is used by the system to provide the Dial via Office feature, not for routing
calls.

• A route to the mobile phone number. The route to the mobile phone
number (that is, the Gateway/Trunk partition) must have a higher
preference than the partitions of the enterprise extension that is associated
with the device.

Cisco Jabber allows users to specify a callback number for Dial via
Office-Reverse calls that is different from the mobile phone number
of the device, and the Rerouting Calling Search Space controls which
callback numbers are reachable.

Note

If the user sets up the DvO Callback Number with an alternate number, ensure
that you set up the trunk Calling Search Space (CSS) to route to destination of
the alternate phone number.

Rerouting Calling
Search Space

e) Select Save.

Add Remote Destination (Optional)
Use this procedure to add a remote destination to specify any alternate number as the destination number. The
Mobility Identity configuration characteristics are identical to those of the remote destination configuration.

Alternate numbers can be any type of phone number, such as home phone numbers, conference room numbers,
desk phone numbers, or multiple mobile phone numbers for additional mobile devices. You can add more
than one remote destination.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Navigate to the device that you want to configure as follows:

a) Select Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 3 In the Associated Remote Destinations section, select Add a New Remote Destination.
Step 4 Enter the desired phone number as the Destination Number.
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You must be able to rout the number to an outbound gateway. Generally, the number is the full E.164 number.

Step 5 Enter the initial values for the following call timers:
a) Answer Too Soon Timer—Enter 3000
b) Answer Too Late Timer— Enter 20000
c) Delay Before Ringing Timer—0

This setting does not apply to DvO-R calls.

These values ensure that calls are not routed to the mobile service provider voicemail before they ring in the
client on the mobile device. For more information, see the online help in Cisco Unified Communications
Manager.

Step 6 Do one of the following:

• If you have Cisco Unified Communications Manager Version 9 or earlier, check the Enable Mobile
Connect check box.

• If you have Cisco Unified Communications Manager Version 10, check the Enable Single Number
Reach check box.

Step 7 Set up the schedule for routing calls to the mobile number.
Step 8 Select Save.

Transfer Active VoIP Call to the Mobile Network
Users can transfer an active VoIP call from Cisco Jabber to their mobile phone number on the mobile network.
This feature is useful when a user on a call leaves the Wi-Fi network (for example, leaving the building to
walk out to the car), or if there are voice quality issues over the Wi-Fi network. This Cisco Jabber feature is
called Move to Mobile.

There are two ways to enable this feature. You can also disable it.
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InstructionsDescriptionImplementation
Method

See the Enable Handoff from VoIP to
Mobile Network topic.

The mobile device calls Cisco Unified
Communications Manager using the
mobile network.

This method requires a Direct Inward Dial
(DID) number.

The service provider must deliver the DID
digits exactly as configured. Alternately,
for Cisco IOS gateways with H.323 or SIP
communication to Cisco Unified
Communications Manager, you can use
Cisco IOS to manipulate the inbound
called-party number at the gateway,
presenting the digits to Cisco Unified
Communications Manager exactly as
configured on the handoff DN.

This method does not work for iPod Touch
devices.

Handoff DN

See the Enable Transfer from VoIP to
Mobile Network topic.

Cisco Unified Communications Manager
calls the phone number of the PSTN
mobile service provider for the mobile
device.

Mobility Softkey

Select Disabled for the Transfer to
Mobile Network option in the Product
Specific Configuration Layout section
of the TCT device page.

Select Disabled for the Transfer to
Mobile Network option in the Product
Specific Configuration Layout section
of the BOT device page.

Disable this feature if you do not want to
make it available to users.

None of the above

Enable Handoff from VoIP to Mobile Network
Set up a directory number that Cisco Unified Communications Manager can use to hand off active calls from
VoIP to the mobile network. Match the user's caller ID with the Mobility Identity to ensure that Cisco Unified
CommunicationsManager can recognize the user. Set up the TCT device and mobile device to support handoff
from VoIP to the mobile network.

Set up a directory number that Cisco Unified Communications Manager can use to hand off active calls from
VoIP to the mobile network. Match the user's caller ID with the Mobility Identity to ensure that Cisco Unified
CommunicationsManager can recognize the user. Set up the BOT device andmobile device to support handoff
from VoIP to the mobile network.
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Set Up Handoff DN

Before You Begin

Determine the required values. The values that you choose depend on the phone number that the gateway
passes (for example, seven digits or ten digits).

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing >Mobility > Handoff Configuration.
Step 3 Enter the Handoff Number for the Direct Inward Dial (DID) number that the device uses to hand off a VoIP

call to the mobile network.
The service provider must deliver the DID digits exactly as configured. Alternately, for Cisco IOS gateways
with H.323 or SIP communication to Cisco Unified Communications Manager, you can use Cisco IOS to
manipulate the inbound called-party number at the gateway, presenting the digits to Cisco Unified
Communications Manager exactly as configured on the handoff number.

You cannot use translation patterns or other similar manipulations within Cisco Unified
Communications Manager to match the inbound DID digits to the configured Handoff DN.

Note

Step 4 Select the Route Partition for the handoff DID.
This partition should be present in the Remote Destination inbound Calling Search Space (CSS), which points
to either the Inbound CSS of the Gateway or Trunk, or the Remote Destination CSS.

This feature does not use the remaining options on this page.

Step 5 Select Save.

Match Caller ID with Mobility Identity

To ensure that only authorized phones can initiate outbound calls, calls must originate from a phone that is
set up in the system. To do this, the system attempts to match the caller ID of the requesting phone number
with an existing Mobility Identity. By default, when a device initiates the Handoff feature, the caller ID that
is passed from the gateway to Cisco Unified Communications Manager must exactly match the Mobility
Identity number that you entered for that device.

However, your system may be set up such that these numbers do not match exactly. For example, Mobility
Identity numbers may include a country code while caller ID does not. If so, you must set up the system to
recognize a partial match.

Be sure to account for situations in which the same phone number may exist in different area codes or in
different countries. Also, be aware that service providers can identify calls with a variable number of digits,
which may affect partial matching. For example, local calls may be identified using seven digits (such as 555
0123) while out-of-area calls may be identified using ten digits (such as 408 555 0199).

Before You Begin

Set up the Mobility Identity. See the Add Mobility Identity topic.

To determine whether you need to complete this procedure, perform the following steps. Dial in to the system
from the mobile device and compare the caller ID value with the Destination Number in the Mobility Identity.
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If the numbers do not match, you must perform this procedure. Repeat this procedure for devices that are
issued in all expected locales and area codes.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters.
Step 3 Select the active server.
Step 4 Select the Cisco CallManager (Active) service.
Step 5 Scroll down to the Clusterwide Parameters (System - Mobility) section.
Step 6 SelectMatching Caller ID with Remote Destination and read essential information about this value.
Step 7 Select Partial Match for Matching Caller ID with Remote Destination.
Step 8 Select Number of Digits for Caller ID Partial Match and read the essential requirements for this value.
Step 9 Enter the required number of digits to ensure partial matches.
Step 10 Select Save.

Set Up User and Device Settings for Handoff

Before You Begin

• Set up the user device on the Cisco Unified Communications Manager.

• Set up the user with a Mobility Identity.

Procedure

Step 1 In theCisco Unified CMAdministration interface, go to the TCT Device page, and selectUse Handoff DN
Feature for the Transfer to Mobile Network option.
Do not assign this method for iPod Touch devices. Use the Mobility Softkey method instead.

Step 2 In the Cisco Unified CM Administration interface, go to the BOT Device page, and select Use Handoff
DN Feature for the Transfer to Mobile Network option.

Step 3 On the iOS device, tap Settings > Phone > Show My Caller ID to verify that Caller ID is on.
Step 4 On some Android device and operating system combinations, you can verify that the Caller ID is on. On the

Android device, open the Phone application and tapMenu > Call Settings > Additional settings > Caller
ID > Show Number.

Step 5 Test this feature.
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Enable Transfer from VoIP to Mobile Network

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 For system-level settings, check that the Mobility softkey appears when the phone is in the connected and

on-hook call states.
a) Select Device > Device Settings > Softkey Template.
b) Select the same softkey template that you selected when you configured the device for Mobile Connect.
c) In the Related Links drop-down list at the upper right, select Configure Softkey Layout and select Go.
d) In the call state drop-down list, select the On Hook state and verify that the Mobility key is in the list of

selected softkeys.
e) In the call state drop-down list, select the Connected state and verify that the Mobility key is in the list of

selected softkeys.

Step 3 Navigate to the device that you want to configure as follows:
a) Select Device > Phone.
b) Search for the device that you want to configure.
c) Select the device name to open the Phone Configuration window.

Step 4 For the per-user and per-device settings in Cisco Unified Communications Manager, set the specific device
to use the Mobility softkey when the device transfers calls to the mobile voice network. Ensure that you have
set up both Mobility Identity and Mobile Connect for the mobile device. After the transfer feature is working,
users can enable and disable Mobile Connect at their convenience without affecting the feature.
If the device is an iPod Touch, you can configure a Mobility Identity using an alternate phone number such
as the mobile phone of the user.

a) Select the Owner User ID on the device page.
b) Select theMobility User ID. The value usually matches that of the Owner User ID.
c) In the Product Specific Configuration Layout section, for the Transfer to Mobile Network option, select

Use Mobility Softkey or Use HandoffDN Feature.

Step 5 In the User Locale field, choose English, United States.
Step 6 Select Save.
Step 7 Select Apply Config.
Step 8 Instruct the user to sign out of the client and then to sign back in again to access the feature.

What to Do Next

Test your settings by transferring an active call from VoIP to the mobile network.
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Cisco Jabber for iOS, Android and Windows

Configure Silent Monitoring and Call Recording
You can set up additional audio path functions for devices such as silent monitoring and call recording.

To enable silent monitoring and call recording, you configure Cisco Unified Communications Manager. See
theMonitoring and Recording section of the Cisco Unified Communications Manager Features and Services
Guide for step-by-step instructions.

Notes:

• Cisco Jabber does not provide any interface to initiate silent monitoring or call recording. You must use
the appropriate software to silently monitor or record calls.

• Cisco Jabber does not currently support monitoring notification tone or recording notification tone.

• You can use silent monitoring and call recording functionality only. Cisco Jabber does not support other
functionality such as barging or whisper coaching.

• Youmight need to download and apply a device package to enable monitoring and recording capabilities
on the device, depending on your version of Cisco Unified Communications Manager. Before you start
configuring the server, do the following:

1 Open the Phone Configurationwindow for the device on which you plan to enable silent monitoring
and call recording.

2 Locate the Built In Bridge field.

If the Built In Bridge field is not available on the Phone Configuration window, you should
download and apply the most recent device packages.

Before You Begin

This feature is supported for on-premises deployment and requires Cisco Unified Communications Manager,
Release 8.6.

For Cisco Jabber for iPhone and iPad and Cisco Jabber for Android, this feature is only supported with Cisco
Unified Communications Manager 11.0 or later releases.

Hunt Group
A hunt pilot contains a hunt pilot number and an associated hunt list. Hunt pilots provide flexibility in network
design. They work in conjunction with route filters and hunt lists to direct calls to specific devices and to
include, exclude, or modify specific digit patterns.

A hunt list contains a set of line groups in a specific order. A single line group can appear in multiple hunt
lists. The group call pickup feature and directed call pickup feature do not work with hunt lists.

A line group comprises a group of directory numbers in a specific order. The order controls the progress of
the search for available directory numbers for incoming calls.
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Cisco Unified Communications Manager determines a call that is to be routed through a defined hunt list,
Cisco Unified Communications Manager finds the first available device on the basis of the order of the line
groups that a hunt list defines.

Cisco Unified Communications Manager 9.x and later allows configuring of automatic log out of a hunt
member when there is no answer.

Logout notification

When a user is auto logged out, manually logged out or logged out by the Cisco Unified Communications
Manager administrator a logout notification is displayed.

Line Group
A line group allows you to designate the order in which directory numbers are chosen. Cisco Unified
Communications Manager distributes a call to an idle or available member of a line group based on the call
distribution algorithm and on the Ring No Answer (RNA) Reversion timeout setting.

Users cannot pick up calls to a DN that belongs to a line group by using the directed call pickup feature.

Configure Line Group

Before You Begin

Configure directory numbers.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing > Route/Hunt > Line Group.

The Find and List Line Groups window opens.

Step 3 Select Add New.
The Line Group Configuration window opens.

Step 4 Enter settings in the Line Group Information section as follows:

1 Specify a unique name in the Line Group Name field.

2 Specify number of seconds for RNA Reversion Timeout.

3 Select a Distribution Algorithm to apply to the line group.

Step 5 Enter settings in the Hunt Options section as follows:

• Select a value for No Answer from the drop-down list.

• Select Automatically Logout Hunt Member on No Answer to configure auto logout of the hunt list.

• Select a value for Busy from the drop-down list.

• Select a value for Not Available from the drop-down list.

Step 6 In the Line Group Member Information section, you can do the following:
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Find directory numbers or route partitions to add to the line group.•

• Reorder the directory numbers or route partitions in the line group.

• Remove directory numbers or route partitions from the line group.

Step 7 Select Save.

What to Do Next

Configure a hunt list and add the line group to the hunt list.

Hunt List
A hunt list contains a set of line groups in a specific order. A hunt list associates with one or more hunt pilots
and determines the order in which those line groups are accessed. The order controls the progress of the search
for available directory numbers for incoming calls.

A hunt list comprises a collection of directory numbers as defined by line groups. After Cisco Unified
Communications Manager determines a call that is to be routed through a defined hunt list, Cisco Unified
Communications Manager finds the first available device on the basis of the order of the line group(s) that a
hunt list defines.

The group call pickup feature and directed call pickup feature do not work with hunt lists.

A hunt list can contain only line groups. Each hunt list should have at least one line group. Each line group
includes at least one directory number. A single line group can appear in multiple hunt lists.

Configure Hunt List

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing > Route/Hunt > Hunt List.

The Find and Hunt List Groups window opens.

Step 3 Select Add New.
The Hunt List Configuration window opens.

Step 4 Enter settings in the Hunt List Information section as follows:

1 Specify a unique name in the Name field.

2 Enter a description for the Hunt List.

3 Select a Cisco Unified Communications Manager Group from the drop-down list.

4 The system selects Enable this Hunt List by default for a new hunt list when the hunt list is saved.

5 If this hunt list is to be used for voice mail, select For Voice Mail Usage.
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Step 5 Select Save to add the hunt list.

What to Do Next

Add line groups to the hunt list.

Add Line Group to Hunt List

Before You Begin

You must configure line groups and configure a hunt list.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing > Route/Hunt > Hunt List.

The Find and Hunt List Groups window opens.

Step 3 Locate the hunt list to which you want to add a line group.
Step 4 To add a line group, select Add Line Group.

The Hunt List Detail Configuration window displays.

Step 5 Select a line group from the Line Group drop-down list.
Step 6 To add the line group, select Save.
Step 7 To add additional line groups, repeat Step 4 to Step 6.
Step 8 Select Save.
Step 9 To reset the hunt list, select Reset. When the dialog box appears, select Reset.

Hunt Pilot
A hunt pilot comprises a string of digits (an address) and a set of associated digit manipulations that route
calls to a hunt list. Hunt pilots provide flexibility in network design. They work in conjunction with route
filters and hunt lists to direct calls to specific devices and to include, exclude, or modify specific digit patterns.

For more detailed information on the configuration options for hunt pilots, see the relevant Cisco Unified
Communications Manager documentation.

Configure Hunt Pilot

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Call Routing > Route/Hunt > Hunt Pilot.

The Find and List Hunt Pilots window opens.
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Step 3 Select Add New.
The Hunt Pilot Configuration window opens.

Step 4 Enter the hunt pilot, including numbers and wildcards.
Step 5 Select a hunt list from the Hunt List drop-down list.
Step 6 Enter any additional configurations in theHunt Pilot Configuration window. For more information on hunt

pilot configuration settings, see the relevant Cisco Unified Communications Manager documentation.
Step 7 Select Save.

Cisco Jabber for iOS, Android and Mac

Flexible DSCP Values
Flexible Differentiated Services Code Point (DSCP) lets you the ability to specify different DSCP values to
separate the audio and video streams on the network. You can configure the DSCP values for audio calls,
video calls, audio portion for video calls and audio portion for telepresence calls separately to prioritize the
audio over video streams for better bandwidth management. It protects audio stream degradation by ensuring
that the audio stream is separated from the higher-bandwidth video stream when the network is congested or
the call quality is impacted.

Related Topics

Configure Flexible DSCP Marking and Video Promotion Service Parameters
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C H A P T E R  16
Cisco Jabber Reference Information

• Client Availability, page 233

• Protocol Handlers, page 234

• Define a Port Range on the SIP Profile, page 238

• Set DSCP Values, page 238

Client Availability
Users can define whether their availability reflects their calendar events by setting an option to let others know
they are in a meeting from the Status tab of the Options window from the client. This option synchronizes
events in your calendar with your availability. The client only displays In ameeting availability for supported
integrated calendars.

The client supports using two sources for the In a meeting availability:

Cisco Jabber for mobile clients don't support this meeting integration.Note

• Microsoft Exchange and Cisco Unified CommunicationManager IM and Presence Integration—Applies
to on-premises deployments. The Include Calendar information in my Presence Status field in Cisco
Unified Presence is the same as the In a meeting option in the client. Both fields update the same value
in the Cisco Unified Communication Manager IM and Presence database.

If users set both fields to different values, then the last field that the user sets takes priority. If users
change the value of the Include Calendar information in my Presence Status field while the client
is running, the users must restart the client for those changes to apply.

• Cisco Jabber Client— Applies to on-premises and cloud-based deployments. You must disable Cisco
Unified Communication Manager IM and Presence and Microsoft Exchange integration for the client
to set the In ameeting availability. The client checks if integration between CiscoUnified Communication
Manager IM and Presence and Microsoft Exchange is on or off. The client can only set availability if
integration is off.

The following deployment scenarios describe how availability is created:
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You do not select In a meeting
(according to my calendar)

You select In a meeting (according
to my calendar)

Deployment Scenario

Availability status does not changeCisco Unified Communication
Manager IM and Presence sets
availability status

You enable integration
between Cisco Unified
Communication Manager IM
and Presence and Microsoft
Exchange.

Availability status does not changeClient sets availability statusYou do not enable integration
between Cisco Unified
Communication Manager IM
and Presence and Microsoft
Exchange.

Availability status does not changeClient sets availability statusCloud-based deployments

Additionally, the following table describes availability that is supported differently by each deployment
scenarios:

Availability Enabled by Integrating Cisco Unified
Communication Manager IM and Presence with
Microsoft Exchange

Availability Enabled in the Client

Offline in a meeting availability is supported.Offline in ameeting availability is not supported.

In a meeting availability is not supported for
non-calendar events.

In a meeting availability is supported for
non-calendar events.

Offline in a meeting availability refers to when the user is not logged in to the client but an event
exists in the user's calendar.

Non-calendar events refer to events that do not appear in the user's calendar, such as instant meetings,
Offline, or On a call.

Note

Related Topics

Calendar Integration, on page 202

Protocol Handlers
Cisco Jabber registers the following protocol handlers with the operating system to enable click-to-call or
click-to-IM functionality from web browsers or other applications:

• XMPP:

Starts an instant message and opens a chat window in Cisco Jabber.

• IM:

Starts an instant message and opens a chat window in Cisco Jabber.
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• TEL:
Starts an audio or video call with Cisco Jabber.

TEL is registered by Apple native phone. It cannot be used to cross launch Cisco Jabber
for iPhone and iPad.

Note

• CISCOTEL:
Starts an audio or video call with Cisco Jabber.

• SIP:
Starts an audio or video call with Cisco Jabber.

• CLICKTOCALL
Starts an audio or video call with Cisco Jabber.

Registry Entries for Protocol Handlers
To register as a protocol handler, the client writes to the following locations in theMicrosoftWindows registry:

• HKEY_CLASSES_ROOT\tel\shell\open\command

• HKEY_CLASSES_ROOT\xmpp\shell\open\command

• HKEY_CLASSES_ROOT\im\shell\open\command

In the case where two or more applications register as handlers for the same protocol, the last application to
write to the registry takes precedence. For example, if Cisco Jabber registers as a protocol handler for XMPP:
and then a different application registers as a protocol handler for XMPP:, the other application takes precedence
over Cisco Jabber.

Protocol Handlers on HTML Pages
You can add protocol handlers on HTML pages as part of the href attribute. When users click the hyperlinks
that your HTML pages expose, the client performs the appropriate action for the protocol.

TEL and IM Protocol Handlers

Example of the TEL: and IM: protocol handlers on an HTML page:
<html>
<body>
<a href="TEL:1234">Call 1234</a><br/>
<a href="IM:msmith@domain">Send an instant message to Mary Smith</a>

</body>
</html>

In the preceding example, when users click the hyperlink to call 1234, the client starts an audio call to that
phone number. When users click the hyperlink to send an instant message to Mary Smith, the client opens a
chat window with Mary.
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CISCOTEL and SIP Protocol Handlers

Example of the CISCOTEL and SIP protocol handlers on an HTML page:
<html>
<body>
<a href="CISCOTEL:1234">Call 1234</a><br/>
<a href="SIP:msmith@domain">Call Mary</a><br/>
<a href="CISCOTELCONF:msmith@domain;amckenzi@domain">Weekly conference call</a>

</body>
</html>

In the preceding example, when users click the Call 1234 or Call Mary hyperlinks, the client starts an audio
call to that phone number.

XMPP Protocol Handlers

Example of a group chat using the XMPP: protocol handler on an HTML page:
<html>
<body>
<a href="XMPP:msmith@domain;amckenzi@domain">Create a group chat with Mary Smith and

Adam McKenzie</a>
</body>

</html>

In the preceding example, when users click the hyperlink to create a group chat with Mary Smith and Adam
McKenzie, the client opens a group chat window with Mary and Adam.

Add lists of contacts for the XMPP: and IM: handlers to create group chats. Use a semi-colon to delimit
contacts, as in the following example:
XMPP:user_a@domain.com;user_b@domain.com;user_c@domain.com;user_d@domain.com

Tip

Add Subject Lines and Body Text

You can add subject lines and body text to any of the protocol handlers so that when users click on the hyperlink
to create a person-to-person or group chat, the client opens a chat window with pre-populated subject line and
body text.

Subject and body text can be added in any of the following scenarios:

• Using any supported protocol handler for instant messaging on the client

• For either person-to-person chats or for group chats

• Including a subject and body text, or one or the other

In this example, when users click on the link below it opens a person-to-person chat window with a
pre-populated body text of I.T Desk:
xmpp:msmith@domain?message;subject=I.T.%20Desk

In this example, when users click on the link below it opens a Start Group Chat dialog box with a topic of
I.T Desk, and the input box for the chat window is pre-populated with the text Jabber 10.5 Query:
im:user_a@domain.com;user_b@domain.com;user_c@domain.com?message;subject=I.T%20Desk;body=Jabber%2010.5%20Query
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Protocol Handler Supported Parameters

Cross Launch for Mobile Clients

The Cisco Jabber for mobile clients provide you with the ability to return to a specified application. For
example if you create a ciscotel URI link that dials a number, you can add in the application name as a
parameter and when the call has completed the user is prompted to return to that application.
ciscotel://1234567?CrossLaunchBackSchema=SomeAppSchema&CrossLaunchBackAppName=SomeAppName

• CrossLaunchBackAppName—Users are prompted with the name of an application that Cisco Jabber
cross launches back to when a call ends.

• none (default)—No application in the dialog box.

• app_name—The application name that is displayed in the dialog box.

• CrossLaunchBackSchema—Specifies the schema used when a call is ended.

• none (default)—You stay in Cisco Jabber.

• schema—The schema used to cross launch back the application.

Supported Separators

When creating a URI link for HTML pages, you can use a semi-colon to separate the characters. This is
supported with the SIP, Tel, CiscoTel and ClickToCall protocol handlers. In the following example, the link
will create a conference call with the two numbers:
tel:123;123

The IM protocol supports the semi-colon separator in addition to supporting the comma separator. In the
following example, the link will create a group chat with the two participants:
im:participant1@example.com,participant2@example.com

DTMF Support

Enter DTMF in the IM Window

In the IM window of the client, you can enter a protocol handler including DTMF digits and the client will
create a link that participants can use. The supported protocols are TEL, CISCOTEL, SIP, CLICKTOCALL,
CISCOIM, IM, and XMPP. The supported parameters are numbers or SIP URIs. In the following example,
the dial in number is 1800-123456, the PIN for entry is 5678#, using the TEL URI link this example creates
a meeting link:
tel:1800123456,,,5678#

Enter DTMF in an Active Call

During a call, users can copy and paste DTMF digits into the call window of the client. Users can easily enter
Meeting IDs, Attendee IDs, and PINs from their meetings invite. If you enter alpha numeric strings during
an active call they are interpreted as the corresponding numbers on the keypad.
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Supported DTMF Strings

A DTMF string can contain the following:

• 0 to 9

• #

• *

• Comma—meaning a one second delay (multiple commas are supported)

• a to z, A to Z—These characters are not supported when on an active call.

Invalid DTMF digits are ignored.

Define a Port Range on the SIP Profile
The client uses the port range to send RTP traffic across the network. The client divides the port range equally
and uses the lower half for audio calls and the upper half for video calls. As a result of splitting the port range
for audio media and video media, the client creates identifiable media streams. You can then classify and
prioritize those media streams by setting DSCP values in the IP packet headers.

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select Device > Device Settings > SIP Profile.
Step 3 Find the appropriate SIP profile or create a new SIP profile.

The SIP Profile Configuration window opens.

Step 4 Specify whether you want common or separate port ranges for audio and video. If you are separating your
audio and video port ranges, provide audio and video ports. Specify the port range in the following fields:

• StartMedia Port—Defines the start port for media streams. This field sets the lowest port in the range.

• StopMedia Port—Defines the stop port for media streams. This field sets the highest port in the range.

Step 5 Select Apply Config and then OK.

Set DSCP Values
Set Differentiated Services Code Point (DSCP) values in RTP media packet headers to prioritize Cisco Jabber
traffic as it traverses the network.
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Set DSCP Values on Cisco Unified Communications Manager
You can set DSCP values for audio media and video media on Cisco Unified Communications Manager.
Cisco Jabber can then retrieve the DSCP values from the device configuration and apply them directly to the
IP headers of RTP media packets.

For later operating systems such as Microsoft Windows 7, Microsoft implements a security feature that
prevents applications from setting DSCP values on IP packet headers. For this reason, you should use an
alternate method for marking DSCP values, such as Microsoft Group Policy.

Restriction

For more information on configuring flexible DSCP values, refer to Configure Flexible DSCP Marking and
Video Promotion Service Parameters

Procedure

Step 1 Open the Cisco Unified CM Administration interface.
Step 2 Select System > Service Parameters.

The Service Parameter Configuration window opens.

Step 3 Select the appropriate server and then select the Cisco CallManager service.
Step 4 Locate the Clusterwide Parameters (System - QOS) section.
Step 5 Specify DSCP values as appropriate and then select Save.

Set DSCP Values with Group Policy
If you deploy Cisco Jabber for Windows on a later operating system such as Microsoft Windows 7, you can
use Microsoft Group Policy to apply DSCP values.

Complete the steps in the following Microsoft support article to create a group policy: http://
technet.microsoft.com/en-us/library/cc771283%28v=ws.10%29.aspx

You should create separate policies for audio media and video media with the following attributes:
Signaling PolicyVideo PolicyAudio PolicyAttributes

CiscoJabber.exeCiscoJabber.exeCiscoJabber.exeApplication name

TCPUDPUDPProtocol

5060 for SIP

5061 for secure SIP

Corresponding port
number or range from
the SIP profile on Cisco
Unified
Communications
Manager.

Corresponding port
number or range from
the SIP profile on Cisco
Unified
Communications
Manager.

Port number or range
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Signaling PolicyVideo PolicyAudio PolicyAttributes

243446DSCP value

Set DSCP Values on the Client
For some configurations there is an option to enable differentiated services for calls in the Cisco Jabber for
Mac client.

This option is enabled by default. Cisco recommends not disabling this option unless you are experiencing
issues in the following scenarios:

Important

• You can hear or see other parties, but you cannot be heard or seen

• You are experiencing unexpected Wi-Fi disconnection issues

Disabling differentiated service for calls may degrade voice and video quality.

Procedure

Step 1 Select Jabber > Preferences > Calls > Advanced
Step 2 Select Enable Differentiated Service for Calls.

Set DSCP Values on the Network
You can configure switches and routers to mark DSCP values in the IP headers of RTP media.

To set DSCP values on the network, you must identify the different streams from the client application.

• Media Streams— Because the client uses different port ranges for audio streams and video streams,
you can differentiate audio media and video media based on those port range. Using the default port
ranges in the SIP profile, you should mark media packets as follows:

• Audio media streams in ports from 16384 to 24574 as EF

• Video media streams in ports from 24575 to 32766 as AF41

• Signaling Streams— You can identify signaling between the client and servers based on the various
ports required for SIP, CTI QBE, and XMPP. For example, SIP signaling between Cisco Jabber and
Cisco Unified Communications Manager occurs through port 5060.

You should mark signaling packets as AF31.
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